Announcement

Collapse
No announcement yet.

Quick style Chooser

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Quick style Chooser

    As of yesterday this used to display at the lower left of every page on the forum..
    nothing has changed..
    I checked the admin logs to confirm this..

    I have 3 styles..

    default style..
    dark styles
    and a untouched stock test style..
    as a admin you would see the drop window with all 3 styles in it ..
    as a member you would only see 2 styles..

    today
    noone can see any
    no settings have changed..

    anyone have a idea..
    thanks for any information..
    Attached Files
    Back up back up Back up, thats all the advice I can give.

  • #2
    That is most likely due to a modification.

    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all products (except vB Blog and vB CMS if you are running the Suite.)

    Admin CP -> Plugins & Products -> Manage Products -> Disable

    Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

    Admin CP -> Plugins & Products -> Plugin Manager

    You must do BOTH of those steps in order to disable all non vBulletin Modifications.

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      thanks for your reply
      this is very weird....Suspect File Versions all good..

      anyway I uploaded all the original vb non-image files..

      disabled all products

      the quick style chooser came back...

      but here's the thing..

      I could change it via web site any page..

      I turned the products back on..

      still worked correctly..

      I changed the style via admincp..
      the style changed
      but the quick style chooser was gone again..

      checked the Suspect File Versions
      again .. all still good.

      cleared cache .. still nothing

      so I re uploaded all the files again... anyway

      the style chooser came back..

      this is weird by far..
      as long as I don't change the style via admincp
      the quick style chooser remains..
      Back up back up Back up, thats all the advice I can give.

      Comment


      • #4
        let me correct a couple things

        the style changer stays good till you log into the admincp..
        after uploading all fresh files..

        I narrowed it down to the datastore_cache.php

        once it writes to this..
        the quick style chooser disappears

        disabling $config['Datastore']['class'] = 'vB_Datastore_Filecache'; in the config.php
        everything works..

        once thats enabled again ..

        this problem persists
        Back up back up Back up, thats all the advice I can give.

        Comment


        • #5
          To get that to work, you need to make sure this directory and file is chomd'd to 777:

          ...includes/datastore/datastore_cache.php
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            has been for years ...
            nothing has been done to the board in months...
            that dir and file has always been chmod'd to 777
            Back up back up Back up, thats all the advice I can give.

            Comment


            • #7
              As I understand it, the problem goes away when you disable 'vB_Datastore_Filecache' and reappears when you enable it. Is that correct? If so, then in my experience that is the cause of this issue, unless you have a strange add-on that is interfering with this.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                yes but it has been enabled and writing to the datastore_cache.php
                ..
                when I over wrote the files before it over wrote that file.. in return the style chooser re-appeared
                Back up back up Back up, thats all the advice I can give.

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X