Announcement

Collapse
No announcement yet.

Attachments in the filesystem - Unable to write

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Rightio, just to eliminate it I have removed the open_basedir restrictions and still see exactly the same issue

    I have left open_basedir to "no value" for now.

    Originally posted by Steve Machol View Post
    Yes, if the /tmp directory exists with 1777 permissions and if you edit your php.ini file accordingly.
    But wouldn't the lack of an upload temp dir prevent all uploads from working? If upload_tmp_dir is not set PHP reverts to the default system directory which for me is /tmp and this is writable - which can be seen as other uploads are working.
    Last edited by MrEyes; Sun 14 Nov '10, 8:27am.
    This is a signature, with a picture

    sigpic

    UK Motorbike Forum

    Comment


    • #17
      I checked and your 'upload_tmp_dir' setting is still empty.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #18
        Originally posted by Steve Machol View Post
        I checked and your 'upload_tmp_dir' setting is still empty.
        That last post was after just removing the entries for open_basedir as a potentially easier fix, unfortunately that didn't work.

        I have just tried exactly what was described earlier:

        Set acp to upload in safe mode
        Set the acp upload dir to : /var/www/vhosts/therevcounter.com/httpdocs/tmp
        Set PHP ini upload_tmp_dir to : "/var/www/vhosts/therevcounter.com/httpdocs/tmp"
        Set chmod permissions on "/var/www/vhosts/therevcounter.com/httpdocs/tmp" to 777
        Web server restart

        Unfortunately still no joy, the same error presents.

        p.s. I have returned open_basedir back to what it was when we started.
        This is a signature, with a picture

        sigpic

        UK Motorbike Forum

        Comment


        • #19
          I checked again. Instead of using /tmp you made this your upload_tmp_dir:

          /var/www/vhosts/therevcounter.com/httpdocs/tmp

          Did you chmod that directory to 1777 (not 777)?
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #20
            Originally posted by Steve Machol View Post
            I checked again. Instead of using /tmp you made this your upload_tmp_dir:

            /var/www/vhosts/therevcounter.com/httpdocs/tmp
            Yep, as per:

            Originally posted by Steve Machol View Post
            ......If you placed the tmp directory in the right place, the path to the Safe Mode Temp Directory will be:

            /var/www/vhosts/therevcounter.com/httpdocs/tmp
            I can and will cheerfully change it to something else if I have misunderstood

            Did you chmod that directory to 1777 (not 777)?
            Yes (typo above)

            I know I have said this before, but it is niggling in the background - other uploads to the server are working fine - so I don't think this is a typically write permissions / php config error. Unless of course I have missed the often over looked allow_vb_avatar_upload PHP setting
            Last edited by MrEyes; Sun 14 Nov '10, 9:08am.
            This is a signature, with a picture

            sigpic

            UK Motorbike Forum

            Comment


            • #21
              Fill out a support ticket at:

              http://members.vbulletin.com/members...ontactform.php

              Please include a complete description of the problem and be sure to include the login info to your Admin CP, phpMyAdmin and FTP in the 'Sensitive Data' field.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #22
                Originally posted by Steve Machol View Post
                Fill out a support ticket at:

                http://members.vbulletin.com/members...ontactform.php

                Please include a complete description of the problem and be sure to include the login info to your Admin CP, phpMyAdmin and FTP in the 'Sensitive Data' field.
                Already done, started one yesterday when I started this thread - no replies yet:

                Ticket ID is 1042755

                I have reverted the changes made during the course of this thread (with the exception of disabling safe mode which will remain disabled as this enables CSS saving)
                Last edited by MrEyes; Sun 14 Nov '10, 9:16am.
                This is a signature, with a picture

                sigpic

                UK Motorbike Forum

                Comment


                • #23
                  That is because you stated the issue was resolved last night, then you just replied a couple of hours ago with a new error. I'll take a look at it.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X