Announcement

Collapse
No announcement yet.

Body Background affects Profile Customizing?!?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Body Background affects Profile Customizing?!?

    I use a custom body background image, and now with the new profile customizing it shows the body background all over the profile.

    Page Background, Inactive Module Background, Content Background, and Header Background all have the body background set as there default background image for some reason.

    Any way to change this? Because it looks really bad.

  • #2
    Am I seriously the only one with this problem?

    See screenshot.

    Click image for larger version

Name:	broken_profile.jpg
Views:	1
Size:	80.4 KB
ID:	3680707

    Comment


    • #3
      The real link would help. Also maybe this will help:

      http://www.vbulletin.com/forum/conte...-Profile-Style.

      FWIW I cannot see this with any of the custom profiles on this site. Do you have any add-ons installed?
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        I don't have any plugins installed. I tried to execute: "UPDATE customprofile SET userid = -1 WHERE userid = 1". I don't have a vbulletin prefix thats why theres nothing in front of customprofile, I don't know if that matters. Also whenever I customize my profile and save, if I go to the profile again it will reset back to the broken version even though I changed it.

        Comment


        • #5
          Sorry, I don't follow. Did you follow the instructions in that link? If so, what happened and what is the URL?
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Originally posted by Steve Machol View Post
            Sorry, I don't follow. Did you follow the instructions in that link? If so, what happened and what is the URL?
            I followed the link, and the sql query doesn't do anything. Here's the URL: http://www.ooohemgeee.com/vbtest/mem...1-oooh-em-geee
            Last edited by oooh em geee; Fri 12th Nov '10, 3:15pm.

            Comment


            • #7
              To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

              Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

              [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

              Next, disable all products (except vB Blog and vB CMS if you are running the Suite.)

              Admin CP -> Plugins & Products -> Manage Products -> Disable

              Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

              Admin CP -> Plugins & Products -> Plugin Manager

              You must do BOTH of those steps in order to disable all non vBulletin Modifications.

              Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

              Do you have the same problem?
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Originally posted by Steve Machol View Post
                To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

                Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

                [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

                Next, disable all products (except vB Blog and vB CMS if you are running the Suite.)

                Admin CP -> Plugins & Products -> Manage Products -> Disable

                Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

                Admin CP -> Plugins & Products -> Plugin Manager

                You must do BOTH of those steps in order to disable all non vBulletin Modifications.

                Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

                Do you have the same problem?
                Overwrited all files with original ones.

                Suspect File Versions gave me this:

                ./
                receiver.php File not recognized as part of vBulletin

                ./clientscript/libraries
                DD_belatedPNG_0.0.8a.js File does not contain expected contents

                ./clientscript/yui/history/assets
                blank.html File does not contain expected contents

                ./includes/facebook
                facebook_desktop.php File not recognized as part of vBulletin
                facebook_mobile.php File not recognized as part of vBulletin
                facebookapi_php5_restlib.php File not recognized as part of vBulletin

                ./packages/vbcms/collection/content
                statichtml.php File not recognized as part of vBulletin

                ./packages/vbcms/content
                statichtml.php File not recognized as part of vBulletin

                ./packages/vbcms/item/content
                statichtml.php File not recognized as part of vBulletin

                ./packages/vbcms/item/widget
                sectionnav.php File not recognized as part of vBulletin
                staticbb.php File not recognized as part of vBulletin

                ./packages/vbcms/search/indexcontroller
                statichtml.php File not recognized as part of vBulletin

                ./packages/vbcms/search/result
                statichtml.php File not recognized as part of vBulletin

                ./packages/vbcms/search/searchcontroller
                newstatichtml.php File not recognized as part of vBulletin

                ./packages/vbcms/search/type
                statichtml.php File not recognized as part of vBulletin

                ./packages/vbcms/widget
                sectionnav.php File not recognized as part of vBulletin
                staticbb.php File not recognized as part of vBulletin

                Still same problem.

                I don't have any plugins or products installed.

                I created a new Default style like you said, and cleared my browsers cache and everything. Still same problem. I turned the template changer on if you wanna see it on the Default style.

                Comment


                • #9
                  None of your styles look like the default style, even test. What is the name of the new, unmodified style you created?
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Originally posted by Steve Machol View Post
                    None of your styles look like the default style, even test. What is the name of the new, unmodified style you created?
                    The new unmodified style is called: Default. And all I changed on that is the body_background stylvar so it has a background image, and as you can see changing the body_background and giving it an image breaks the custom profile.

                    Comment


                    • #11
                      Even 'Default' is not the unmodified original vB style. It has been modified. Please create a new style as per the original instructions so we can test this.

                      Also make sure you have uploaded all the original images as well.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        Originally posted by Steve Machol View Post
                        Even 'Default' is not the unmodified original vB style. It has been modified. Please create a new style as per the original instructions so we can test this.

                        Also make sure you have uploaded all the original images as well.
                        I just made a new one. Default is now completely unmodified.

                        Comment


                        • #13
                          It looks fine with the default style: http://www.ooohemgeee.com/vbtest/mem...eee&styleid=11

                          This means that either a modification is at fault, or you did not follow the instructions in post #3.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            Originally posted by Steve Machol View Post
                            It looks fine with the default style: http://www.ooohemgeee.com/vbtest/mem...eee&styleid=11

                            This means that either a modification is at fault, or you did not follow the instructions in post #3.
                            It looks fine now until I change the body_background and give it an image as a background, thats why I started this topic in the first place. Please read the first couple of posts I made. So how do I fix that?

                            Comment


                            • #15
                              Tell me the exact change you are making and I will try this on my unmodified test forum.
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              Related Topics

                              Collapse

                              • Zer0_
                                Background won't set.
                                by Zer0_
                                Greetings! I've encountered a rather urgent issue on my forums. For some odd reason, I change the Background via Style Variable Editor. For some odd reason, the background won't change. Any suggestio...
                                Sat 23rd Sep '17, 6:17pm
                              • DemOnstar
                                Static background image
                                by DemOnstar
                                If I have an image as a background, what do I need to add to css_additionals.css to make everything above the background scroll over the background?

                                Thanks to all...........
                                Fri 10th May '13, 9:35am
                              Working...
                              X