Login issue - vBulletin 4.0.8

Collapse
X
 
  • Time
  • Show
Clear All
new posts
  • ATX78753
    New Member
    • Oct 2010
    • 6
    • 4.0.x

    [Forum] Login issue - vBulletin 4.0.8

    I know this is a small issue but most of us can admit there is a large group of people who do not know anything about the internet and small issues we know how to work around they will not.

    Well the issue I am having is when I go to my forum it is asking me to log in, I have saved log in info with Firefox (also tried in IE with same issue) and clicked the "Remember Me" option. If I click on our logo at the top left it will refresh the page and show that I am logged in. I know this is an issue for other users.

    Has anyone else had this issue? If so, how did you resolve it?
  • Steve Machol
    Former Customer Support Manager
    • Jul 2000
    • 154488

    #2
    This is probably a cookie domain/path issue. To fix this, upload the tools.php script in the 'do_not_upload' folder of the vB zip file to your Admin CP directory and run it from your browser. Use this to reset the cookie domain and path back to the defaults. And then leave your cookie domain and path at the default settings. There is no reason to change these. If you need to specify a unique cookie, use the cookie prefix setting in config.php instead.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment

    • Mathew7000
      New Member
      • Oct 2006
      • 3

      #3
      i've also had this issue since i upgraded to 4.x, it says to log in, i do, says redirecting then puts me back to the log in page saying i need to log in. but then i'll just click on the top left logo and out of the blue i'm logged in. a bunch of users on my forum are having this problem on multiple browsers. i've tried resetting cookies, tried reinstalling 4.x, but nothing has worked so far.

      edit, figured out a little bit, when i type in www.xxxxxxx.com it works fine, but if i just type in http://xxxxxxxxx.com it fails the log in, so i changed the cookie thing to .xxxxxxx.com and now it works but some of the page fails to load until you click or type in www.xxxxxxxxxxxx.com
      none of this happened until i upgraded to 4.0.8
      Last edited by Mathew7000; Sat 30 Oct '10, 10:15pm.

      Comment

      • Steve Machol
        Former Customer Support Manager
        • Jul 2000
        • 154488

        #4
        Previous versions worked the same way. You can also try setting the cookies domain in the Admin CP to:

        .mysite.com

        Note the leading period.

        Admin CP -> Settings -> Options -> Cookies and HTTP Header Option -> Cookie Domain
        Last edited by Steve Machol; Sun 31 Oct '10, 9:04am.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment

        • Octavius
          Senior Member
          • Jul 2010
          • 208
          • 4.2.X

          #5
          I have this same problem but not with my old members, just with people who try to register and sign in.
          www.8thos.com

          Comment

          • Mathew7000
            New Member
            • Oct 2006
            • 3

            #6
            Originally posted by Steve Machol
            Previous versions worked the same way. You can also try setting the cookies domain in the Admin CP to:

            .mysite.com

            Note the leading period.

            Admin CP -> Settings -> Options -> Cookies and HTTP Header Option -> Cookie Domain
            yep, i said that i did that, changed the cookie thing to .xxxxxx.com and it somewhat works now, but only half the site loads correctly until you click on something with www. in it

            Comment

            • Trevor Hannant
              vBulletin Support
              • Aug 2002
              • 24185
              • 5.7.X

              #7
              You would be better to decide which URL version you wish to use then create a redirect using .htaccess to forward all traffic to that one.
              Vote for:

              - Admin Settable Paid Subscription Reminder Timeframe (vB6)
              - Add Admin ability to auto-subscribe users to specific channel(s) (vB6)

              Comment

              • Daniel.P
                Senior Member
                • Apr 2008
                • 600
                • 4.0.x

                #8
                I noticed the problem in 4.0.3.
                Related with this report.

                Priority: Minor Minor???
                I think it is at least major.
                therefore do not work domains, subdomains, WWW, https, etc.
                it is because you always routed to the basic domain.
                all links also, login and etc.
                changed cookie to .xxxxxx.com solve only login problem (eventually).
                vote for it, hopefully at the end is fixed.
                Last edited by Daniel.P; Mon 1 Nov '10, 5:59am.
                born to fish forced to work

                Comment

                • Falcon Capt
                  Senior Member
                  • May 2006
                  • 237
                  • 4.2.x

                  #9
                  Some browsers actually store a site specific cookie in the bookmark (bookmarklet). We had this same problem when we first upgraded from vB3.8.5 to vB4.0.5. The trick was, the users who were having problems needed to delete their old bookmark for our site and create a new one, once they did this the problem went away.

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  😀
                  😂
                  🥰
                  😘
                  🤢
                  😎
                  😞
                  😡
                  👍
                  👎