Announcement

Collapse
No announcement yet.

Issue when going to profile.php?do=editprofile

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Issue when going to profile.php?do=editprofile

    Code:
    Database error in vBulletin 4.0.7:
    
    Invalid SQL:
    ();
    
    MySQL Error   : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1
    Error Number  : 1064
    Request Date  : Monday, October 18th 2010 @ 05:35:38 PM
    Error Date    : Monday, October 18th 2010 @ 05:35:38 PM
    Script        : http://toracademy.com/forums/profile.php?do=editprofile
    Referrer      : http://toracademy.com/forums/member.php?1-Aaron217
    IP Address    : ************
    Username      : Aaron217
    Classname     : ***********
    MySQL Version : 5.0.91
    Any help would be appreciated.

  • #2
    Invalid SQL errors are almost always related to modified code.

    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all products (except vB Blog and vB CMS if you are running the Suite.)

    Admin CP -> Plugins & Products -> Manage Products -> Disable

    Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

    Admin CP -> Plugins & Products -> Plugin Manager

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      It is still giving the error as above.

      Comment


      • #4
        Unfortunately I don't see how that is possible. In addition I can readily see that you have add-ons and a heavily customized style on your site. Please try those instructions again.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          No add-on's besides 1 that powers the "Site's Core" and "vBulletin". I will try those steps again and see if I messed up last time.

          Comment


          • #6
            When we do ask you to disable addons we do mean all of them, at the very least temporarly to test.

            Comment


            • #7
              My developer disabled his product and we tried everything as stated above, however the site is still giving the error. It is very odd because it was working just fine and then just recently started doing this.

              We recently went from using MySQL to MySQLi if that makes any difference.

              Comment


              • #8
                If you have followed all the steps in post #2, then fill out a support ticket at:

                http://members.vbulletin.com/members...ontactform.php

                Please include a complete description of the problem and be sure to include the login info to your Admin CP, phpMyAdmin and FTP in the 'Sensitive Data' field.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  I have found the issue with it, it seems my database has become corrupt and we are moving to a fresh install of vBulletin to fix this.

                  Thanks Steve for your help.

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X