Announcement

Collapse
No announcement yet.

Image resize failed.....

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] Image resize failed.....

    Hi wonder if you can help - seen this raised a couple of times on the Forum, but no fix offered seems to work -

    I've been running the forum www.surftalk.co.uk for about 7 months now, and this problem only occured today:

    I'm trying to add an image to a post, or into a CMS article, using the "Insert Image" icon, then selecting an image from "My Computer". When I upload the image, I get the error,

    "Image resize failed due to inability to obtain image size".


    I've not had this problem before. The image I'm trying to upload is around 100k, and is 600px x 600 px, so it's not a huge file.

    I've tried it on IE and Firefox with same results.
    I've not upgraded my version of vBulletin recently.
    I'm running Image Magick and the server isn't in safe mode.

    I've currently got about 100Mb of images on the site, stored in the database.
    Is there some kind of size limit? Could that be the issue - I can't think what else might have changed.

    If I attach the image using the attachment manager / BB code, it attaches without a problem, but my users are too lazy for that kind of approach!

    Really appreciate any advice!

  • #2
    The attachment statistics show that I'm currently using 87Mb to store 837 attachments. The bar is completely red. Yet I've checked my usergroup permissions (administrator) all set to 0 (no limit).
    So I'm thinking that the problem must be a size limit applied to me as an individual or the website as a whole (100Mb of images across the site).
    Where is the limit imposed from? Is it related to PHP memory limit (100Mb) or is that a coincidence that has nothing to do with this issue?

    Really appreciate some support on this, even if it's a very simple problem that I've overlooked / not understood.

    Comment


    • #3
      Try another image as a test. If that works, load your image into an image program and resave it. Try as a PNG and see if you have the same problem. I've had goofy images on rare occasion.

      Your error is not "over limit".

      Comment


      • #4
        Originally posted by nakedanvil View Post
        Try another image as a test. If that works, load your image into an image program and resave it. Try as a PNG and see if you have the same problem. I've had goofy images on rare occasion.

        Your error is not "over limit".
        Thanks for helping me clarify where the problem doesn't lie! I've tried re-saving the same image as a PNG but get the same error. I've also tried uploading other JPG files (including really tiny file sizes) but get the same error regardless.

        Comment


        • #5
          My attachments are stored in the database rather than the file system. Does this pose a problem if the attachments as a whole take up more than a certain amount of storage?
          I also tried the upload diagnostic which indicated there were no problems.

          Any other suggestions please? I need to upload fresh content on a daily basis and at the moment I'm unable to do this, so it's doing my head in!

          Comment


          • #6
            If I try to attach an image from URL I just get an undefined error.
            If I add an image using the attachment manager, then I have no preview of the image showing on the home page.

            There isn't a work around and I really need some help, there must be someone out there who can offer some advice?

            Comment


            • #7
              Is your server running in Safe Mode?
              Vote for:

              - *Admin Settable Paid Subscription Reminder Timeframe*
              -
              *PM - Add ability to reply to originator only*
              - Add Admin ability to auto-subscribe users to specific channel(s)
              - "Quick Route" Interface...

              Comment


              • #8
                Hi Trevor. No it isn't. Report from the diagnostic below. Thanks, Ad.

                file_uploads:Onopen_basedir:/nfs:/tmp:/usr/local:/etc/apache2/gs-binsafe_mode:Offupload_tmp_dir:Noneupload_max_filesize:2.00 MB
                Help
                Results No errors occurred while opening the uploaded file for reading.

                Comment


                • #9
                  You have open_basedir restrictions on your server. Try creating a 'tmp' subdirectory under your main hosting directory and chmod it to 777. Then in the Admin CP set "Upload In Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to that directory.

                  Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Safe Mode Temporary Directory

                  Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Safe Mode Upload Enabled -> Yes

                  Also the php.ini setting for 'upload_tmp_dir' may be empty. It's possible you (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd to 1777. You will also need to restart Apache after making this change.
                  Vote for:

                  - *Admin Settable Paid Subscription Reminder Timeframe*
                  -
                  *PM - Add ability to reply to originator only*
                  - Add Admin ability to auto-subscribe users to specific channel(s)
                  - "Quick Route" Interface...

                  Comment


                  • #10
                    Trevor - firstly thanks for taking the time to help me solve the problem.

                    Secondly - in case anyone else here is hosted on the Grid / Cluster Service on Media Temple, it may be worthwhile being aware of some recent changes - PHP has been upgraded to 5.2.14 and the Suhosin hardening patches have been enabled.

                    I assume it was the hardening patches that required the changes outlined by Trevor in order to maintain functionality.

                    All working again now

                    Comment

                    Related Topics

                    Collapse

                    Working...
                    X