Announcement

Collapse
No announcement yet.

Login Box still shows after login

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Login Box still shows after login

    We are using 4.0.7... Alot of our users complain that after logging in, the login box still shows after a successful login. Only after clicking on a forum (or anything else for that matter) does it show that they are logged in at the top, and display the notifications, and "my profile", etc...

    Any suggestions?

  • #2
    We have the same Problem. After login the login field is still displayed but if u change to another Side u are looged in

    Comment


    • #3
      We're having the very same problem. Has a solution ever been found??

      Also, we're using the lite version of the VB Optimise mod for VB 4. Could this be part of the issue?
      Fantasy Writing Forum - Mythic Scribes

      Comment


      • #4
        I have not experienced this issue on 4.0.8 on my own site, nor on 4.1.0 or 4.1.1 running on here.

        Create a new style with no parent and test using this (you'll have to set it as the default style for testing purposes so it's used for guests).

        If this doesn't fix it...
        Disable all plugins and see if it still occurs.
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.6.0 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #5
          Hi Mark,

          That's for the advice. It was useful in helping me to pinpoint the problem.
          Fantasy Writing Forum - Mythic Scribes

          Comment


          • #6
            Problem Solved!

            It looks like the problem has been solved. After five hours of trial and error I was able to pinpoint the source of the issue - an htaccess file in the root directory!

            My "forums" directory is under my root directory, which is powered by Wordpress. The Wordpress htaccess file had some of the following lines added to it by the W3 Total Cache plugin:

            Code:
            ExpiresActive On
            ExpiresDefault A1800
            To correct this, I created a new htaccess file in the "forums" subdirectory, which reads as follows:

            Code:
            # Turn on Expires and set default to 0
            ExpiresActive On
            ExpiresDefault A0
            
            # Force no caching for dynamic files
            <FilesMatch "\.(php|cgi|pl|htm|html)$">
            ExpiresActive Off
            Header set Cache-Control "private, no-cache, no-store, proxy-revalidate, no-transform"
            Header set Pragma "no-cache"
            </FilesMatch>
            After a couple of hours of testing, this appears to have completely solved the problem.

            I hope that someone else will find this solution to be helpful.
            Fantasy Writing Forum - Mythic Scribes

            Comment

            Related Topics

            Collapse

            Working...
            X