Announcement

Collapse
No announcement yet.

Removing 'Sub-Forums:' text from forum index / Moving sub-forums below threads

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lynne
    replied
    Glad it's working now.
    Originally posted by WeMovie.co.uk View Post
    Looks like I can't use that modification if I don't want the text to show.
    Or look at the code and take the phrase out of it. (You may be able to ask in the modification thread for how to do this.)

    Leave a comment:


  • WeMovie.co.uk
    replied
    Oh my days - It's working!
    I don't know why it didn't happen before but I just edited all 4 templates again and it's totally worked. Thankyou so much Lynne for all your help.

    Edit:
    I just realised why it wasn't working before...
    I just enabled 'Sorky Sub-Forum List Control' and even though I removed the phrase from the templates, the Sub-Forums: text was still displaying. I disabled the mod and the text disappeared. Looks like I can't use that modification if I don't want the text to show.

    Leave a comment:


  • WeMovie.co.uk
    replied
    Did you edit the templates for your particular style that you are using? If you removed the phrase from all the templates for the style you are using to view your site, then it should not be showing up any longer.
    I edited it out of all 4 templates and the Sub-Forums: text was still showing. And yes I edited the template that the forum is using.

    I just looked at your site and I do not see Sub-Forums on your forum page any longer. Perhaps you didn't clear your browser cache after making the change.
    I'm using the VSa - Sub Forum Manager mod which has an option to hide the Sub-Forums: text. However it isn't ideal as this mod doesn't give as much flexibility as the other Sub-Forum Manager I was using.

    Leave a comment:


  • Lynne
    replied
    Most browsers will give you the page source if you go to View > Page Source or apple-key + U, probably control + U on a PC?

    Did you edit the templates for your particular style that you are using? If you removed the phrase from all the templates for the style you are using to view your site, then it should not be showing up any longer.

    I just looked at your site and I do not see Sub-Forums on your forum page any longer. Perhaps you didn't clear your browser cache after making the change.

    Leave a comment:


  • WeMovie.co.uk
    replied
    I'm sorry but I don't understand what any of this means.
    I don't understand how to view the page source. I've tried searching for <h4 class="subforumlistlabel">{vb:rawphrase subforums}:</h4> in the templates and I found 4 templates using that phrase so I removed it from all 4 templates and it did nothing. The Sub-Forums: text still displays on the forum home.
    I give up.
    Thanks for trying.
    Last edited by WeMovie.co.uk; Sat 25 Sep '10, 11:29am.

    Leave a comment:


  • Lynne
    replied
    Originally posted by WeMovie.co.uk View Post
    And I don't understand the template thing you mentioned. I set it to yes but I don't get what I'm supposed to do after this...
    It doesn't change anything on the forums...
    You need to look in the page source. If you do that, you will see the template names listed in there.

    Then, when you find the template, remove the actual phrase from the template. This part:
    <h4 class="subforumlistlabel">{vb:rawphrase subforums}:</h4>

    Leave a comment:


  • TheLastSuperman
    replied
    Originally posted by WeMovie.co.uk View Post
    That's what I did. But I can't just delete the phrase because if I do it re-appears, as it seems you can't leave a phrase blank.
    If I delete the phrase and then just leave it as a space, then the : symbol is still there. How do I delete this symbol?
    Then simply uses <!-- Hiding STYLEVARNAME --> that way it has content saved yet it's still invisible...

    Originally posted by WeMovie.co.uk View Post
    And I don't understand the template thing you mentioned. I set it to yes but I don't get what I'm supposed to do after this...
    It doesn't change anything on the forums...
    In the case of threads: 123 Posts: 123 you could be editing the wrong template, remember there are post and no post templates to the forumhome templates your trying to edit.

    Leave a comment:


  • WeMovie.co.uk
    replied
    And I don't understand the template thing you mentioned. I set it to yes but I don't get what I'm supposed to do after this...
    It doesn't change anything on the forums...

    Leave a comment:


  • WeMovie.co.uk
    replied
    That's what I did. But I can't just delete the phrase because if I do it re-appears, as it seems you can't leave a phrase blank.
    If I delete the phrase and then just leave it as a space, then the : symbol is still there. How do I delete this symbol?

    Leave a comment:


  • Lynne
    replied
    Just delete the use of the phrase from the template then. I posted instructions on how to find the template, then just go in and remove the phrase.

    Leave a comment:


  • WeMovie.co.uk
    replied
    OK So I found what I need to change in order to get rid of the Sub-Forums: text.
    The varname is $vbphrase[subforums] but I can't save it with no text because otherwise it just goes back to displaying Sub-Forums: and if I just create a space and save it then it still displays the : which appears after the text. How can I remove this?

    Should I delete the varname $vbphrase[subforums] altogether??? If so, how? I don't even know if that's possible.
    Last edited by WeMovie.co.uk; Fri 24 Sep '10, 11:33am.

    Leave a comment:


  • WeMovie.co.uk
    replied
    Searching for the phrase Sub-Forums: gives me the following:

    Use this option to display deep subforums as text links in the parent's forum description area.<br /><br />

    For example, if your forums are setup like this:<br /><br />

    parent<br />
    --child<br />
    ----child's child<br /><br />

    And your forum depth is set to 2 and this setting is set to 3 then you will see the first two forums displayed "fully" on the forum homepage while the level 3 "child's child" forum will appear within the "child" forum's description:<br /><br />

    parent<br />
    --child<br />
    &nbsp;&nbsp;<i>child forum's description.</i><br />
    &nbsp;&nbsp;<b>Sub-Forums:</b> child's child


    I copied the above into the text box but I removed Sub-Forums: and it did nothing.

    Leave a comment:


  • Lynne
    replied
    It's just a phrase. Do a Search in Phrases for it and change it to be blank (or whatever). Or, just edit the template to remove it.

    To find the template to modify, do this - vboptions > General Settings > Add Template Name in HTML Comments > set to Yes . Then go back to your page and view the source code and you will see the name of the template called around your part of the code. (Sometimes the template is the one mentioned at the very top of the page source.)

    Leave a comment:


  • Removing 'Sub-Forums:' text from forum index / Moving sub-forums below threads

    Hi there

    I have acouple of problems which I need to fix.

    I've Googled my question several times but it never provides an answer that fixes my problem.

    I want to remove the Sub-Forums: text from my forum index.
    If you visit my forums (http://www.wemovie.co.uk) you'll see why.
    The text is overlapping the forum name and it looks very messy.

    I also want to move all sub-forums below the thread list.
    If you visit here (http://www.wemovie.co.uk/forum/forum...php?91-Actors&) you can see that all the sub-forums listed A - Z are above the thread list and you have to scroll down quite alot before you can see the threads in that forum.

    Thanks in advance for any help you can provide.

    ~ WeMovie.co.uk
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X