Announcement

Collapse
No announcement yet.

Imported system, shows ' for apostrophes!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Imported system, shows ' for apostrophes!

    Hi peeps, can anyone help with this?

    I have imported from my SMF 2 and all the threads now look pretty screwy. Any advice for this?

    ' shows up where apostrophes should be. Example:

    [quote author=Jer link=topic=1118.msg46798#msg46798 date=1284059913]
    Well, so far today I've called him an idiot, a moron, a lyin' piece of rubbish, and made fun of him for being from Florida. Nothing yet.
    [/quote]

  • #2
    Originally posted by Threepwud View Post
    Hi peeps, can anyone help with this?

    I have imported from my SMF 2 and all the threads now look pretty screwy. Any advice for this?

    ' shows up where apostrophes should be. Example:

    [quote author=Jer link=topic=1118.msg46798#msg46798 date=1284059913]
    Well, so far today I've called him an idiot, a moron, a lyin' piece of rubbish, and made fun of him for being from Florida. Nothing yet.

    Try my mod. It does just that.

    http://www.vbulletin.org/forum/showthread.php?t=239234

    Comment


    • #3
      Please delete post

      Comment


      • #4
        Database error in vBulletin 4.0.6:
        Invalid SQL:
        UPDATE thppost
        SET pagetext = replace(pagetext, 'I'', ''');
        MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '''')' at line 2
        Error Number : 1064
        Request Date : Saturday, September 11th 2010 @ 12:34:43 PM
        Error Date : Saturday, September 11th 2010 @ 12:34:43 PM
        Script : http://www.threepwud.com/vb/showthre...ndings?p=46049
        Referrer : http://www.threepwud.com/vb/forum.php
        IP Address : 94.170.240.143
        Username : Threepwud
        Classname : vB_Database
        MySQL Version : 5.1.41


        That's the error I now get using your mod! heh...! Any advice?

        Comment


        • #5
          Originally posted by Threepwud View Post
          Database error in vBulletin 4.0.6:
          Invalid SQL:
          UPDATE thppost
          SET pagetext = replace(pagetext, 'I'', ''');
          MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '''')' at line 2
          Error Number : 1064
          Request Date : Saturday, September 11th 2010 @ 12:34:43 PM
          Error Date : Saturday, September 11th 2010 @ 12:34:43 PM
          Script : http://www.threepwud.com/vb/showthre...ndings?p=46049
          Referrer : http://www.threepwud.com/vb/forum.php
          IP Address : 94.170.240.143
          Username : Threepwud
          Classname : vB_Database
          MySQL Version : 5.1.41


          That's the error I now get using your mod! heh...! Any advice?
          It looks like you are not entering the text correct. I replied to your post at my mod thread. Let us keep it there, as per the rules all the mod/theme/coding questions should be posted over at vb.org

          Comment


          • #6
            Alright - thanks mate. If anyone else has any fix for this other than borbole's nice mod then please include below.

            Kind regards,

            Comment


            • #7
              Originally posted by Threepwud View Post
              Alright - thanks mate. If anyone else has any fix for this other than borbole's nice mod then please include below.

              Kind regards,
              You can do that with this query as well.

              Code:
              UPDATE post 
                      SET pagetext = replace(pagetext, 'text_to_be_replaced', 'replacement_text');
              And change 'text_to_be_replaced', 'replacement_text' accordingly.

              But with my mod it can be done from the confort of the Acp.

              You had the error first time because you didn''t escape the single quote character with a backslash. I posted the right way to do it at my mod''s thread. It will work. I tested it at my test forum as well and it worked fine.

              Comment


              • #8
                Update. I see from your post at my mod''s thread that you solved it after running the Update Counter.

                http://www.vbulletin.org/forum/showt...=239234&page=2

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X