Announcement

Collapse
No announcement yet.

vBulletin CMS Can't Configure Widgets

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • LOGECT
    replied
    Still can't configure widgets!

    Leave a comment:


  • LOGECT
    replied
    I've the same problem, can't modify widgets after upgrading to 4.2.2.
    Last edited by LOGECT; Fri 14 Mar '14, 12:41am.

    Leave a comment:


  • raywjohnson
    replied
    I have verified that the problem is the url. If your Site Name / URL / Contact Details says http://example.com and you login via http://www.example.com., you will have this problem. I suspect is has to do with cookies/cookie path.

    I just added the following to my htaccess to force a "no www." url. See: How to remove www from your URL with mod_rewrite

    RewriteCond %{HTTP_HOST} ^www.example.com$ [NC]
    RewriteRule ^(.*)$ http://example.com/$1 [R=301,L]

    Leave a comment:


  • twinscentric
    replied
    FWIW, I was able to get past this with something similar. In the setting in admincp, under "Site Name / URL / Contact Details" I had http://www.twinsdaily.com in the Forum URL field but I didn't have the "www" in several other fields. I got rid of the "www." and now the configure links work fine.

    Leave a comment:


  • Miss T
    replied
    Originally posted by digitalpoint View Post
    I had the same issue, and it turned out it was because I had a CMS URL specified in the settings. Check your vBulletin settings under "Content Management" and see if you have "CMS URL" set to something other than blank (the default).

    The problem is the Configure link is actually an AJAX request, and AJAX can't make requests to domains (or sub-domains) other than the domain it was started from. Since I had the CMS URL set to http://articles.digitalpoint.com, the underlying AJAX request was going to http://articles.digitalpoint.com/widget.php, which is illegal (as far as AJAX is concerned) since the AJAX request started from http://forums.digitalpoint.com

    It's related to this bug report: http://tracker.vbulletin.com/browse/VBIV-6332

    Ideally the vB_Route::getCurrentURL() method should not be forcing an absolute URL when it's using the call to build a URL for an AJAX request (maybe it needs a $aboslute_url = true) option in the function or something.

    As a work-around, open up your admincp/cms_admin.php file, way down at the bottom, change this line:
    PHP Code:
    $config_url vB_Route::create('vBCms_Route_Widget''config/' $widget->getID() . '/0')->getCurrentURL(); 
    to this:
    PHP Code:
    $config_url str_replace(vB::$vbulletin->options['vbcms_url'], ''vB_Route::create('vBCms_Route_Widget''config/' $widget->getID() . '/0')->getCurrentURL()); 
    That will just strip whatever you have set in your CMS URL from the AJAX request URL.
    tiny problem...

    my code doest say

    PHP Code:
    $config_url vB_Route::create('vBCms_Route_Widget''config/' $widget->getID() . '/0')->getCurrentURL(); 
    it says

    PHP Code:
    $config_url vBCms_Route_Widget::getUrl(array('action' =>'config' ,'widget' => $widget->getID()), nulltrue); 

    is that the same and can i still change it... i have the same problem with the configuration


    EDIT: i tried it - and it didnt make a difference... i still cant configure widgets and i have no idea where to find the htacces - i know i have seen it before... but havent a clue where
    Last edited by Miss T; Sat 17 Sep '11, 10:57pm.

    Leave a comment:


  • billstelling
    replied
    hey guys, went though the same problem and it was an add on mod called all in one that was doing it. if you have that installed you will need to get rid of it. if you don't then you need to disable each mod you have one at a time and then check to see if the configure will work and then move on the the next until you find the one causing it. Once i figured out the one causing it on my site I was able to configure widgets. Keep in mind that I have allot of mods installed and it was not a quick task to do,
    Also you need to make sure that you have everything configured correctly in your options as well as adding the line to the htaccess file.
    Click image for larger version

Name:	site.jpg
Views:	2
Size:	87.4 KB
ID:	3682228
    Code:
    RewriteRule ^widget/config/([0-9]+) widget.php?r=config/$1&%{QUERY_STRING}

    Leave a comment:


  • Wayne Luke
    replied
    You need to open your own threads for help with your specific problems.

    Leave a comment:


  • barroca
    replied
    Unable do configure widgets! Same issue here
    And not a fix

    Leave a comment:


  • The Rocketeer
    replied
    having the same pathetic problem

    Leave a comment:


  • galerio
    replied
    I have just modified some js files that contain
    Code:
    asyncRequest("POST", "some_file.php"
    and that are loaded in blog section and now Ajax seems to work.

    But ... my forum home is in a subdirectory "site.com/forum" and there are some ajax requests that are now for php files from root, for example:

    site.com/ajax.php?do=editorswitch

    and should be:

    site.com/forum/ajax.php?do=editorswitch

    The example above refers to the "Switch Editor Mode" to post comments on blog or to post in forum! So I have to put an htaccess rule in the root htaccess (not the forum's one):

    Code:
    RewriteRule ^ajax.php(.*) forum/ajax.php$1 [L]
    and in this way it works. Hoping the rewrite rule is ok, I'm not an expert.
    Last edited by galerio; Sun 17 Apr '11, 9:39am.

    Leave a comment:


  • galerio
    replied
    Thank you digitalpoint, but I have not enough skills to understand how to put the solution.

    For exmple, in a js there is the line
    Code:
        YAHOO.util.Connect.asyncRequest("POST", "threadtag.php?contenttype=" + this.contenttype + "&contentid=" + this.contentid, {
    and I have to change to:

    Code:
     YAHOO.util.Connect.asyncRequest("POST", window.location.protocol + "//" + window.location.hostname + "/threadtag.php?contenttype=" + this.contenttype + "&contentid=" + this.contentid, {
    with a slash before threadtag.php.

    But when the line is:

    Code:
    YAHOO.util.Connect.asyncRequest("POST", form.action, {
    or
    Code:
    YAHOO.util.Connect.asyncRequest("POST", 'online.php?do=resolveip&ipaddress=' + PHP.urlencode(this.ip), {
    or
    Code:
    YAHOO.util.Connect.asyncRequest("POST", desturl, { success: this.callback }, datastream + "&securitytoken=" + SECURITYTOKEN + "&s=" + fetch_sessionhash());
    or
    Code:
    YAHOO.util.Connect.asyncRequest("POST", this.vars.ajaxtarget + "?do=" + this.vars.ajaxaction + "&" + this.vars.objecttype + "=" + this.objectid, {
    what should I do?
    I counted about 53 js files with asyncRequest, and in the most of them it is simple to make the change... but there are others too complicated for me.

    Is there someone that has already changed all js and want to share with us?

    Leave a comment:


  • digitalpoint
    replied
    Originally posted by galerio View Post
    Can someone tell me what and where I have to change the code in order to make ajax works on every subdomain?
    http://tracker.vbulletin.com/browse/VBIV-6332

    Leave a comment:


  • galerio
    replied
    It seems that developer team doesn't wont to resolve this issue soon.

    Can someone help me to make ajax works on blog and profile page?

    I have this situation: every user has it's own subdomain for profile page and blog. For example:

    username.site.com (user's profile page)
    username.site.com/blog (user's blog homepage)
    and my website is on www.site.com/forum.

    Can someone tell me what and where I have to change the code in order to make ajax works on every subdomain?

    Thank you.

    Leave a comment:


  • lingstar
    replied
    Alas, this doesn't work for me. I have apparently the same scenario and made sure that the CMS URL is blank in my installation. Tried the .htaccess and the replacement code too....help?

    Leave a comment:


  • JimF
    replied
    Thank you, digitalpoint. Worked perfectly.

    Leave a comment:

Related Topics

Collapse

Working...
X