Announcement

Collapse
No announcement yet.

Problem with domains with and without WWW

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • exyuteam
    replied
    Originally posted by Ace View Post
    If you want people to be able to login at either www- or non-www, set your cookie to .domain.com (not domain.com).
    Yeah, I know.... I wrote "if I set Cookie Domain to my domain, (instead of default setting (blank)), user can use forum, but some plugins still have a problem to working well.... ", so it's not problem with cookies....


    Originally posted by Ace View Post
    Base Path talks about link consistency, and has nothing to do with cookies as far as I can tell. Now you are talking about cookies.
    That is the problem - link consistency! Did you read my first message? Maybe I not explain right? From domain.com, forum redirect to www.domain.com/login.php and after successful login goes to domain.com/forum.php. Do you see where is a problem here and what I try to explain?
    SHOULD BE: domain.com -> domain.com/login.php -> domain.com/forum.php (right? )

    Originally posted by Ace View Post
    Which one is your issue actually with?
    Like thread name say.... I don't have problem with cookies - yet.... and everything will be OK when this problem with link consistency been fixed...

    Leave a comment:


  • Zachery
    replied
    Originally posted by Ace View Post
    If you want people to be able to login at either www- or non-www, set your cookie to .domain.com (not domain.com).

    Base Path talks about link consistency, and has nothing to do with cookies as far as I can tell. Now you are talking about cookies.

    Which one is your issue actually with?
    It makes a small issue, since if you didnt redirect to the bburl you'd stay logged in.

    Leave a comment:


  • Ace
    replied
    If you want people to be able to login at either www- or non-www, set your cookie to .domain.com (not domain.com).

    Base Path talks about link consistency, and has nothing to do with cookies as far as I can tell. Now you are talking about cookies.

    Which one is your issue actually with?

    Leave a comment:


  • exyuteam
    replied
    Originally posted by Zachery View Post
    It isn't a new bug, the cookie issue isn't new, just more prevelant now. You need to choose www. or non www.
    Hmmmm, is this an official response or just your opinion? Let's see.... In AdminCP -> Settings -> Options -> Site name / URL / Contact details we have option: Always use Forum URL as Base Path - Right?

    Now, let it be like that we don't know what that means, so we read explanation for that:
    If this is set to 'Yes' the Forum URL will always be used for links instead of the current URL. This ensures that links are consistent but may not be desirable if you use multiple domains or a mix of http and https.

    OK. I use multiple domains or I want to use mix HTTP and HTTPS, and I don't want that, so I choose NO (like suggested). On ver. 3.xx this is working like a charm, and here I think some of pages have this bug and ignore this option (login.php are always use Base Path).

    Why I need it, it's not question.... This not working like it should be - that is issue. Right?

    For now, if I set Cookie Domain to my domain, (instead of default setting (blank)), user can use forum, but some plugins still have a problem to working well....

    So, please check this..... Thanks in advance...

    Leave a comment:


  • Ace
    replied
    Originally posted by exyuteam View Post
    We all have our reasons... We have option ("Always use Forum URL as Base Path") and it's not working like it should! For all who want to rewrite URL to base path, they should put this option to YES, but what we can do? Nothing. If we set it to NO, we have mixing URL's....
    Yeah, it is working like it should, you just don't understand what it's for, despite it quite clearly stating "but may not be desirable if you use multiple domains".

    www and non-www ARE multiple domains. You HAVE to use htaccess (or similar) rules to fix it. Everyone else does.

    Leave a comment:


  • Zachery
    replied
    It isn't a new bug, the cookie issue isn't new, just more prevelant now. You need to choose www. or non www.

    Leave a comment:


  • exyuteam
    replied
    We all have our reasons... We have option ("Always use Forum URL as Base Path") and it's not working like it should! For all who want to rewrite URL to base path, they should put this option to YES, but what we can do? Nothing. If we set it to NO, we have mixing URL's....

    Please fix this.....

    Leave a comment:


  • Ace
    replied
    Why do you want both www. and non-www.?

    Having both means that any Search Engine linkage could be to one or the other, diluting your link power by 50%.

    Leave a comment:


  • camani
    replied
    This is a problem when setting the cms home to root and the forum in the forum directory. I followed all the instructions for that here http://www.vbulletin.com/forum/conte...n-subdirectory which works.

    BUT the link on my navbar for "home" does not include www? I put everything in with an absolute url, including the www, but the link on the nav tab for home does NOT include the www. I used a htaccess redirect to take care of it, but I don't like it. The links should be correct. I don't know what other setting to change. All the other links on the navbar include the www. Odd.

    Leave a comment:


  • exyuteam
    replied
    Like daniel_pet said - seem taht this IS a BUG, but it seems that vB stuff don't find it important....

    My settings:
    "Forum URL" - set with WWW
    "Always use Forum URL as Base Path" - NO
    (If this is set to 'Yes' the Forum URL will always be used for links instead of the current URL. This ensures that links are consistent but may not be desirable if you use multiple domains or a mix of http and https.)

    Option exsist! I set it like I want to be, but it's not working well....

    Leave a comment:


  • Daniel.P
    replied
    no matter what's on
    "Always use Forum URL as Base Path"

    http://tracker.vbulletin.com/browse/VBIV-7195

    Leave a comment:


  • alexp999
    replied
    Go to your AdminCP > Settings > Site Name / URL / Contact Details

    What do you have set for "Forum URL" and "Always use Forum URL as Base Path"?

    Leave a comment:


  • exyuteam
    replied
    Originally posted by Andy View Post
    You really should use .htaccess to change http://www.domain.com/login.php to http://domain.com/login.php
    That's not solve problem, because all of users who use WWW will have a same problem....


    @Zachery
    That's not a point. Why I must decide are ALL of my users MUST use with or without WWW? Why this is hard for you to make that all of links "read" entered domain ($_SERVER['SERVER_NAME']; or 'HTTP_HOST' or.... anything else....)?

    This IS WORKING on old versions vB, and now "I need to chose"? Just tell me WHY???

    Leave a comment:


  • Zachery
    replied
    Choose one or the other and stick with it be it: www. or non www.

    Leave a comment:


  • Andy
    replied
    You really should use .htaccess to change http://www.domain.com/login.php to http://domain.com/login.php

    Leave a comment:

Related Topics

Collapse

Working...
X