Announcement

Collapse
No announcement yet.

Error 403 with Photo Uploading

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Error 403 with Photo Uploading

    Hi all.

    My users are having trouble uploading photos to accompany a post.

    [FYI: I have done the maintenance test and have come back with no errors with uploading attachments.]

    They click on the little paperclip, select a photo and you get a little red circle with a ! in it. When you hover, the error is something like this:

    Error 403 [IO ErrorEventType="IO error" bubbles=false canceleable=falseeventPhase=2 text= "Error 2038"

    What the heck is this? Please respond back as if I'm a total noob with clear direction.

    Thanks in advance.

  • #2
    Do you have mod_securoty/mod_security2 running on your server?
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - "Quick Route" Interface...

    Comment


    • #3
      Okay, here's how I solved the problem.

      First of all, I read all the threads here related to uploading photos, and nothing really helped. I worked with my host company who have a phenomenal tech staf (shout out to U2-webs!).

      Anyway, it had nothing to do with the servers, and they said they could disable the mod security, but that it would obviously leave me open for attacks. I was not about to do that.

      Here's what I did and it worked for me. Not sure if it will help someone else, but here goes.

      1) In admin CP-->Settings-->Options-->Message Attachment Options. In the Limit Space Taken Up By Attachments (Total), I put in 0 (since I started having a problem with uploading photos due to size, but put the largest figure here you feel comfy with).

      2) Next, in the same area scroll down to Asset Manager - Enable and select the Yes, AJAX UPLOAD BY DEFAULT.

      Now, when users want to upload a photo or attachment to their forum post, they have to go to the Advanced Mode when posting. If they hit the little paperclip icon, the basic upload box pops up and they can upload their photos from the desktop. Previously, I had mine set to Flash Upload (instead of AJAX upload), and it just wouldn't work. My users kept getting upload errors.

      That solved my problem as a circumvent. I hope this helps someone else.

      Now, Vbulletin should really fix the main problem in that the Flash Uploader does not work properly. I find it disheartening that the common reply is to disable security mod for so many common issues. I refuse to weaken or remove security on my forum and suffer a potential hack or put my user's personal info at risk. My host is continually surprised (and tired), and that continual comments that it's a server host error. Particularly when it comes to 403 errors/Forbidden. I was plagued with 403 Forbidden issues last month, and this is what my host said:

      "This really isn't a proper way to do things -- to push the responsibility for their software maintenance onto the hosting provider when the issue originates within their code and needs to be resolved there, especially from a security and code QA standpoint."

      Comment


      • #4
        I've been having the exact same problem, started when I upgraded to 4.0.5 from 4.0.3. I changed it like you said and I will let you know if it works.

        Thanks!

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X