Announcement

Collapse
No announcement yet.

Site suddenly calling for phrasegroups that are missing from DB

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Site suddenly calling for phrasegroups that are missing from DB

    I have a problem I'm hoping someone can help with. It appears it happened when I uninstalled an old vb3 mod that had been disabled in vb4. It completely crashed our site, and the database errors were all something like this:

    Unknown column 'language.phrasegroup_global' in 'field list'

    Which column was missing from the language table depends on what page I'm on. I've added the tables back to get the site running, but since they're blank I now have no labels for anything.

    Anyone know of a way to address this short of a db backup?

  • #2
    Update -- I'm trying to use tools.php (on vb 4.0.3) and I'm getting a Invalid SQL error. Is there a new version of tools.php -- or a bug fix for the language import for 4.0?

    Comment


    • #3
      I would recommend upgrading vb to vb 4.0.5 that will hopefully solve your issue. I am however assuming you do not want to reinstall the mod or have a db backup

      Update:where are you placing tools.php in the admincp right?

      Comment


      • #4
        Make sure you delete any bitfield xml files that came with the mod.
        vBulletin - Sometimes, I'm just like, Wow, and then I'm like, Whoa, and then I'm like, Damn.

        vBulletin.org's ol' Moderator

        I have a lifetime terrorist hunting permit - #091101

        chmod a+x /bin/laden -- Allows anyone the permission to execute /bin/laden

        Comment


        • #5
          Thanks for the tips -- I tried upgrading to 4.0.5 (the suspect plugin had no bitfield file) but I'm getting the exact same error when it hit the finalupdate.php script that I got with tools.php:

          Invalid SQL:
          UPDATE vb3_language SET title = title, phrasegroup_global = 'a:778:{.... etc....etc....

          Comment


          • #6
            Got it -- my max packet size was set at 1MB, and that was what the SQL Error was. Thanks for the assist guys!

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X