Announcement

Collapse
No announcement yet.

Database error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] Database error

    I am now getting database errors on the CMS. Here is the error:

    Code:
    Database error in vBulletin 4.0.4:
     
    Invalid SQL:
    SELECT MAX(permissions & 1) AS perm FROM cms_permissions
          WHERE nodeid = 1 AND usergroupid in ();
     
    MySQL Error   : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 2
    Error Number  : 1064
    Request Date  : Monday, June 28th 2010 @ 05:00:04 AM
    Error Date    : Monday, June 28th 2010 @ 05:00:19 AM
    Script        : http:///
    Referrer      : 
    IP Address    : 
    Username      : 
    Classname     : vB_Database
    MySQL Version :
    I am getting it every hour? I checked the function.php and it shows:
    Code:
    $sql = "SELECT MAX(permissions & 1) AS perm FROM " . TABLE_PREFIX . "cms_permissions
     WHERE nodeid = 1 AND usergroupid in (" . $vbulletin->userinfo['usergroupid'] .
     ($vbulletin->userinfo['membergroupids'] != '' ? ', ' . $vbulletin->userinfo['membergroupids'] : '' ) . ")";
    Does anyone have a clue what is going on?

    Thanks if you can help..
    Last edited by Trevor Hannant; Mon 28 Jun '10, 5:51am.
    Thanks,
    Slinger

    Tandy Services
    Chamber Theory ~Your Locked Up Thoughts~

  • #2
    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - "Quick Route" Interface...

    Comment


    • #3
      I think it is a mod. Thanks
      Thanks,
      Slinger

      Tandy Services
      Chamber Theory ~Your Locked Up Thoughts~

      Comment


      • #4
        Ok I think I figured it out.. I have random album pic on the CMS. But in my usergroups I did not let guest see the album pic.. I now let them and I don't get the database error?
        Thanks,
        Slinger

        Tandy Services
        Chamber Theory ~Your Locked Up Thoughts~

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X