Announcement

Collapse
No announcement yet.

Page rendering fast but browser "Transferring data from"... For 10 seconds more

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    At the time of my post, from Japan, IE7/8 & FF3.6.3 -- no delay at the end of loading.

    Are you on shared or dedicated hosting?
    To be updated...

    Comment


    • #17
      DecNetPHase4: please start a new thread on this as in may / may not be related. A new thread makes this easier to sort out and is the way to go according to site rules here. If you post a link in the new thread I will take a look if your problem apears to be the same.

      Comment


      • #18
        Dedicated server. See first post.

        There was some major link outing yesterday but that was totally unrelated to the delay on the server. I even get this delay on a browser running on the server.

        The pages load in a snap but some do not finish (stop showing the progress bar etc) until about 15seconds later. See my post nr 2. Tried IE8, FF, Linux, XP, local net, outside net. Consistent.

        The BLOG is a good example now
        http://www.41hz.com/forums/blog.php

        I removed the forum blocks as a temporary solution which make the forum pages behave better. However, that made the problem move to the thread view level, for example here:
        http://www.41hz.com/forums/forumdisp...AMP32-AMP32-PS

        FF Page Speed does NOT catch the problem. But site visitors complain because the browser indicates the pages are still loading. Some script running in the background?

        Click image for larger version

Name:	PS.png
Views:	1
Size:	44.4 KB
ID:	3679504
        Attached Files
        Last edited by janaf; Mon 21st Jun '10, 2:41am.

        Comment


        • #19
          The blog page consistently completes loading at ~15secs.

          I can't identify what the hold-up is either...
          To be updated...

          Comment


          • #20
            Not solved. After the 4.0.4 install, the site download time has skyrocketed according to Google Webmaster tools, from typically 0.3s to 4 seconds.

            Click image for larger version

Name:	chart.png
Views:	1
Size:	8.4 KB
ID:	3679514

            I need help. What can I do? How can I debug? My LAMP experience is limited.

            Should I post a bug report?

            Should I do a clean install and restore the db on top of that?
            Last edited by janaf; Tue 22nd Jun '10, 2:40am.

            Comment


            • #21
              I am having the same problem as janaf, some forums on my site are loading for 10 sec and longer after the update from 4.0.3 to 4.0.4
              any suggestions how to fix it?

              Comment


              • #22
                I have posted a support ticket to vB but they say they see nothing unusual on my site, but say my net is slow. However I even have the same problem browsing from the local net of the server.

                I insist that these pages (and several others) are consistenty not finished loading (hourglass, progress bar..) until after about 15 seconds:

                http://www.41hz.com/forums/blog.php
                http://www.41hz.com/forums/forumdisp...47-Latest-News

                But these (and several others) consistently loading in typically 1 second or so:

                http://www.41hz.com/forums/content.php
                http://www.41hz.com/forums/content.php?208

                Can others confirm this?

                Mbain, please post or PM your URL so I can take a look if yours behaves the same as mine. Or compare to my site and confirm here if the your problem is the same.

                Comment


                • #23
                  Getting closer

                  The problem seems directy related to the apache KeepAliveTimeout which I had set to 15s.
                  If I change it, the problem changes the same.

                  Can i set this timeout short, something like 2 s, or will visitors on slow connections get timeout errors then?
                  pages are usually finished in 0.3s or less by the server.

                  I also have the option of turning KeepAlive Off. Would that have drawbacks?

                  Edit: I have now disabled all Ajax and turned KeepAlive Off.

                  Pages now load in a snap! But without Ajax...
                  Last edited by janaf; Thu 24th Jun '10, 10:17am.

                  Comment


                  • #24
                    Why disable ajax?

                    Comment


                    • #25
                      Because a vB support person told me so. But I have now enabled it again and it seems to work. But I keepAlive off.

                      Comment


                      • #26
                        Originally posted by Zachery View Post
                        Why disable ajax?
                        Some more relevant questions;



                        It took a friend with LAMP knowledge, zero vB experience, about two minutes on an overseas connection
                        • read my problem description,
                        • confirm it was relevant
                        • suggest a cause; an unterminated script call
                        • point out where to start looking; search for timeout settings in the config scripts
                        so why no real help from vB for five days?

                        What side effects do trunig KeepAlive off have? (I really do not know at all)

                        What (script) is running that is unterminated? (Beyond my debugging skills)

                        Do you also have the problem on your site? I see elsewhere that you recommend a KeepAliveTimeout of 3s. If you have that setting on your own sites; maybe the symtom is not seen because of his?

                        Comment


                        • #27
                          Well whatever you did it seems to be loading quickly, at least for me.
                          vB4 SuperCharged
                          http://www.gamingmasters.co.uk

                          Comment


                          • #28
                            Originally posted by Darkimmortal View Post
                            Well whatever you did it seems to be loading quickly, at least for me.
                            All I did: Apache KeepAlive = Off

                            Comment


                            • #29
                              Keep alive Content-Length problem

                              We have recently upgraded to vbulletin 4.0.4 and have noticed the same long page load problem.

                              After some investigation we have discovered that the Content-Length header is incorrect. When you have output gzipping disabled and allow apache to gzip the data, then setting the content length becomes wrong.

                              In vbulletin 4.0.3 and below the Conent-Length header only gets set if vbulletin has gzipped the data.

                              The workaround is (for vbulletin 4.0.4) to change line 6866 of includes/functions.php from:
                              PHP Code:
                                              if ($sendheader
                              To:
                              PHP Code:
                                              if ($sendheader AND $vbulletin->donegzip
                              Zingzam
                              Smarter online communities. Smarter you.

                              Comment


                              • #30
                                My research into this problem leads me to believe that the problem is caused by a bug in mod_fastcgi. It handles the content-length field incorrectly with in turn causes mod_deflate to not overwrite it like it should. We changed the code to set the content-length on all cases to avoid some other bugs that occur when the content-length is not set. The details can be found at http://tracker.vbulletin.com/browse/VBIV-8268.

                                Comment

                                Related Topics

                                Collapse

                                Working...
                                X