Announcement

Collapse
No announcement yet.

"Sorry, you do not have permission to access this page." after upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] "Sorry, you do not have permission to access this page." after upgrade

    It seems that after I upgraded to v4.0.4 from 4.0.3, some of my forum categories no longer work. I have checked the permissions and they seem fine but they give me no-perm errors when not logged in.

    For example, visiting http://atheistdiscussion.com/vbcms-c...on-peace-5162/ gives me the message "Sorry, you do not have permission to access this page." and when I view the vbcms-comments section located here: http://atheistdiscussion.com/vbcms-comments-33/ it says "Invalid Forum specified. If you followed a valid link, please notify the administrator". When I'm logged in, it works fine though.

    Any suggestions?

  • #2
    No suggestions yet - same thing here though.

    Comment


    • #3
      Originally posted by fogjuice View Post
      It seems that after I upgraded to v4.0.4 from 4.0.3, some of my forum categories no longer work. I have checked the permissions and they seem fine but they give me no-perm errors when not logged in.

      For example, visiting http://atheistdiscussion.com/vbcms-c...on-peace-5162/ gives me the message "Sorry, you do not have permission to access this page." and when I view the vbcms-comments section located here: http://atheistdiscussion.com/vbcms-comments-33/ it says "Invalid Forum specified. If you followed a valid link, please notify the administrator". When I'm logged in, it works fine though.

      Any suggestions?
      I have the same problem ...

      Comment


      • #4
        I think this was done intentionally to "force" using the CMS for comments.

        showthread.php:
        Code:
        // CMS comment threads
        if ($thread['forumid'] == $vbulletin->options['vbcmsforumid'] AND !can_moderate($thread['forumid']))
        {
        	eval(standard_error(fetch_error('invalid_comment_forum', $vbphrase['forum'], $vbulletin->options['contactuslink'])));
        }
        forumdisplay.php:
        Code:
        // Don't allow access to anything below if an invalid $forumid was specified
        // Also, don't allow access to the CMS comment forum unless user is a moderator
        cache_moderators();
        if (!$foruminfo['forumid'] OR ($foruminfo['forumid'] == $vbulletin->options['vbcmsforumid'] AND !can_moderate($foruminfo['forumid'])))
        {
        	eval(standard_error(fetch_error('invalidid', $vbphrase['forum'], $vbulletin->options['contactuslink'])));
        }

        Comment


        • #5
          well then they should have 1. excluded the comments from the whats new search ... so now I have people clicking get the error 2 . should have let us know so we could have let our community know the change .....

          Comment


          • #6
            Wow, another reason to use this mod......

            http://www.vbulletin.org/forum/showt...=230417&page=4

            too bad I can't figure out how to get it to work in 4.0.4

            Comment


            • #7
              hello? I can't believe there is still no solution to that yet!!!

              Comment


              • #8
                Ah, thanks for the bump.

                I can confirm the mod, http://www.vbulletin.org/forum/showt...=230417&page=4

                DOES work, and there is a bug report that needs to be voted on so the kind folks at IB fix it.....

                Vote early, and vote often.

                http://tracker.vbulletin.com/browse/VBIV-952

                Comment


                • #9
                  Hey, this is now the third most popular requested fix!

                  Now, I wonder if the folks at IB ever look at that metric?

                  http://tracker.vbulletin.com/browse/...arissues-panel

                  Comment


                  • #10
                    any way i can change those permissions? As admin i can view those posts but my members can't...

                    Comment


                    • #11
                      I am also getting this error since upgrading to 4.0.4. When registered members try and follow the link to the new Article from the Forum sidebar they get No permission message and cannot even get into the vBCms Comments forum. It works for an Administrator

                      Comment


                      • #12
                        I posted a FAQ this morning , 7-08-10, that would have answered your question, but I guess vbulletin didn't like it. It has been deleted.



                        I would suggest that you use the search to find your answer looking for one of my posts, but ah, you wouldn't be able to find anything, because search doesn't work when you use it with member name, unless, of course you know the super secret, methodology...........


                        Search Doesn't work properly, unless you do this.....

                        http://www.vbulletin.com/forum/showt...ghlight=search



                        Your answer about CMS permission errors is in this thread...... along with how to unfix the fix


                        http://www.vbulletin.com/forum/showt...ight=%2ACMS%2A

                        How to separate CMS directory from your forum directory (I don't know if it works, I'm just providing the link)

                        http://www.vbulletin.com/forum/showt...ight=%2Acms%2A






                        Since vbulletin doesn't want this info in a FAQ, I guess, I'll just keep copying and pasting this post for you folks...........





                        This post can now be found in the following threads.......



                        http://www.vbulletin.com/forum/showt...comments-forum



                        http://www.vbulletin.com/forum/showt...ghlight=search



                        http://www.vbulletin.com/forum/showt...by-member-name


                        http://www.vbulletin.com/forum/showt...dit-an-article

                        http://www.vbulletin.com/forum/showt...66#post2006566

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X