Announcement

Collapse
No announcement yet.

VBCMS Comments

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    I understand all of this thread and pleased to see others have this issue but I want my members to have this feature back. I am getting nailed on this as they are used to something. You really can't give something to someone like this and just yank it out from under them. It isn't right nor fair. Now if they never had this feature then yea this would of been okay. I am not mad or anything just wanting a fix. I am hoping that what was posted above is true and can we get a php file for both to overwrite the current.? There should just be a setting in the admin panel to allow or not I think. This way you have the best of both worlds as I know users were wanting this feature to post only on the CMS page. So I beg of you Devs to please post the 2 altered php files to overcome this so some of us can have this feature back. Yes I went and redid all the permissions to no avail.

    Comment


    • #17
      Originally posted by Charlie_Brown View Post
      I understand all of this thread and pleased to see others have this issue but I want my members to have this feature back. I am getting nailed on this as they are used to something. You really can't give something to someone like this and just yank it out from under them. It isn't right nor fair. Now if they never had this feature then yea this would of been okay. I am not mad or anything just wanting a fix. I am hoping that what was posted above is true and can we get a php file for both to overwrite the current.? There should just be a setting in the admin panel to allow or not I think. This way you have the best of both worlds as I know users were wanting this feature to post only on the CMS page. So I beg of you Devs to please post the 2 altered php files to overcome this so some of us can have this feature back. Yes I went and redid all the permissions to no avail.
      I agree. It is extremely frustrating that you left this in for 3 revisions and then yanked it on the fourth. Everyone on my forum uses it now and you've frustrated a lot of my users. Please release a PHP file so we can put it back and next release create an on off switch in the forum settings.

      *edit* I've just fixed it myself based on what Mystics said:

      Comment out line 317 to 320 in showthread.php.
      PHP Code:
      //if ($thread['forumid'] == $vbulletin->options['vbcmsforumid'] AND !can_moderate($thread['forumid']))
      //{
          //eval(standard_error(fetch_error('invalid_comment_forum', $vbphrase['forum'], $vbulletin->options['contactuslink'])));
      //} 
      Now open forumdisplay.php, scroll down to line 138.

      Replace the following
      PHP Code:
      if (!$foruminfo['forumid'] OR ($foruminfo['forumid'] == $vbulletin->options['vbcmsforumid'] AND !can_moderate($foruminfo['forumid']))) 
      with this:
      PHP Code:
      //if (!$foruminfo['forumid'] OR ($foruminfo['forumid'] == $vbulletin->options['vbcmsforumid'] AND !can_moderate($foruminfo['forumid'])))
      if (!$foruminfo['forumid']) 
      You will have to do this if you upgrade your forum again or when ever you replace the showthread.php and forumdisplay.php files. Hopefully next release vbulletin team creates an on/off switch for this.
      Last edited by fogjuice; Sat 19th Jun '10, 12:08pm.

      Comment


      • #18
        I prefer the way that they've done it now but the only problem is the threads still show up in the whats new etc. It seems its only half implemented.

        Comment


        • #19
          Originally posted by akia View Post
          I prefer the way that they've done it now but the only problem is the threads still show up in the whats new etc. It seems its only half implemented.
          Turn the permissions off in forum permissions and turn of search indexing for vbcms comments and that should stop it from showing up, I think.

          Comment


          • #20
            Thats sorted it I think

            Comment


            • #21
              Thanks fogjuice waiting to hear from my users if this edit worked.

              Comment


              • #22
                Yes it works! I think they need to incorporate a setting in the options settings of the admin panel to allow or not then we won't need to go through and do this manual edit.

                Comment


                • #23
                  Yeah, I am having the identical issue. As an Admin, I can see the links fine, but all of the non-admins are reporting the same no permissions error.

                  The permissions are set correctly.

                  http://www.comixtreme.com

                  I have to admit - this issue confuses me a little bit. It sounds to me like in 4.0.4 - an attempt was made to remove Article Comments from appearing in What's New? I can't figure out why this would be considered a good idea. I would think you would want your users to view comments on articles in this fashion....

                  Comment


                  • #24
                    Correct I know I want this feature to remain as it was. I already did the edit needed to make my users happy again. Worst part this thing wasn't mentioned in the release notes that is what scares me.

                    Originally posted by Craig Reade View Post
                    Yeah, I am having the identical issue. As an Admin, I can see the links fine, but all of the non-admins are reporting the same no permissions error.

                    The permissions are set correctly.

                    http://www.comixtreme.com

                    I have to admit - this issue confuses me a little bit. It sounds to me like in 4.0.4 - an attempt was made to remove Article Comments from appearing in What's New? I can't figure out why this would be considered a good idea. I would think you would want your users to view comments on articles in this fashion....

                    Comment


                    • #25
                      Originally posted by Charlie_Brown View Post
                      Correct I know I want this feature to remain as it was. I already did the edit needed to make my users happy again. Worst part this thing wasn't mentioned in the release notes that is what scares me.
                      I would like the option to use it or not ... and I agree 100% that it wasn't mentioned in the release notes and that's a huge issue and shows a possible breakdown in release and change management process.

                      I am going to try and do the edits mentioned above because I am getting countless PM and pings on the error

                      Comment


                      • #26
                        Originally posted by Sfitzgerald View Post
                        I would like the option to use it or not ... and I agree 100% that it wasn't mentioned in the release notes and that's a huge issue and shows a possible breakdown in release and change management process.

                        I am going to try and do the edits mentioned above because I am getting countless PM and pings on the error
                        I want the option to turn off or on as well at least. The edits do work so you know.

                        Comment


                        • #27
                          Oh, I just submitted a ticket for this, I guess I wasnt alone.

                          Terrible, terrible bug. My users are complaining about this, they've grown to like the vbcms forum.

                          I'll try the edit mentioned above, but I hope this is fixed soon, even with a patch.

                          Comment


                          • #28
                            Well it looks like vb offically can't win! People complained about the comments showing up in the forum so they come up with a solutions and fix it and now people complain that they don't show up.

                            Only thing I'd complain about is the fact that the threads were still showing up in the search.

                            Comment


                            • #29
                              Originally posted by akia View Post
                              Well it looks like vb offically can't win! People complained about the comments showing up in the forum so they come up with a solutions and fix it and now people complain that they don't show up.

                              Only thing I'd complain about is the fact that the threads were still showing up in the search.
                              I'm all in favor of being reasonable and constructive in criticism (you will never see me Flame the developpers because I don't like a feature)

                              But removing easy access to those comments isn't a solution - it's just taking it away. And doing so halfway, so that the posts are still showing up as new, but you can't view them. If they want to change the way the comments are stored and displayed, that's fine, but they still need a mechanism so that users can quickly and easily see what articles have new comments via the What's New...

                              Even if you have no problems with the idea behind this change, there is still something physically broken here that needs to be fixed. You should never have a situation where users are able to click something that returns a no permission message....

                              Comment


                              • #30
                                I never flamed either I was just asking for a fix. Also note I suggested this be a feature to enable or disable. Then gave constructive criticism on the not releasing this info in the release notes. Never once did I complain.

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X