Announcement

Collapse
No announcement yet.

weird error when adding new post / new thread:

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] weird error when adding new post / new thread:

    weird error when adding new post / new thread:
    Warning: array_key_exists() [function.array-key-exists]: The second argument should be either an array or an object in [path]/packages/vbdbsearch/indexer.php on line 69

    Warning: array_key_exists() [function.array-key-exists]: The second argument should be either an array or an object in [path]/packages/vbdbsearch/indexer.php on line 75

    Warning: Cannot modify header information - headers already sent by (output started at [path]/includes/class_core.php:4517) in [path]/includes/functions.php on line 4935

  • #2
    Try disabling your modifications/plugins and see if you still have this problem.
    Note: To temporarily disable the plugin system, edit includes/config.php and add this line right under <?php

    PHP Code:
    define('DISABLE_HOOKS'true); 

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools &lt;- awesome site for html/css help

    Comment


    • #3
      I'm getting the first two errors since upgrading to 4.0.4

      Disabling plugins seems to have solved the problem but I don't know which is causing the problem yet as I've quite a few installed.

      Can anyone give a hint to what might be causing it based on the code on lines 69 & 71 indexer.php

      Comment


      • #4
        <double post glitch>

        Comment


        • #5
          Would like to know which modification it is as well. Running into the same error. Does it damage something?

          Comment


          • #6
            Probably the easiest way is if we all list our products and see if there's a common denominator.

            Currently I have the following products enabled (but many others disabled):

            • Easy Forms
            • JJs Piwik tracking code integration
            • Tabs en vBulletin 4.x
            • vbStopForumSpam
            • vBulletin CMS
            • VSa - PayPal Donate

            Comment


            • #7
              I have the same bug, and It seems to be caused by this mod: Use original Thread for comments
              When I disable this mod, it's OK. I posted a comment at vB.org to inform the mod's coder.
              It only appears in advanced mode, not in quick replies.

              Comment


              • #8
                I have that mod installed but disabled - I haven't seen the error since disabling it so that's probably the cause for me as well.

                Comment


                • #9
                  Any ways to solve it as this mod is awesome.

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X