Announcement

Collapse
No announcement yet.

Facebook Connect

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] Facebook Connect

    After i test to connect my account with facebook but i get this error:


    Sorry, that facebook user does not match what we have on record.

    Click image for larger version

Name:	Bildschirmfoto 2010-06-18 um 11.46.17.png
Views:	1
Size:	18.9 KB
ID:	3718019

    can anyone help?

    thanks

  • #2
    Had a user of my forum report the same issue. I wasn't able to duplicate it myself.

    Comment


    • #3
      I got the same problem here. I don't know how to fix that.
      Attached Files

      Comment


      • #4
        I've just tried changing the "Enable Auto-Register" setting to "no" in Admin CP > Facebook Settings. That's just on a hunch that that's the cause of the problem that was reported.

        Comment


        • #5
          Probably there are also some troubles in fb's site. Creating a new app will result in a blank page, but later on the application is in the list. But you can't upload pictures and so on. Maybe the fb/developers is not the right place to get startet there? Since there is only a poor documentation from vbulletin I have no idea how to get that feature to work.

          Comment


          • #6
            Is there another suggestion on how to fix this? I can connect my Facebook account just fine here, but on my own forum I get the same message as the original poster. Other users on my forum can connect.

            Comment


            • #7
              Dump your browser cache, along with active logins.
              usercp Settings > Edit Connections > ensure you are not connected.
              Try a different browser
              Logout of your facebook account and back in.

              It just does some stupid things at times, and it gets down to the petty stuff in order to solve the issue.

              Private fields and forced private fields are also an issue with integration.

              Comment


              • #8
                I would suggest double checking that the Facebook Secret key is correct. I was having a similar issue on my board, and when I reentered the information from scratch, it worked.

                It seemed like the Secret changed. You might be experiencing something similar.

                Comment


                • #9
                  I re-entered the secret key; I cleared all my cookies, passwords, etc. from my browser; I tried IE, Firefox, and Chrome; I looked in the User CP connections area; and I even temporarily took myself off the list of unalterable users in the vB configuration. I have still not been able to use Facebook Connect, though. Should I open a support ticket?

                  Again, it works for other users, but not for me.

                  Comment


                  • #10
                    I also tested everything. That damn thing won't work. I have no idea what's wrong. Also the connect window asking for connect permission looks complete different as here at this board. Could it be, that vbulletin uses some different applications or facebook files as it is delivered to the customers? I gonna open a ticket now. Got grey hair cause of this.

                    Comment


                    • #11
                      Any updates on this from anyone?

                      Comment


                      • #12
                        The problem is a difference in facebook's userids



                        On the left is the correct id used in the URL "Hallo, Stephan Pogo....."
                        The one on the right....no idea where this is from.
                        this is my sig

                        Comment


                        • #13
                          Well, I figured out why I was getting the message. It seems at some point in time I signed up for a Facebook account with another e-mail address. Facebook insists that I log in with that e-mail address or it won't let my forum account connect. I bet if I try logging in to Facebook on a different computer, the problem will be solved.

                          Of couse, Facebook won't let me transfer that e-mail to my new account, even though I never used the old one. Why can't we delete accounts with zero friends, or at least merge two accounts?
                          Last edited by TNL_Nick; Tue 22 Jun '10, 7:04pm.

                          Comment


                          • #14
                            No. Facebook INSISTS on using the old account that I didn't send or accept a single friend request on. As Pogo pointed out above, it appears to know who I am and appears to be ready to make the connection, but then it just doesn't follow through. I was able to make the link only when I logged in to Facebook with the bad profile.

                            I even went back and forth between the old and new Facebook pages, ultimately assigning the old e-mail address to the new Facebook account. But that didn't work either, since vBulletin was still calling the old FB ID.

                            This is assinine. Somehow I got it to offer to overwrite the old connection, but when I pressed the button to make it so, it just wouldn't do it.

                            Comment


                            • #15
                              There is a bug report for this http://tracker.vbulletin.com/browse/VBIV-6919, and the problem has to do with a rounding error in Facebook's Graph API with certain versions of PHP. We are investigating this currently. Please check the bug report for any further updates.

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X