Announcement

Collapse
No announcement yet.

Database Error 1064 - UPDATE searchlog

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Database Error 1064 - UPDATE searchlog

    Hello! After upgrading to 4.0.3 following error message is displayed from time to time. All messages have UPDATE searchlog in common. Do you have any suggestions why it is happening with my database and how to fix it?

    Code:
     
    Database error in vBulletin 4.0.3:
    Invalid SQL:
       UPDATE searchlog
       SET searchtime = 0,01,
        completed = 1
       WHERE searchlogid = 4757;
    MySQL Error   : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '01,
        completed = 1
       WHERE searchlogid = 4757' at line 2
    Error Number  : 1064
    Request Date  : Wednesday, June 16th 2010 @ 03:31:16 AM
    Error Date    : Wednesday, June 16th 2010 @ 03:31:16 AM
    Script        : [URL]http://rallysim.gamenavigator.ru/forum/[/URL]
    Referrer      : 
    IP Address    : 
    Username      : 
    Classname     : vB_Database
    MySQL Version : 5.1.30-log
    Thank you.

  • #2
    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - "Quick Route" Interface...

    Comment


    • #3
      Not sure why I had this issue, but it seems to be solved by upgrading to 4.0.4

      Thank you for suggestions, Trevor! I did everything except creating new style (as it was default one with exception of page width and alignment adjustements), and it didn't work although I was getting less errors. I created new style after upgrade to 4.0.4 though.

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X