Announcement

Collapse
No announcement yet.

I have totally stuffed up an upgrade HELP PLEASE

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] I have totally stuffed up an upgrade HELP PLEASE

    Hi All,

    I have done something completely stupid/ I was upgrading and have done it many times before.

    Uploaded everything.

    Followed directions like I always do and Im half thru going thru the steps of upgrade when I remember I didnt change the config.php file so i stop go change the name in the folder - go back to the upgrade steps and it throws a wobble.

    A big fat error on the database what do I do.

    Have I got to go back and re install previous upgrade or what.

    everything I do seems to throw up database error.

    Have refreshed page and cleared cache doesnt seem to make a difference please help forum is down atm.

    thaks all - silly woman I am.

    regards
    Kozzie - Caroline.

  • #2
    Originally posted by kozzie View Post
    Hi All,

    I have done something completely stupid/ I was upgrading and have done it many times before.

    Uploaded everything.

    Followed directions like I always do and Im half thru going thru the steps of upgrade when I remember I didnt change the config.php file so i stop go change the name in the folder - go back to the upgrade steps and it throws a wobble.

    A big fat error on the database what do I do.

    Have I got to go back and re install previous upgrade or what.

    everything I do seems to throw up database error.

    Have refreshed page and cleared cache doesnt seem to make a difference please help forum is down atm.

    thaks all - silly woman I am.

    regards
    Kozzie - Caroline.
    From what version did you upgrade? What is the exact db error that you are getting?

    Comment


    • #3
      I upgraded from

      4-0-2 Patch Level 4 UPGRADED TO 4-0-3 Patch Level 1

      So when I fixed (changed name) the config.php and went to log in to go thru the upgrade steps on:

      /forums/install/upgrade.php (in my case)

      It comes up with page that says:

      Database error The database has encountered a problem.
      Database error in vBulletin :

      mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Access denied for user 'root'@'localhost' (using password: NO)
      /hometwo/musle6d6/public_html/forums/includes/class_core.php on line 312

      MySQL Error :
      Error Number :
      Request Date : Thursday, June 10th 2010 @ 02:16:19 PM
      Error Date : Thursday, June 10th 2010 @ 02:16:19 PM
      Script : http://www.muslimhomeschool.net/foru...ll/upgrade.php
      Referrer :
      IP Address : 144.131.112.173
      Username :
      Classname : vB_Database

      What do I do?

      regards Kozzie - Caroline

      Comment


      • #4
        It seems like somehow you changed something at the db details. Make sure that you got the right db info at the config.php file and run the upgrader once more seeing the fact that you stopped midway.

        Comment


        • #5
          dear borbole -

          when u say the rice ddb info on the config.php what do u mean by that please. cud you be more precise.

          thank you I appreciate all your help.

          regards

          Caroline

          Comment


          • #6
            caroline did you just rename the default config.php.new to config.php without editing the file first?

            Comment


            • #7
              yes, i actually have not changed the config,php for along time when I upgrade it always seemed to upgrade ok without me changing it.

              Have I done something wrong.

              I have been upgrading with out changing information in it since vb 3.84

              oh dea what have I done wrong?

              regards Caroline

              Comment


              • #8
                you will need to edit you config.php file and add in your database information...

                specifically these values:
                $config['Database']['dbname'] This value should be altered to state the name of the database that will contain your vBulletin installation on the database server.

                $config['MasterServer']['username'] This variable contains the username provided to you by your host for connecting to your database server.

                $config['MasterServer']['password'] The password that accompanies the database username should be entered here.


                here's the vbulletin manual for editing the config.php file

                http://www.vbulletin.com/docs/html/editconfig

                from what I understand once you update those values in the fine you should be ok... I think

                Comment


                • #9
                  Can you please teall us how exactly what did you change at the config.php file? Did you change some code, did you rename the file, did you overite it with with a new file, what? We need to know what exactly you did in order to be able to help you further.

                  Comment


                  • #10
                    Ok I have gone into the config.php file and I have changed all the information asked for as stated above.

                    When I Then go to try and up grade I get this error:

                    Parse error: syntax error, unexpected T_STRING in /hometwo/musle6d6/public_html/forums/includes/config.php on line 35

                    ca you please tell me what i did wrong?

                    regards caroline

                    Comment


                    • #11
                      Ok,

                      I filled in everything that i was supposed to as I missed something before.

                      I went through the step by step upgrade and reached teh follwoing step and received this error:

                      Step 5) Merge template changes
                      Merged template successfully: FORUMHOME (style: 62)
                      Conflict when merging template: header (style: 62)
                      Merged template successfully: navbar (style: 62)
                      Merged template successfully: postbit-lite.css (style: 62)
                      Merged template successfully: postbit_legacy (style: 62)
                      Merged template successfully: socialgroups_overview.css (style: 62)
                      Database error
                      followed by:
                      Database error in vBulletin 4.0.3:

                      Invalid SQL:

                      oh dear waht a nightmare - this has never happened before I should have just left it.

                      Please help

                      regards Caroline

                      Comment


                      • #12
                        There is also a huge error note below that which is just so much script its too much to put here:

                        At the end of all the scripting it says thes:

                        MySQL Error : MySQL server has gone away
                        Error Number : 2006
                        Request Date : Thursday, June 10th 2010 @ 03:51:47 PM
                        Error Date : Thursday, June 10th 2010 @ 03:52:30 PM
                        Script : http://www.musl.net/forums/install/finalupgrade.php?step=5&startat=14
                        Referrer :
                        IP Address : 144.131.112.173
                        Username :
                        Classname : vB_Database
                        MySQL Version :
                        Last edited by kozzie; Fri 11th Jun '10, 6:03am.

                        Comment


                        • #13
                          "MySQL Error : MySQL server has gone away"

                          If the details in your config.php file are correct, you should speak to your host regarding this message.
                          Vote for:

                          - *Admin Settable Paid Subscription Reminder Timeframe*
                          -
                          *PM - Add ability to reply to originator only*
                          - Add Admin ability to auto-subscribe users to specific channel(s)
                          - Highlight the correct navigation tab when you are on a custom page
                          - "Quick Route" Interface...
                          - Allow to use custom icons for individual forums

                          Comment


                          • #14
                            thanks to all i have fixed just reinstalled the entire update file fixed the config.php and it seems to be fine now thank u for all ur help and concern

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X