Announcement

Collapse
No announcement yet.

templates and stylevars arent saving

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] templates and stylevars arent saving

    I have been editing a template, everything was being saved fine for many hours. Suddenly at some point the pages would say they are saving and updating, but when it reloaded the template was the same unedited template. When I go to stylevar, the "revert" button for each stylevar is no longer there. When I change a color in the stylevar it says it is saving fine, but when it reloads its the old color.

    So basically I can't change this style at all. Whatever changes I make, it says were saved, but they arent getting saved.

    The style is enabled (check marked).

    I am able to edit other styles (parents).

  • #2
    I have this exact same problem. I`ve done a bit of changing before and then it stuck but suddenly it won`t work locally or in production. The strange thing is that sometimes I get the merger screen and then it shows a changed template.

    Templates saves good an everything (and the changes are there when doing "save and reload") but it won`t be highlighted red when I view the template list again and the contents are the default when opening them again.

    What can I have done to cause this?

    Comment


    • #3
      Are you editing css templates? Conceivably, the problem could be that you're storing the css on the filesystem (admincp->options->Style & Language Settings->Store CSS Stylesheets as Files?) and the clientscript/vbulletin_css directory isn't 777. I'm not entirely sure how the template editor and the store css setting react together, but it's worth investigating.

      Comment


      • #4
        Originally posted by Nick Celestin View Post
        Are you editing css templates? Conceivably, the problem could be that you're storing the css on the filesystem (admincp->options->Style & Language Settings->Store CSS Stylesheets as Files?) and the clientscript/vbulletin_css directory isn't 777. I'm not entirely sure how the template editor and the store css setting react together, but it's worth investigating.
        Thanks for your input, but I am talking about style templates. I have in fact chmodded the css files restrictively because I didn`t want them to be overwritten. I tried setting them to 777 again but it didn`t help.

        Comment


        • #5
          I could've sworn I responded to this earlier...

          Anyhow, in that case I don't really know of any settings or such in the admincp that would prevent the style templates from saving like that. Though you might want to check the administrator permissions just in case (ACP->Usergroups->Administrator Permissions). Also, you could try using a different url prefix (www or non www) or a different browser in case this is a cookie related issue.

          If you still come up empty, I'd suggest opening a support ticket.

          Comment


          • #6
            I have a similar problem, if not the same one. When I update the varstyles nothing happens. Sometimes the variables change, sometimes not.

            For example, I updated I updated the color of pagination_color to a deep red.

            When I tried to update the color for pagination_background, however, nothing happens, though I made it some ridiculous color to test it.

            Moreover, when I try to rechange the color of pagination_color to a different color, it stays deep red.

            Comment


            • #7
              I guess what I am saying is that when I follow the instructions exactly as they are shown in this youtube video on how to use Firebug that vb has linked, the text does not actually increase in size when I refresh. I follow this exactly, but nothing happens when I refresh.

              Comment

              Related Topics

              Collapse

              Working...
              X