Announcement

Collapse
No announcement yet.

Error when updating user groups

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Error when updating user groups

    I'm getting this DB error when I try and update a usergroup setting

    Code:
    MySQL Error   : Unknown column 'ms_vopt_permissions' in 'field list'
    Error Number  : 1054
    There's a lot more in the error, but wasn't sure what to show.

    It happens with any usergroup I try and update in the usergroup manager portion of the admin panel
    New Mexico Offroad

  • #2
    We really need to see the query to find out what table/field it is looking for. My guess is that is from a modification. When you remove modifications, there is sometimes more to it than just uninstalling the product. You need to remove ALL the files you uploaded for the product also.

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools <- awesome site for html/css help

    Comment


    • #3
      Does this help?

      Database error in vBulletin 4.0.3:

      Invalid SQL:
      UPDATE usergroup SET

      ### UPDATE QUERY GENERATED BY fetch_query_sql() ###
      New Mexico Offroad

      Comment


      • #4
        Can you post the full error please? Especially that part where it says: Mysq Error:.........

        Comment


        • #5
          Here's everything, minus IP addy:

          Database error in vBulletin 4.0.3:

          Invalid SQL:
          UPDATE usergroup SET

          ### UPDATE QUERY GENERATED BY fetch_query_sql() ###
          `title` = 'Administrators',
          `description` = '',
          `usertitle` = 'Administrator',
          `opentag` = '',
          `closetag` = '',
          `passwordexpires` = '0',
          `passwordhistory` = '360',
          `forumpermissions` = '16777215',
          `genericpermissions` = '2147483583',
          `attachlimit` = '0',
          `pmquota` = '1000',
          `pmpermissions` = '7',
          `pmsendmax` = '5',
          `pmthrottlequantity` = '0',
          `calendarpermissions` = '63',
          `wolpermissions` = '31',
          `adminpermissions` = '3',
          `genericpermissions2` = '1',
          `genericoptions` = '55',
          `profilepicmaxwidth` = '100',
          `profilepicmaxheight` = '100',
          `profilepicmaxsize` = '65535',
          `avatarmaxwidth` = '150',
          `avatarmaxheight` = '150',
          `avatarmaxsize` = '20000',
          `signaturepermissions` = '237567',
          `sigpicmaxwidth` = '500',
          `sigpicmaxheight` = '100',
          `sigpicmaxsize` = '10000',
          `sigmaxrawchars` = '0',
          `sigmaxchars` = '0',
          `sigmaxlines` = '0',
          `sigmaxsizebbcode` = '7',
          `sigmaximages` = '0',
          `albumpermissions` = '255',
          `albumpicmaxwidth` = '600',
          `albumpicmaxheight` = '600',
          `albummaxpics` = '100',
          `albummaxsize` = '0',
          `usercsspermissions` = '63',
          `visitormessagepermissions` = '63',
          `socialgrouppermissions` = '262143',
          `maximumsocialgroups` = '5',
          `groupiconmaxsize` = '65535',
          `vbblog_general_permissions` = '524286',
          `vbblog_customblocks` = '10',
          `vbblog_custompages` = '10',
          `vbblog_entry_permissions` = '24575',
          `vbblog_comment_permissions` = '990',
          `ms_vopt_permissions` = '0',
          `market_discount` = '0.0000',
          `market_maxdonate` = '0.00000',
          `market_undo_time` = '24',
          `market_undo_penalty` = '0.5000',
          `market_gift_minimum` = '100.85',
          `market_gift_maximum` = '3500.45',
          `market_steal_percent` = '100',
          `market_permissions` = '0'
          WHERE usergroupid=6;

          MySQL Error : Unknown column 'ms_vopt_permissions' in 'field list'
          Error Number : 1054
          Request Date : Thursday, May 20th 2010 @ 02:02:16 PM
          Error Date : Thursday, May 20th 2010 @ 02:02:16 PM
          Script : http://www.nmoffroad.com/forumvb/adm....php?do=update
          Referrer : http://www.nmoffroad.com/forumvb/adm...&usergroupid=6
          IP Address :
          Username : abqtj
          Classname : vB_Database
          MySQL Version : 5.0.90-community
          New Mexico Offroad

          Comment


          • #6
            As Lynne said, that comes from a mod. There is no ms_vopt_permissions column in the default vb tables. What were the most recent modifications you added to your forum prior to getting that error? Try to disable them one by one until you find the culprit.

            Comment


            • #7
              Originally posted by borbole View Post
              As Lynne said, that comes from a mod. There is no ms_vopt_permissions column in the default vb tables. What were the most recent modifications you added to your forum prior to getting that error? Try to disable them one by one until you find the culprit.

              Ah thanks...then it might be either uCash or Point Market System. It did the same in vb4.0.1 right after I added those two mods.
              New Mexico Offroad

              Comment


              • #8
                I uninstalled both of the above mods and am still getting the error...any ideas?
                New Mexico Offroad

                Comment


                • #9
                  Originally posted by abqtj View Post
                  I uninstalled both of the above mods and am still getting the error...any ideas?
                  Can you post a screenshot of the column ''s list of the usergroup table?

                  Comment


                  • #10
                    You have an addon that is looking for this field - ms_vopt_permissions

                    Remove the addon or add the field to your database.
                    Translations provided by Google.

                    Wayne Luke
                    The Rabid Badger - a vBulletin Cloud demonstration site.
                    vBulletin 5 API - Full / Mobile
                    Vote for your favorite feature requests and the bugs you want to see fixed.

                    Comment


                    • #11
                      Originally posted by Wayne Luke View Post
                      You have an addon that is looking for this field - ms_vopt_permissions

                      Remove the addon or add the field to your database.

                      Sorry for getting back to this so late...

                      How could I go about determining what plugin is trying to find that field?

                      I DO have a box below the BLOG COMMENTS permissions that has two buttons for YES and NO, with nothing in there...I suspect that's the culprit but I don't know what it is or was without a heading.
                      New Mexico Offroad

                      Comment


                      • #12
                        Add the field 'ms_vopt_permissions' to your usergroup table, make it an int field.
                        Hard to say exactly what is/was causing the problem but my first guess would be any mods with the initials 'ms' if that rings a bell for you.

                        Comment


                        • #13
                          Thanks Joe! You rock, that fixed it.
                          New Mexico Offroad

                          Comment


                          • #14
                            I had the same problem with 4.0.8 Patch Level 1 trying to disable customizing profiles.
                            I have no extra mods installed. I do however have 1 extra profile field.

                            EDIT: added ms_vopt_permissions field and it was fixed, must have been a old mod from long ago.
                            Last edited by Zytran; Thu 18th Nov '10, 1:18pm.

                            Comment


                            • #15
                              If you don't have any/many mods installed you could just double check your active plugins (not products) and see if any of them have the text "ms_vopt_permissions" in them... If so it's probably that plugin causing the issue and it can probably be de-activated safely.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X