Announcement

Collapse
No announcement yet.

Local host(Xampp) links still lead to live site?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • TheChaosFactor
    replied
    Thanks. I appreciate the help. And this is the same thing I would do if I changed the domain name too, right?

    Leave a comment:


  • JamesAB
    replied
    Originally posted by TheChaosFactor View Post
    Guess I should have tried to be more specific. When I click a link to a thread, it takes me to the thread on my live site instead of the one on my localhost
    Replacement variables should work for you.
    AdminCP -> Styles & Templates -> Replacement Variable Manager

    Add a replacement variable to the style you are using. In the above example, you'll need to change sub.domain.tld to your own forum's domain like www.myforum.com or forum.mysite.org

    Leave a comment:


  • TheChaosFactor
    replied
    Originally posted by JamesAB View Post
    Now you are talking about links people have made in existing posts, correct?

    I think you could make these links work correctly on your local machine by setting up a replacement variable in the style you are using. For example:

    Search for Text
    Code:
    http://sub.domain.tld/
    Replace with Text
    Code:
    http://localhost/
    Guess I should have tried to be more specific. When I click a link to a thread, it takes me to the thread on my live site instead of the one on my localhost

    Leave a comment:


  • TheChaosFactor
    replied
    Originally posted by JamesAB View Post
    Rather than changing things in the database, wouldn't vBulletin's replacement variables also work for changing the domain to localhost?
    Umm... Sorry for the ignorance, but how would I go about that?

    Leave a comment:


  • JamesAB
    replied
    Now you are talking about links people have made in existing posts, correct?

    I think you could make these links work correctly on your local machine by setting up a replacement variable in the style you are using. For example:

    Search for Text
    Code:
    http://sub.domain.tld/
    Replace with Text
    Code:
    http://localhost/

    Leave a comment:


  • MRGTB
    replied
    Originally posted by JamesAB View Post
    Rather than changing things in the database, wouldn't vBulletin's replacement variables also work for changing the domain to localhost?
    I'm not sure about that, never tried it myself.

    Leave a comment:


  • MRGTB
    replied
    The problem is though, all links in the database you downloaded from your live site will be like this in it. http://www.yourdomain.com/showthread123.php (e.t.c). Same with image paths that use a URL for them. Just installing the forum in XAMP and changing the URL in the forum settings will not change any of that, it didn't for me anyway in WAMP. That's why you need to use a good text editor (not Notepad). And use the search and replace tool, because you might have 1000's of instances where your domain needs to be replaced with localhost. It all depends on the size of your database really, and even then you have to be careful how you use the Search and Replace doing it for you fast automatically, that you don't change some things by accident - that shouldn't be changed.

    Leave a comment:


  • JamesAB
    replied
    Rather than changing things in the database, wouldn't vBulletin's replacement variables also work for changing the domain to localhost?

    Leave a comment:


  • TheChaosFactor
    replied
    Well aint that the pits... But I can assume since the links work when manually entered, AND since they lead back to all the right places on my forum, that the database and everything was backed up with no problem?

    Leave a comment:


  • MRGTB
    replied
    If only it was that simple, you need to edit the database itself and do a "search and replace" for yourdomain.com, and replace it with localhost. You may also have to change a few others things also (depending). I use WAMPSERVER and just imported my database and forum to a live server from it, but only after editing the database first itself. And even then I had to use the TOOLS.php to reset the forums cache.

    Leave a comment:


  • JamesAB
    replied
    Have you tried setting your Forum URL to localhost?

    AdminCP -> Settings -> Options -> Site Name / URL / Contact Details -> Forum URL

    Leave a comment:


  • TheChaosFactor
    replied
    Sorry... I forgot to mention that the only place this does NOT happen is the admincp...

    Leave a comment:


  • TheChaosFactor
    started a topic [Forum] Local host(Xampp) links still lead to live site?

    Local host(Xampp) links still lead to live site?

    What I did was download all my forum files, and then export the database so I could make sure I was doing everything right before I try to do it online.

    Now everything looks good, works good. . . IF I manually input urls (localhost/newforums/whateva.php), but if I click any links on any page it takes me to my live site...

    What can I do to fix this?

Related Topics

Collapse

Working...
X