Announcement

Collapse
No announcement yet.

Empty space in first post (where ad is not being displayed)?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Empty space in first post (where ad is not being displayed)?

    Hello,

    We display ads to guests in the first post, right side. Obviously, logged in members do not see the ad. However, the logged in members see the text 'left indented' and the ad space is empty. This problem started occurring after we upgraded to 4.03PL1. Earlier, the logged in members did not see indented text.

    How do I fix this?
    Founder | CrazyEngineers®
    About CE | Small Talk | Official Blog 'VoiCE'
    The Big K's SuperBlog | Join CE!
    The Mobiles Forum. Got A Question?

  • #2
    I think this is the same bug that was fixed in 4.0.3 but reintroduced in 4.0.3 PL1. If that is the case then there was a temporary fix but I don't know if it will impact on the ads served to your guests.

    The fix was to search for <div class="content<vb:if condition="$show['first_ad'] OR $show['last_ad']"> hasad</vb:if>"> in the postbit_legacy template and replace it with <div class="content">

    I'm pretty sure that will fix the white space but I really don't know what impact it will have on your advertising so you would need to check that out.
    .

    Comment


    • #3
      Reintroduction of bug really pisses me off! :|

      Can someone confirm that this is a bug?
      Founder | CrazyEngineers®
      About CE | Small Talk | Official Blog 'VoiCE'
      The Big K's SuperBlog | Join CE!
      The Mobiles Forum. Got A Question?

      Comment


      • #4
        Can someone look into this, please?
        Founder | CrazyEngineers®
        About CE | Small Talk | Official Blog 'VoiCE'
        The Big K's SuperBlog | Join CE!
        The Mobiles Forum. Got A Question?

        Comment


        • #5
          It's a confirmed bug and in the bug tracker with the above fix by someone outside of vbulletin but the official bug fix was:

          Change from: <div class="content<vb:if condition="$show['first_ad'] OR $show['last_ad']"> hasad</vb:if>"

          Change to: <div class="content<vb:if condition="$show['first_ad'] OR $show['last_ad']">hasad</vb:if>" (just remove the space before hasad)

          Comment


          • #6
            Wow, Works like charm THanks a ton, zelnik

            vBulletin: ...... :|
            Founder | CrazyEngineers®
            About CE | Small Talk | Official Blog 'VoiCE'
            The Big K's SuperBlog | Join CE!
            The Mobiles Forum. Got A Question?

            Comment


            • #7
              Hi,

              I'm new to vBulletin. We have this bug in 4.0.3 PL1 - but not sure how to make that edit ("postbit_legacy template"?).

              Any quick heads-up where to find, much appreciated!

              Comment


              • #8
                Originally posted by zelnik View Post
                It's a confirmed bug and in the bug tracker with the above fix by someone outside of vbulletin but the official bug fix was:

                Change from: <div class="content<vb:if condition="$show['first_ad'] OR $show['last_ad']"> hasad</vb:if>"

                Change to: <div class="content<vb:if condition="$show['first_ad'] OR $show['last_ad']">hasad</vb:if>" (just remove the space before hasad)
                That will give you the class "contenthasad" which does not exist. You're better of by removing the ad code and just have <div class="content">.
                OTFans.net Administrator

                Comment


                • #9
                  Originally posted by zelnik View Post
                  It's a confirmed bug and in the bug tracker with the above fix by someone outside of vbulletin but the official bug fix was:

                  Change from: <div class="content<vb:if condition="$show['first_ad'] OR $show['last_ad']"> hasad</vb:if>"

                  Change to: <div class="content<vb:if condition="$show['first_ad'] OR $show['last_ad']">hasad</vb:if>" (just remove the space before hasad)
                  Well i did that, i still have the big space.
                  Attached Files

                  Comment


                  • #10
                    Same here, removing space did not fix this.

                    Comment


                    • #11
                      Hopefully will be fixed in 4.0.4 or somebody can help.

                      Comment


                      • #12
                        All I can say is it works fine for me but I do have the advert set up in the first post for guests, perhaps that's why it works for me and doesn't for you guys?

                        Here's the link with the fix: http://www.vbulletin.com/forum/proje...?issueid=37832

                        Comment


                        • #13
                          If you still have the issue, please post a link to your thread where the issue is still occurring.

                          Please don't PM or VM me for support - I only help out in the threads.
                          vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                          Want help modifying your vbulletin forum? Head on over to vbulletin.org
                          If I post CSS and you don't know where it goes, throw it into the additional.css template.

                          W3Schools &lt;- awesome site for html/css help

                          Comment


                          • #14
                            Removing the space before hasad for postbit legacy template, not postbit, fixes the issue for me.

                            So my next question is, why am I using postbit legacy and not postbit, and does it matter?

                            Comment


                            • #15
                              Originally posted by waynem View Post
                              Removing the space before hasad for postbit legacy template, not postbit, fixes the issue for me.

                              So my next question is, why am I using postbit legacy and not postbit, and does it matter?
                              postbit_legacy has the user info to the left of the actual post while postbit has the userinfo about the post itself. And btw, removing the space is not the correct solution as you create an invalid class called "contenthasad".
                              Change <div class="content<vb:if condition="$show['first_ad'] OR $show['last_ad']"> hasad</vb:if>">
                              Into <div class="content<!--<vb:if condition="$show['first_ad'] OR $show['last_ad']"> hasad</vb:if>-->">
                              OTFans.net Administrator

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X