Announcement

Collapse
No announcement yet.

Upon log in, directs to CMS page. How to?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • david4514
    replied
    It has now been posted in Bug Tracker.

    Leave a comment:


  • Trevor Hannant
    replied
    I'd put that one in the Bug Tracker

    Leave a comment:


  • david4514
    replied
    I have exactly the same issue. We are still just in test mode and newbies at the same time. When I first browse my website, index.php correctly directs me to ../content.php. However, if I logoff from vBulletin and then log back on (without exiting the browser or browsing to any other page) I am always directed back to ../forum.php. I am currently using vBulletin 4.03 PL1, though this behaviour has been there from the initial release of vBulletin 4.

    The issue is that when you logoff from vBulletin, the url in the browser still points to ../login.php with a bunch of query parameter information still appended. The fact that login.php is still there prevents index.php from being used. It appears that vBulletin internally prefers forum.php.
    Last edited by david4514; Wed 28 Apr '10, 2:14pm. Reason: Additional thoughts

    Leave a comment:


  • Trevor Hannant
    replied
    Url?

    Leave a comment:


  • sqzdog
    replied
    Code:
    **
     * If you want to move this file to the root of your website, change this 
     * line to your vBulletin directory and uncomment it (delete the //).
     *
     * For example, if vBulletin is installed in '/forum' the line should 
     * state:
     *
     *    define(VB_RELATIVE_PATH, 'forum');
     *
     * Note: You may need to change the cookie path of your vBulletin 
     * installation to enable your users to log in at the root of your website.
     * If you move this file to the root of your website then you should ensure 
     * the cookie path is set to '/'.
     *
     * See 'Admin Control Panel
     *    ->Cookies and HTTP Header Options
     *      ->Path to Save Cookies
     */
    
    //define(VB_RELATIVE_PATH, 'forums');
    
    
    // Do not edit.
    if (defined('VB_RELATIVE_PATH'))
    {
        chdir('./' . VB_RELATIVE_PATH);
    }
    
    
    /**
     * You can choose the default script here.  Uncomment the appropriate line 
     * to set the default script.  Note: Only uncomment one of these, you must 
     * add // to comment out the script(s) that you DO NOT want to use as your 
     * default script.
     *
     * You can choose the default script even if you do not plan to move this 
     * file to the root of your website.
     */
    
    /**
     * Use the CMS as the default script:
     */
    
    require('content.php');
    
    
    /**
     * Use the forum as the default script:
     */
    
    // require('forum.php');
    
    
    /*======================================================================*\
    || ####################################################################
    || # Downloaded: 12:07, Mon Apr 26th 2010
    || # CVS: $RCSfile$ - $Revision: 31201 $
    || ####################################################################
    \*======================================================================*

    Leave a comment:


  • Trevor Hannant
    replied
    Can you post the code for your index.php file here and a link to your site please

    Leave a comment:


  • sqzdog
    replied
    Nope

    Leave a comment:


  • Trevor Hannant
    replied
    You don't have any .htaccess files in the root directory that may have a redirect on it?

    Leave a comment:


  • sqzdog
    replied
    Its already set up that way as a default. For some reason it goes to the forum.php, even though the part is commented out.

    Leave a comment:


  • steven s
    replied
    Edit the index.php file so they go to content.php instead of forum.php.

    Leave a comment:


  • sqzdog
    started a topic [CMS] Upon log in, directs to CMS page. How to?

    Upon log in, directs to CMS page. How to?

    When my users log in from the CMS page, I want them to be directed back to the CMS page after the log in routine, instead of forum home. Any ideas? I'm sure this is simple and I am just having one of my moments...
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X