Announcement

Collapse
No announcement yet.

Installing vbulletin 4.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Installing vbulletin 4.0

    I hope this is the right place to get help for my problem.

    I am trying to install my forum (vbulletin 4.0). I have installed the files via ftp. I have also created a database in SQL via cPanel. I have located my config.php file and i need to modify it for my database. I thought i configured it correctly but when i go to install vbulletin it gives me this error:

    Step 2) Connect to the database
    Attempting to attach to database
    Error description: mysql_connect() [function.mysql-connect]: Access denied for user 'MYDOMAINNAME'@'localhost' (using password: NO) /home/HOSTINGUSERNAME/public_html/includes/class_core.php on line 312
    The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.












    I have made my database name: 'forums' .In the database name section should it be enterrred as forums? or as HOSTINGACCOUNT_forums?


    I have made my username: 'user' . In the username section...should it be 'user' or 'HOSTINGACCOUNT_user'?











    This is what my config.php file looks like:




    // ****** DATABASE NAME ******
    // This is the name of the database where your vBulletin will be located.
    // This must be created by your webhost.
    $config['Database']['user_forums'] = 'forum';




    // ****** MASTER DATABASE USERNAME & PASSWORD ******
    // This is the username and password you use to access MySQL.
    // These must be obtained through your webhost.
    $config['MasterServer']['user'] = 'root';
    $config['MasterServer']['PASSWORD'] = '';






    Thanks for your help

  • #2
    You need to change the values after the = sign, not in the [].
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - "Quick Route" Interface...

    Comment


    • #3
      If your database name is "forums" you should add this and not as you did "forum" (without ending s).
      Based upon your informations your config.php should be:

      // ****** DATABASE NAME ******
      // This is the name of the database where your vBulletin will be located.
      // This must be created by your webhost.
      $config['Database']['user_forums'] = 'forums';




      // ****** MASTER DATABASE USERNAME & PASSWORD ******
      // This is the username and password you use to access MySQL.
      // These must be obtained through your webhost.
      $config['MasterServer']['user'] = 'user';
      $config['MasterServer']['PASSWORD'] = 'here you need to add your db password';
      .......

      Comment


      • #4
        Thank you for your help. I have changed my config.php to be identical to yours. I get this error:

        Step 2) Connect to the database
        Attempting to attach to database
        Connect failed: unexpected error from the database.
        Error number: 1046
        Error description: No database selected
        Please ensure that the database and server is correctly configured and try again.

        Comment


        • #5
          Grab a default copty of the config.php and edit it again.

          Comment


          • #6
            Thanks for all your help. So i uploaded a new config and i changed it to be identical to Ramsexs. I get the same error as my second post...


            Step 2) Connect to the database
            Attempting to attach to database
            Connect failed: unexpected error from the database.
            Error number: 1046
            Error description: No database selected
            Please ensure that the database and server is correctly configured and try again.






            // ****** DATABASE NAME ******
            // This is the name of the database where your vBulletin will be located.
            // This must be created by your webhost.
            $config['Database']['user_forums'] = 'forums';




            // ****** MASTER DATABASE USERNAME & PASSWORD ******
            // This is the username and password you use to access MySQL.
            // These must be obtained through your webhost.
            $config['MasterServer']['user'] = 'user';
            $config['MasterServer']['password'] = 'mypassword';

            Comment


            • #7
              You did not grab a new fresh copy of the config.php file as instructed.

              Code:
                  //    ****** DATABASE NAME ****** 
                  //    This is the name of the database where your vBulletin will be located. 
                  //    This must be created by your webhost. 
              $config['Database']['dbname'] = 'forum';
              Notice the database name setting?

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X