Announcement

Collapse
No announcement yet.

Fatal Error, Please Help..

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Fatal Error, Please Help..

    I got this error while trying to upgrade from 4.0.2 to 4.0.3. I tried asking my hosting provider ( hostgator ) and they will not raise my memory for me. I asked them before and they done it but now they wont!?.. wtf? Anyway i get around this?

    Fatal error: Out of memory (allocated 65536000) (tried to allocate 4178 bytes) in /home/vicro5/public_html/includes/class_diff.php on line 170
    Pixel Playground
    vB Skins.. Supplying Skins for the little guys....lol

  • #2
    Nvm i fixed it.
    Pixel Playground
    vB Skins.. Supplying Skins for the little guys....lol

    Comment


    • #3
      It seems that the execution of the above php file needs more that the allocated memory.

      Since the hosting provider will not increase the memory_limit value, you can use the following workaround:

      1. Open your vBulletin include/config.php file.

      2. Below the php open tag add the following line:

      ini_set('memory_limit', '200M');

      The code will look as follows:


      <?php
      ini_set('memory_limit', '200M');

      In this way your script will use 200 MB of the memory.

      Alternatively, you can download your forum script on a local LAMP or WAMP server, set the preferred php configuration, upgrade the script locally and reupload it back.
      Last edited by sven4o; Tue 20 Apr '10, 6:51am.
      SiteGround Technical Support Team Member.
      Check out our special vBulletin hosting package.

      Comment


      • #4
        This worked a treat for me. Thanks. I take it that I take the line out after the installation has completed successfully?
        sigpic

        Comment


        • #5
          Originally posted by sven4o View Post
          It seems that the execution of the above php file needs more that the allocated memory.

          Since the hosting provider will not increase the memory_limit value, you can use the following workaround:

          1. Open your vBulletin include/config.php file.

          2. Below the php open tag add the following line:

          ini_set('memory_limit', '200M');

          The code will look as follows:


          <?php
          ini_set('memory_limit', '200M');

          In this way your script will use 200 MB of the memory.

          Alternatively, you can download your forum script on a local LAMP or WAMP server, set the preferred php configuration, upgrade the script locally and reupload it back.
          Had the same problem and it worked for me too.

          Thank you sven4o

          Comment


          • #6
            Originally posted by Vicros View Post
            Nvm i fixed it.
            How did you fix this? Curious as I have some sites on HostGator and did not run into this although all but one are on shared hosting, remember to ALWAYS provide how you fixed it instead of a simple "It's fixed now" "I got it" "nevermind"... what if you would have happened along a thread and the title matches your problem but then within it simply said, nvm I fixed it?

            Help others, don't forget!


            Former vBulletin Support Staff
            Hacked recently? See my blog post "Recovering a Hacked vBulletin Site".
            Thinking outside the box? Need modification support? Visit www.vBulletin.org and have at it!

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X