Announcement

Collapse
No announcement yet.

SEO, HostGator and "Hacking Attempt!" on one of my threads.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] SEO, HostGator and "Hacking Attempt!" on one of my threads.

    I have a thread: http://www.dzwiek.org/threads/4753
    When I access it via SEO link directly from forums: http://www.dzwiek.org/threads/4753-Y...jako-interfejs it returns "Hacking Attempt!" error. It's just this one thread. Any ideas why?

  • #2
    Check your mod_security settings on the server.
    I drank WHAT?! - Socrates

    Comment


    • #3
      Originally posted by Biker View Post
      Check your mod_security settings on the server.
      where will I find it?

      Comment


      • #4
        If you're on shared hosting, your provider will have to check for you.

        Do you have any modifications installed? Specifically any that are supposedly security related?
        I drank WHAT?! - Socrates

        Comment


        • #5
          hostgator said:
          Originally posted by hostgator
          I dont actually see your account compromised. Do you have anything setup in your vb forum that might be blocking rewrites or does strict checking of links ?
          my question is: why is it just one thread? for months everything was fine and this is just this one thing. Why removing Search Engine friendly part of web address solves the problem?

          Why this doesn't work:
          PHP Code:
          http://www.dzwiek.org/threads/4753-Yamaha-01V96-jako-interfejs 
          and this works fine:
          PHP Code:
          http://www.dzwiek.org/threads/4753 
          ???

          Comment


          • #6
            mail to [email protected]
            you can't change mod_security settings normally.

            edit: ignore the above part. ninja'd.

            what is in your htaccess file?

            also, try changing those strict seo url settings introduced in vB 4.0.3

            Comment


            • #7
              Originally posted by CvP View Post
              mail to [email protected]
              you can't change mod_security settings normally.
              edit: ignore the above part. ninja'd.
              what is in your htaccess file?
              also, try changing those strict seo url settings introduced in vB 4.0.3
              changing setting to strict doesn't fix the problem

              PHP Code:
              ErrorDocument 404 http://www.dzwiek.org/404.php
              <ifModule mod_expires.c>
                
              ExpiresActive On
                ExpiresDefault 
              "access plus 1 seconds"
                
              ExpiresByType text/html "access plus 1 seconds"
                
              ExpiresByType image/gif "access plus 259200000 seconds"
                
              ExpiresByType image/jpeg "access plus 259200000 seconds"
                
              ExpiresByType image/png "access plus 259200000 seconds"
                
              ExpiresByType text/css "access plus 60480000 seconds"
                
              ExpiresByType text/javascript "access plus 21600000 seconds"
                
              ExpiresByType application/x-javascript "access plus 21600000 seconds"
              </ifModule>
              <
              ifModule mod_headers.c>
                <
              filesMatch "\\.(ico|pdf|flv|jpg|jpeg|png|gif|swf)$">
                  
              Header set Cache-Control "max-age=25920000, public"
                
              </filesMatch>
                <
              filesMatch "\\.(css)$">
                  
              Header set Cache-Control "max-age=6048000, public"
                
              </filesMatch>
                <
              filesMatch "\\.(js)$">
                  
              Header set Cache-Control "max-age=2160000, private"
                
              </filesMatch>
                <
              filesMatch "\\.(xml|txt)$">
                  
              Header set Cache-Control "max-age=2160000, public, must-revalidate"
                
              </filesMatch>
                <
              filesMatch "\\.(html|htm|php)$">
                  
              Header set Cache-Control "max-age=1, private, must-revalidate"
                
              </filesMatch>
              </
              ifModule>
              <
              ifModule mod_headers.c>
                
              Header unset ETag
              </ifModule>
              FileETag None
              <ifModule mod_headers.c>
                
              Header unset Last-Modified
              </ifModule>

              RewriteEngine on

              RewriteCond 
              %{HTTP_HOST} ^dzwiek.org$ [OR]
              RewriteCond %{HTTP_HOST} ^www.dzwiek.org$
              RewriteRule ^vbulletin\/?(.*)$ "http\:\/\/www\.dzwiek\.org\/$1" [R=301,L]
              RewriteCond %{HTTP_HOST} ^dzwiek.org$
              RewriteRule ^(.*)$ "http\:\/\/www\.dzwiek\.org\/$1" [R=301,L]


              # Author: Matty Asia
              # Version 1.6
              # Downloaded from: http://www.vbulletin.com/forum/showthread.php?325798

              RewriteEngine On
              Options 
              +FollowSymLinks

              ### THIS IS A LITTLE EXTRA SECURITY AND CAN BE REMOVED

              RewriteRule ^includes/(.*) index.php
              RewriteRule 
              ^vb/(.*) index.php
              RewriteRule 
              ^packages/(.*) index.php

              ### THIS IS THE ACTUAL REWRITE

              RewriteRule ^threads/([0-9]+)(?:/?$|(?:-[^/]+))(?:/?$|(?:/page([0-9]+)?)) showthread.php?t=$1&page=$2&%{QUERY_STRING}
              RewriteRule ^members/([0-9]+) member.php?u=$1&%{QUERY_STRING}
              RewriteRule ^forums/([0-9]+)(?:/?$|(?:-[^/]+))(?:/?$|(?:/page([0-9]+)?)) forumdisplay.php?f=$1&page=$2&%{QUERY_STRING}
              RewriteRule ^blogs/([0-9]+)(?:/?$|(?:-[^/]+))(?:/?$|(?:/page([0-9]+)?)) blog.php?u=$1&page=$2&%{QUERY_STRING}
              RewriteRule ^entries/([0-9]+)(?:/?$|(?:-[^/]+))(?:/?$|(?:/page([0-9]+)?)) entry.php?b=$1&page=$2&%{QUERY_STRING}
              RewriteRule ^list/([^/]*/)([0-9]+) list.php?r=$1$2&%{QUERY_STRING}
              RewriteRule ^content/(.*) content.php?r=$1&%{QUERY_STRING}
              RewriteRule ^widget/config/([0-9]+) widget.php?r=config/$1&%{QUERY_STRING}
              ### END

              RewriteEngine On

              ####Charset
              AddDefaultCharset Off 

              ####Gzip
              <IfModule mod_rewrite.c>
              RewriteCond %{REQUEST_FILENAME} -f
              RewriteRule 
              ^(.*)(js|css)$ redir.php?file=$1$2&type=$[L]
              </
              IfModule>

              ####ETags
              FileETag None

              ####Expires
              <IfModule mod_expires.c>
              ExpiresActive On
              ExpiresByType image
              /gif A2592000
              ExpiresByType image
              /jpeg A2592000
              ExpiresByType image
              /png A2592000
              ExpiresByType application
              /x-shockwave-flash A2592000
              ExpiresByType text
              /css A2592000
              ExpiresByType application
              /x-javascript A2592000
              </IfModule>

               <
              IfModule mod_php4.c>  
              php_value max_execution_time  1000  
              </IfModule

              Comment


              • #8
                this is info from hostgator:
                Originally posted by hostgator
                The problem is that your forum software is not properly handling the SEF urls, and is reading the extra characters as a possible hacking attempt. You should contact Jelsoft for assistance in configuring vBulletin to properly handle these URLs. If there's anything else we can do to assist you, please let us know.

                Comment


                • #9
                  I renamed the thread and it works now. Must be a bug.

                  Comment


                  • #10
                    I had the same problem. I stopped using the friendly URLs. Maybe they can be improved upon like your technical support suggested.

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X