No announcement yet.

Perplexing Login Problem

  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Perplexing Login Problem

    I have my .htaccess file setup so that anytime someone types the website's name, the www is automatically inserted. Common and simple process.

    However when the www. is in front of the domain name, it is impossible to login. If you type your information and click the login button it skips the "Thank You for Logging In" page, saves no session or cookie data, and refreshes to the forum homepage.

    As soon as I reverse the process in the .htaccess file to remove the www, users can login fine and have no problems.

    The login system I use for the rest of the site works fine with either setting.

    I have tried several cookie settings in the admincp with no luck. Every setting does the same thing. Running vB 4.0.2 PL4.

    Thanks in advance!

  • #2
    Can someone from the support team please answer at least? I see many other responses from you after my thread...

    That is what this forum is here for after all right?


    • #3
      What are your cookie settings in the admincp?

      It could also be that if an extra www. is inserted into the URL, users visiting www. will be getting instead...

      Why isn't your www. setup under the dns subdomain alias settings on your server instead?


      • #4
        Unbelievable... Customers pay for a product and then get ignored by the staff when asking for help. And vBulletin used to be considered respectable. Now the best term I can think of to describe it is useless.

        I don't expect an answer all the time when the forum is completely volunteer based. But when we pay for this and there's less support? Pathetic.


        • #5
          Don't use .htaccess to redo your URLs. Use cookie domain... Set it to (note the leading period). This will allow users to log in from AND
          I drank WHAT?! - Socrates


          • #6
            Thanks for the response Biker. Good to know the volunteers are more efficient than the staff.

            I'm using .htaccess so that search bots can index my pages smoothly. And I did set the cookie domain to when I had htaccess redirecting. I guess I'll change it back. Thanks