Announcement

Collapse
No announcement yet.

Problem - User Cannot login

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • AFemaleProdigy
    replied
    vBulletin members cannot log in. Problem with www and non-www domain.

    SOLUTION:

    I have been a vB user for many years. I'm a web developer. It wasn't until the new suite came out that I experienced this issue with users not being able to log in. There was a definite difference between the www and non-www domain login. I had experienced this before with other types of software so I just took a guess and added an htaccess file. It worked and I decided to see if vB is aware of the issue and found this. I can confirm that if your problem is similar to what I describe, an htaccess file should work for you. I do not know what that salt file is and have not used it. This fix does not require any changes to the cookie domain, hash, and does not require users to reset passwords/clear cache/or anything like that. Just add the htaccess and that's it.

    I also want to add that an htaccess file is recommended even if you aren't experiencing this issue. It's in your best interest to allow only one (www or non-www) to be accessed on your site. This is beneficial for search engine optimization. Allowing both to be accessible can make search engines think you have duplicate content, as they are viewed as two different domains.

    To create an htaccess file, open up Notepad or Dreamweaver and copy this code into it. Save the file in your root directory as .htaccess and don't forget the dot (period). It may take a while for it to take effect. It varies. You will know it is working when you are redirected when trying to use the now inactive version of the domain.

    Code:
    Options +FollowSymLinks
    RewriteEngine On
    # END WordPress
    RewriteCond %{HTTP_HOST} ^40by20\.com$ [NC]
    RewriteRule ^(.*)$ http://www.40by20.com/$1 [R=301,L]
    I want to add that I am surprised that vB has not addressed this issue yet. I mean, other then having to take extra steps beyond the upgrade/install. I hope this is included in the next patch. It used to be that when you set the domain in the admincp, it would do the redirect automatically. You would not need to manually create the htaccess file. VBSEO also achieved this. So I hope that vB reads this and recognizes the issue. I just installed the latest patch version and am also using a slightly older version on another site and both had the same problem.

    Hope this helps!!
    Last edited by AFemaleProdigy; Wed 9 Mar '11, 8:53am.

    Leave a comment:


  • vuser12
    replied
    Originally posted by princesspepper View Post
    We are having the same problem.

    Members cannot login on multiple browsers, multiple IPs.

    I even set up a second account for a member today, which worked until I merged it with his existing one.

    This is a serious issue and our forum is losing members fast as a result.

    Please attach some urgency to this issue.
    Same issue here.

    Resolution:
    • Changed cookies to .forumdomain.com
    • I ran install/upgrade_402_salt.php

    It seems to have fixed the problem with one user. I will wait and see if others complain.

    Leave a comment:


  • anthonyparsons
    replied
    Interesting... it has worked for others using 4.0.3. "arms go up in air"

    Have you submitted a support ticket? I would try that.

    Leave a comment:


  • qubed
    replied
    in addition. what fix is there for users running vb 3.85 if there is no script to run?

    Leave a comment:


  • vdinh
    replied
    Originally posted by anthonyparsons View Post
    Yes... absolutely.

    Attempting the upgrade brought up the message:

    Your vBulletin version does not appear to match with the version for which this script was created (version 4.0.2).
    Please ensure that you are attempting to run the correct script.
    Last edited by vdinh; Tue 11 May '10, 10:05pm.

    Leave a comment:


  • anthonyparsons
    replied
    Yes... absolutely.

    Leave a comment:


  • vdinh
    replied
    Originally posted by anthonyparsons View Post
    Run install/upgrade_402_salt.php ensuring you have all install folder files present, bar the install.php one, when doing this. It should fix your immediate issue.
    So I can run this upgrade even though I'm now on version 4.0.3 already?

    Leave a comment:


  • anthonyparsons
    replied
    Run install/upgrade_402_salt.php ensuring you have all install folder files present, bar the install.php one, when doing this. It should fix your immediate issue.

    Leave a comment:


  • vdinh
    replied
    Upgraded from 3.8 to 4.0.3. Same problem here!

    Leave a comment:


  • princesspepper
    replied
    Bump.

    Leave a comment:


  • princesspepper
    replied
    We are having the same problem.

    Members cannot login on multiple browsers, multiple IPs.

    I even set up a second account for a member today, which worked until I merged it with his existing one.

    This is a serious issue and our forum is losing members fast as a result.

    Please attach some urgency to this issue.

    Leave a comment:


  • StevieGooGs
    replied
    THis is strange i have the same problem not and upgrade a clean install and i cannot login via IE but FF is fine?

    Leave a comment:


  • Mandi
    replied
    We were able to resolve this problem this morning for our locked-out users by running the install/upgrade_402_salt.php script, and then asking those affected to please (once more ...) request new passwords from the login system. These fresh passwords did work, finally.

    Leave a comment:


  • exyuteam
    replied
    Originally posted by plexus View Post
    I am experincing the same error. www.yoursite.com allows a valid login http://yoursite.com dosnt. i have noticed this with IE and FF. what i noticed it does is if you try to log in with out the www. it keeps your user in a login loop, however it you go back up to the addy bar and add the www. your user will be logged in. the VB team needs to really fix this issue due to most people dont use the www. prefix when viewing or going to internet sites. i still have this issue after updating to 4.3 i thought it was a issue in 4.02pl4(that is where it started for me or should i say me noticing it).

    Originally posted by Wayne Luke View Post
    If you have already run the install/upgrade_402_salt.php script already then everyone in this thread should try this fix...

    1) Reset the Cookie Path and Cookie Domain to the defaults. You should only change these if you have multiple vBulletin systems installed on the same domain.

    2) Open your config.php file and change the cookie_prefix variable from 'bb' to 'vb'.

    This should require everyone to log in again but the password hash will take into account the 30 digit salt as opposed to the 3 digit salt in previous versions. The 30 Digit Salt was introduced in vBulletin 3.8.5 and 4.0.2 PL3.
    Originally posted by Don McR View Post
    The problem I reported has been resolved for my site. Contrary to what has been posted above, instead of ensuring that the cookie domain was set to default, I found that the cookie domain needed to be set to the domain of my site.

    To recap, the problem that I and others in this thread have reported was that including or not including www in the forum address caused problems in logging in. For example, "http://www.mysite.com" allowed me to login correctly where "http://mysite.com" would not work. Setting the cookie domain to "mysite.com" solved the problem. Now logins from either address work correctly and the cookies are functional in allowing automatic logins from either address where before they would not. It should be noted that any old cookies that date prior to chaning the cookie domain need to be deleted by users. Otherwise, the login problems will continue.

    I have a same problem. Is this problem will fix in next release? My users also use mixed domain name (some WITH www, and some WITHOUT www), and I don't know WHY login.php redirect to WWW.DOMAIN.COM?

    Thanks in advance!

    Leave a comment:


  • reichadler
    replied
    My experience of this issue is it is not related to the www.domname.com or http://domname.com (Or at least is not the only cause of the issue)

    My testing has produced the result on the same machine, ip, explorer version & URL with some new & moderately new users. I tried to log into their accounts & got the password user name errors. Yet could log in with other accounts fine. I also signed up new accounts & experienced the issue. I can not access their accounts from other machines at different locations. I reset the password even, they still cant access. The username password challenge is consistent across browsers, Win version & even different IPs.

    I have 2 members of 150 that I know off, but signing up new acounts has ressulted in a 33% fail rate. The whole process goes fine, I can browse the forum. I log out, then get the error trying to log in. And that is with 100% the correct information. This is frustrating my members. Who pay to belong, hence why I have devoted time to trying find out what is going wrong.

    I would strongly recomend this be bumped up the priority fix list. I suspect it may be quite wide spread, but folk who use the same machines to access the forum wont notice it until they actually log out.

    Leave a comment:

Related Topics

Collapse

Working...
X