Announcement

Collapse
No announcement yet.

Better to UPGRADE or use IMPEX (3.8 to 4)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Better to UPGRADE or use IMPEX (3.8 to 4)

    Hello,

    I am looking to get onto VB4.0. However, I foresee many problems. My board has been hacked to high hell and back again that I rather suspect, even if I do disable all my mods, the upgrade will not be error-free. In fact, I anticipate lots of problems, considering that many others are having similar problems too.

    Further, the MYSQL database is also filled with useless information of previous hacks that left bits and pieces even after uninstall, which is disheartening to say the least.

    Would I be better off using the IMPEX system? That is, could I not import all the posts/threads/users from my 3.8 into my 4.2 fresh install?


    To make matters even worse, I am planning on switching my forum's directory (from forum to root).

    Any advice would be greatly appreciated.
    Cedric
    FictionPost.com - Where Writers Unite!

  • #2
    Hello Cedric

    Impex is designed to import data to your forum. If you upgrade your forums via Impex , then all your current urls may change. Thats why it is always suggested to upgrade vBulletin through upgrade script. Just make sure you backup your database before starting upgrade process. You can check http://www.vbulletin.com/forum/showt...grading-to-4.0 on how to backup your forums.

    Comment


    • #3
      But I'll also be changing my forum URL from /forums to root, so the URL's will change anyway. Would IMPEX be better suited for this?

      As for all my current URL's - if you mean all my indexed URL's in search engines?

      That's ok - most of my forums are private anyway.
      Cedric
      FictionPost.com - Where Writers Unite!

      Comment


      • #4
        Impex is not intended to be used as an upgrade tool. Use the upgrade scripts.

        Comment


        • #5
          If I were you, I'd upgrade.

          There are tools available to 'clean' up your DB of all the rubbish the hacks have put in there.

          What I'd do.......
          Backup the DB. (and files)
          Remove all the hacks. (and files)
          Backup the DB
          Upgrade to v4

          Comment


          • #6
            Backup all your DB an upgrade. Test is out on a password protected directory make sure it works.

            Remember to disable plugins.
            Problems with vB4? Try This Thread for answers!

            Comment


            • #7
              Alright I'll try the upgrade path.

              Thanks folks
              Cedric
              FictionPost.com - Where Writers Unite!

              Comment


              • #8
                I do not under ANY CIRCUMSTANCES recommend using IMPEX for 3.8 to 4.0.

                I tried it on my test forum and it was so messed up you would spend weeks fixing the newly created problems that it would be counterintuitive over the amount of problems your hacks may have caused.

                Comment


                • #9
                  Thank you - that's the sort of reply I was really looking for.

                  I'll stay away from Impex
                  Cedric
                  FictionPost.com - Where Writers Unite!

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X