Announcement

Collapse
No announcement yet.

Cannot upgrade or do a fresh install of vbulletin 4.XX on my VPS

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Cannot upgrade or do a fresh install of vbulletin 4.XX on my VPS

    I've done upgrades a ton of times however, going from 3.8 to the current 4.XX release, all I get is

    Parse error: parse error, unexpected T_ARRAY, expecting '&' or T_VARIABLE in /httpdocs/test2/includes/class_core.php on line 3833

    I cannot figure out what to do. I just wasted 170.00

  • #2
    First things:

    Did you actually complete the VB4 install? Or when does this error occur?

    1) Did you upload all of your files in ASCII mode?
    2) What PHP version are you running on your host?

    Both of these are key issues before you can install VB4.
    To be updated...

    Comment


    • #3
      this happens when I try to either run the upgrade or even a clean install script.
      I am running php 5.0.4

      and yes all files were in ASCII
      Last edited by Chubzilla; Mon 29th Mar '10, 8:54pm.

      Comment


      • #4
        Originally posted by Chubzilla View Post
        this happens when I try to either run the upgrade or even a clean install script.
        I am running php 5.0.4
        You should have read the VB4 requirements before buying... You'll need to upgrade your PHP. (to at least PHP 5.2.0)

        See here: http://www.vbulletin.com/forum/showt...m-Requirements
        To be updated...

        Comment


        • #5
          Upgrading the PHP software is a pain. I've googled and tried to do the steps that are laid out and I can't get it to install via ssh

          Comment


          • #6
            Unless you're on a dedicated server you can't upgrade PHP yourself, your host has to do it. But I doubt that's the problem as long as you have 5.x. Did you uninstall all your mods prior to attempting the upgrade?

            Comment


            • #7
              Originally posted by Videx View Post
              Unless you're on a dedicated server you can't upgrade PHP yourself, your host has to do it. But I doubt that's the problem as long as you have 5.x. Did you uninstall all your mods prior to attempting the upgrade?
              VB4 Requires PHP 5.2.0 -- He has PHP 5.0.4 = VB4 Won't work.
              To be updated...

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X