Puuurllease help me with this!

I'm trying to embed a KML viewer in a CMS article on vB4.
I know the Viewer works, as if I embed the code below, in for instance my blogger account page, it displays both the google earth viewer and all the detail from the KMZ/KML file fine.

If I create a widget and use this code, it also displays fine. The problem is I don't want the KML viewer in a widget, I want it in an article!

When I create an article, nothing is diplayed at all. I've checked permissions, and as an admin I can create html so thats not the problem. If I wrap the embed code in CODE tags, the viewer displays (with all the correct data) but it's inside the tiny code box so it isn't usable. Can i make the code box bigger? Is there some other way I can get it to display? I'm assuming that I've made some dumb error in a setting somewhere but I can't track it down. Please help!


<script src="http://www.gmodules.com/ig/ifr?url=http://code.google.com/apis/kml/embed/embedkmlgadget.xml&amp;up_kml_url=http%3A%2F%2Fwww.surftalk.co.uk%2Fearthncwxbuoysnl.kmz&a mp;up_view_mode=earth&amp;up_earth_2d_fallback=0&amp;up_earth_fly_from_space=1&amp;up_eart h_show_nav_controls=1&amp;up_earth_show_buildings=1&amp;up_earth_show_terrain=1&amp;up_ear th_show_roads=1&amp;up_earth_show_borders=1&amp;up_earth_sphere=earth&amp;up_maps_zoom_out =0&amp;up_maps_default_type=map&amp;synd=open&amp;w=500&amp;h=400&amp;title=Embedded+KML+V iewer&amp;border=%23ffffff%7C3px%2C1px+solid+%23999999&amp;output=js"></script>