Announcement

Collapse
No announcement yet.

How to replace special characters in SEO URL alias?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] How to replace special characters in SEO URL alias?

    Hi,

    Everytime I try to create a new article the SEO URL Alias gets auto completed according to the title of my article. However, if I use a non-english character in my title, it gets replaced to a dash character "-".

    I don't want this behavior because it hurts the SEO of my pages. Sure, I can edit it manually but when you are creating several articles a day it just sucks. It is worst when other unexperienced users try to create an article, they just don't know what a SEO URL alias is and they will leave the option untouched.

    Is there any option to auto replace special non-english characters to english characters when the SEO URL Alias field is auto completed?

    For example
    á => 'a',
    ñ => 'n',
    ¿ => ''.
    ~ LANeros.com ~

  • #2
    I'm also concerned with this issue because now cyrrilic URLs are displayed incorrectly

    Comment


    • #3
      We've been doing a lot with UTF-8 characters. I've been testing the current version. Now the following characters may be gibberish, but they are how the current code generates url's from titles. I believe they indicate a substantial improvement.

      Komplettlösung und Trophäen -> Komplettlösung-und-Trophäen
      المداهاط مات ونق -> المداهمات-ونقاط
      Избранная статья -> Избранная-статья

      # ベータ版 を試す->#-ベータ版-を試す
      Please- I'm not tech support. Don't send your problem reports to me unless I've asked you to.

      Comment


      • #4
        Thank you Edwin for your update. I would like to know if I need to convert my forum to UTF-8 in order to use the improvements you mention. On the other hand, I would like to have something as simple as an array like array('á' =>'a') to convert non-english characters to english character. That would be all I need.
        ~ LANeros.com ~

        Comment


        • #5
          Yes, I believe your forum would have to be in UTF-8 to use these improvements. This would be a good application for a hook but we don't have one in an ideal place. Could you put in a feature request in Project Tools?
          Please- I'm not tech support. Don't send your problem reports to me unless I've asked you to.

          Comment


          • #6
            Originally posted by Edwin Brown View Post
            Yes, I believe your forum would have to be in UTF-8 to use these improvements. This would be a good application for a hook but we don't have one in an ideal place. Could you put in a feature request in Project Tools?
            How do I post a feature request? I only see a bug issue type when I go to the vBulletin project http://www.vbulletin.com/forum/project.php?projectid=6
            ~ LANeros.com ~

            Comment

            Related Topics

            Collapse

            Working...
            X