Announcement

Collapse
No announcement yet.

suddenly a ton of users can't login

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] suddenly a ton of users can't login

    I had a couple of errors yesterday, and now I'm getting tons of users that suddenly can't login. Also, the "send new password" function isn't helping.

    Is there a quick fix for this? Any ideas?

    Thanks!

  • #2
    What were the database errors?

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools <- awesome site for html/css help

    Comment


    • #3
      Database error in vBulletin :

      mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
      /home/dinarvet/public_html/forums/includes/class_core.php on line 312

      MySQL Error :
      Error Number :
      Request Date : Friday, March 5th 2010 @ 09:11:17 AM
      Error Date : Friday, March 5th 2010 @ 09:11:17 AM
      Script : http://dinarvets.com/forums/404.php
      Referrer :
      IP Address : 67.134.168.2
      Username :
      Classname : vB_Database
      MySQL Version :

      Comment


      • #4
        See this page for the causes of this error: http://www.vbulletin.com/docs/html/cantconnect

        Please don't PM or VM me for support - I only help out in the threads.
        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
        Want help modifying your vbulletin forum? Head on over to vbulletin.org
        If I post CSS and you don't know where it goes, throw it into the additional.css template.

        W3Schools &lt;- awesome site for html/css help

        Comment


        • #5
          how about my users? Can I fix the broken password issue?

          Comment


          • #6
            Suddenly no one can login? And no one can reset their password? What happens when they try to reset it? Any idea what you did right before this whole issue started?

            Please don't PM or VM me for support - I only help out in the threads.
            vBulletin Manual & vBulletin 4.0 Code Documentation (API)
            Want help modifying your vbulletin forum? Head on over to vbulletin.org
            If I post CSS and you don't know where it goes, throw it into the additional.css template.

            W3Schools &lt;- awesome site for html/css help

            Comment


            • #7
              apparently something is buggy on my forum, because these same people CAN get in if they delete cookies and cache and then try to login.

              Unfortunately, my server site doesn't seem to be sending out new passwords, and my forum email is spam-filtered by most ISPs anyway so it wouldn't matter if it did.

              grr.

              Comment


              • #8
                If the cookie domain was changed at all, then that would make sense regarding the deleting cookies/cache.

                Try maintenance > diagnostics > email and see if you get an email sent to you.

                Please don't PM or VM me for support - I only help out in the threads.
                vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                Want help modifying your vbulletin forum? Head on over to vbulletin.org
                If I post CSS and you don't know where it goes, throw it into the additional.css template.

                W3Schools &lt;- awesome site for html/css help

                Comment


                • #9
                  i got the email to my google account.

                  Good news - one of the users having the problem contacted me with her username and password. I tried logging in - no luck. In the admincp, I changed her username and password...

                  still no luck. This username is impossible to login, even after manually changing the password in the admincp.

                  Any ideas?

                  Comment


                  • #10
                    got a couple more users that sent usernames and passwords that can't login now too.

                    Comment


                    • #11
                      Why are you changing the usernames when it is their password that isn't working?

                      I would strongly suggest you create and use a default style with no modifications on and see if these problems persist:
                      Create a new style with no parent:
                      • Styles & Templates > Style Manager > Add New Style
                      • Parent Style: No Parent Style
                      • Title: Default vBulletin
                      • Allow User Selection: Yes
                      • Save


                      Then browse the site using that totally default vbulletin style - do you still have the same problem?

                      If it is still happening - Try disabling your modifications/plugins and see if you still have this problem.
                      Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

                      PHP Code:
                      define('DISABLE_HOOKS'true); 

                      Please don't PM or VM me for support - I only help out in the threads.
                      vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                      Want help modifying your vbulletin forum? Head on over to vbulletin.org
                      If I post CSS and you don't know where it goes, throw it into the additional.css template.

                      W3Schools &lt;- awesome site for html/css help

                      Comment


                      • #12
                        I meant password, didn't mean to mis-speak.

                        Anyway.

                        I switched to a default style, disabled hooks as you mentioned, changed this user's password in the admincp - no luck.

                        I can log in fine, it's only certain users that are having issues.

                        Comment


                        • #13
                          Is there anywhere I can get an emergency technician to pop the hood on this thing and fix the problem?

                          Comment


                          • #14
                            You may put in a support ticket. However since it is the end of the work day here, I don't know how quick they can be. When they do get around to looking at your site, they will want to be able to disable all your plugins and use a default style and all default files in order to look into the problem.

                            Please don't PM or VM me for support - I only help out in the threads.
                            vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                            Want help modifying your vbulletin forum? Head on over to vbulletin.org
                            If I post CSS and you don't know where it goes, throw it into the additional.css template.

                            W3Schools &lt;- awesome site for html/css help

                            Comment


                            • #15
                              Ok, thanks Lynne.

                              Can you give me instructions on how to do that?

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X