Announcement

Collapse
No announcement yet.

CMS Major Issue!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • roller
    replied
    Originally posted by roller View Post
    Is this still the case? I want my users to be able to publish content, but I don't want them to be able to edit other's content.
    FWIW, I upgraded to 4.0.6 tonight and it doesn't seem to have addressed this issue.

    This is a pretty serious issue. Shall I start a ticket?

    Leave a comment:


  • roller
    replied
    Originally posted by Dennis Kaczor View Post
    No problem for shouting, you are just advising this is a bad idea and I understand, I only had set that for the admin only and no others. I placed a support ticket on this and it was resolved some time last night and here is a copy of that message, so that if any others have the same issue could get their issues resolved as well.



    You gave those usergroups the Can publish, which gives them access to the other permissions as well. At this time permissions are inclusive of others.

    As for why they can't see the page: Show on Section widget is set to no, this is currently asking if you want to hide the page.


    Zachery Woods
    Is this still the case? I want my users to be able to publish content, but I don't want them to be able to edit other's content.

    Leave a comment:


  • nakedanvil
    replied
    I've had to go through the cycle twice before (don't understand that), clear cms cache, log out, log in as user, clear browser cache. It will work.

    Leave a comment:


  • Fun and Bliss
    replied
    I tried it, but no changes

    Leave a comment:


  • nakedanvil
    replied
    Go to adminCP > cms permissions and set them as you need.

    Leave a comment:


  • Fun and Bliss
    replied
    On the front page of my forums 'Home Page' - any registered member can edit as there is still the edit option avaliable (the pencil) and there is also the same edit option for each article. How do I lock these areas down to view only access?

    Leave a comment:


  • Fun and Bliss
    replied
    Hi Wayne,

    On my site www.funandbliss.com, am facing the same problem, here any registered member can edit any article (and may do the admin role) as can move the mouse over the EDIT Pencil and edit any article.

    Leave a comment:


  • Carly1
    replied
    I was having the same problem. I was sure the articles were set as published. I had ticked the Publish option when I first created it, I am 100% positive of that.

    Turns out, when I went in to double check it, the toggle was set to No for Published, and setting it to Yes immediately fixed the problem.

    I would triple check.

    Leave a comment:


  • Dennis Kaczor
    replied
    There was no link at all, just follow thesre instructions that they gave me that they had found. On the CMS page, click on the root Edit Pencil, and look for the radio button that is underlined below, that was part of the problem. The below listed fixed my problems and I hope that this will correct your issue.

    You gave those usergroups the Can publish, which gives them access to the other permissions as well. At this time permissions are inclusive of others.

    As for why they can't see the page: Show on Section widget is set to no, this is currently asking if you want to hide the page.

    Leave a comment:


  • freestyle
    replied
    That link seems to be gone... Can you redirect us?
    Originally posted by Dennis Kaczor View Post
    I placed a support ticket on this and it was resolved some time last night and here is a copy of that message, so that if any others have the same issue could get their issues resolved as well.

    You gave those usergroups the Can publish, which gives them access to the other permissions as well. At this time permissions are inclusive of others.

    As for why they can't see the page: Show on Section widget is set to no, this is currently asking if you want to hide the page.


    Zachery Woods
    Changing the "show on section widget" made my home page viewable to read only permissions. So that was helpful. However, since the issue has nothing at all to do with widgets, that is an odd choice to house this viewing permission.

    Leave a comment:


  • Dennis Kaczor
    replied
    Originally posted by Edwin Brown View Post
    Are you giving everybody HTML access? If so, PLEASE STOP NOW.




    Sorry for shouting. HTML access means that this person can create content that includes raw HTML. Perfect if you want your site to be known as the place to go to create an XSS attack, bad idea otherwise. See http://www.vbulletin.com/forum/entry.php?2408-v403-CMS-Permissions

    Actually, reading back over your post you describe exactly what I would expect if you never published your content. I may have missed it, but I didn't notice any questions about published status. Please could you verify that both the sections and articles are published with dates in the past (at least one second ago)? If you have released content there is no reason why normal users need more than "read", and in v403 "download". If they do something is misconfigured.
    No problem for shouting, you are just advising this is a bad idea and I understand, I only had set that for the admin only and no others. I placed a support ticket on this and it was resolved some time last night and here is a copy of that message, so that if any others have the same issue could get their issues resolved as well.



    You gave those usergroups the Can publish, which gives them access to the other permissions as well. At this time permissions are inclusive of others.

    As for why they can't see the page: Show on Section widget is set to no, this is currently asking if you want to hide the page.


    Zachery Woods

    Leave a comment:


  • Edwin Brown
    replied
    Are you giving everybody HTML access? If so, PLEASE STOP NOW.




    Sorry for shouting. HTML access means that this person can create content that includes raw HTML. Perfect if you want your site to be known as the place to go to create an XSS attack, bad idea otherwise. See http://www.vbulletin.com/forum/entry.php?2408-v403-CMS-Permissions

    Actually, reading back over your post you describe exactly what I would expect if you never published your content. I may have missed it, but I didn't notice any questions about published status. Please could you verify that both the sections and articles are published with dates in the past (at least one second ago)? If you have released content there is no reason why normal users need more than "read", and in v403 "download". If they do something is misconfigured.

    Leave a comment:


  • Dennis Kaczor
    replied
    Originally posted by Wayne Luke View Post
    You should open a support ticket then so we can get access to your site and see what the problem is. I cannot recreate this issue on a clean installation.
    Thanks Wayne, I will try a few other things on the system first and if these don't work I will open a ticket on this. It sure is a strange one for me.

    Dennis

    Leave a comment:


  • Dennis Kaczor
    replied
    Originally posted by freestyle View Post
    I did assume the last column was the HTML column... you're right there.

    But the bug I described is definitely there, and I'm not sure how it manifests itself... For instance, you have "Can publish" checked for UNregistered / Not logged in users. I can see that having the same effect and allowing everyone to have complete editor controls on your content. I haven't tested it, but "can publish" might cause the same behavior as "can use html" as far as this editing bug goes.

    And I know what you mean about the rest... I have the same issue. Right now I am in testing and I have Moderators set to "Can Read" ONLY... And guess what? They can't read the home page.... but they can link to all the subsections... I'm going to review what Wayne Luke said and see if my section is considered unpublished or not... maybe that will solve that part of the issue.
    I agree, just cannot seem to rectify why I need can publish to get the users to see the page, and than this opens a whole can a worms for the CMS page, and again why does everyone have access to the articles, there sure is a problem witn this software. But the biggest problem is gettiing help for these issues, I have spent 2 days looking for fixes on here and on my system and keep having the same old thing happen.

    Thanks

    Dennis

    Leave a comment:


  • Wayne Luke
    replied
    You should open a support ticket then so we can get access to your site and see what the problem is. I cannot recreate this issue on a clean installation.

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X