Announcement

Collapse
No announcement yet.

CMS Major Issue!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by Wayne Luke View Post
    You should open a support ticket then so we can get access to your site and see what the problem is. I cannot recreate this issue on a clean installation.
    Thanks Wayne, I will try a few other things on the system first and if these don't work I will open a ticket on this. It sure is a strange one for me.

    Dennis

    Comment


    • #17
      Are you giving everybody HTML access? If so, PLEASE STOP NOW.




      Sorry for shouting. HTML access means that this person can create content that includes raw HTML. Perfect if you want your site to be known as the place to go to create an XSS attack, bad idea otherwise. See http://www.vbulletin.com/forum/entry.php?2408-v403-CMS-Permissions

      Actually, reading back over your post you describe exactly what I would expect if you never published your content. I may have missed it, but I didn't notice any questions about published status. Please could you verify that both the sections and articles are published with dates in the past (at least one second ago)? If you have released content there is no reason why normal users need more than "read", and in v403 "download". If they do something is misconfigured.
      Please- I'm not tech support. Don't send your problem reports to me unless I've asked you to.

      Comment


      • #18
        Originally posted by Edwin Brown View Post
        Are you giving everybody HTML access? If so, PLEASE STOP NOW.




        Sorry for shouting. HTML access means that this person can create content that includes raw HTML. Perfect if you want your site to be known as the place to go to create an XSS attack, bad idea otherwise. See http://www.vbulletin.com/forum/entry.php?2408-v403-CMS-Permissions

        Actually, reading back over your post you describe exactly what I would expect if you never published your content. I may have missed it, but I didn't notice any questions about published status. Please could you verify that both the sections and articles are published with dates in the past (at least one second ago)? If you have released content there is no reason why normal users need more than "read", and in v403 "download". If they do something is misconfigured.
        No problem for shouting, you are just advising this is a bad idea and I understand, I only had set that for the admin only and no others. I placed a support ticket on this and it was resolved some time last night and here is a copy of that message, so that if any others have the same issue could get their issues resolved as well.



        You gave those usergroups the Can publish, which gives them access to the other permissions as well. At this time permissions are inclusive of others.

        As for why they can't see the page: Show on Section widget is set to no, this is currently asking if you want to hide the page.


        Zachery Woods

        Comment


        • #19
          That link seems to be gone... Can you redirect us?
          Originally posted by Dennis Kaczor View Post
          I placed a support ticket on this and it was resolved some time last night and here is a copy of that message, so that if any others have the same issue could get their issues resolved as well.

          You gave those usergroups the Can publish, which gives them access to the other permissions as well. At this time permissions are inclusive of others.

          As for why they can't see the page: Show on Section widget is set to no, this is currently asking if you want to hide the page.


          Zachery Woods
          Changing the "show on section widget" made my home page viewable to read only permissions. So that was helpful. However, since the issue has nothing at all to do with widgets, that is an odd choice to house this viewing permission.
          ...

          Comment


          • #20
            There was no link at all, just follow thesre instructions that they gave me that they had found. On the CMS page, click on the root Edit Pencil, and look for the radio button that is underlined below, that was part of the problem. The below listed fixed my problems and I hope that this will correct your issue.

            You gave those usergroups the Can publish, which gives them access to the other permissions as well. At this time permissions are inclusive of others.

            As for why they can't see the page: Show on Section widget is set to no, this is currently asking if you want to hide the page.

            Comment


            • #21
              I was having the same problem. I was sure the articles were set as published. I had ticked the Publish option when I first created it, I am 100% positive of that.

              Turns out, when I went in to double check it, the toggle was set to No for Published, and setting it to Yes immediately fixed the problem.

              I would triple check.

              Comment


              • #22
                Hi Wayne,

                On my site www.funandbliss.com, am facing the same problem, here any registered member can edit any article (and may do the admin role) as can move the mouse over the EDIT Pencil and edit any article.

                Comment


                • #23
                  On the front page of my forums 'Home Page' - any registered member can edit as there is still the edit option avaliable (the pencil) and there is also the same edit option for each article. How do I lock these areas down to view only access?

                  Comment


                  • #24
                    Go to adminCP > cms permissions and set them as you need.

                    Comment


                    • #25
                      I tried it, but no changes

                      Comment


                      • #26
                        I've had to go through the cycle twice before (don't understand that), clear cms cache, log out, log in as user, clear browser cache. It will work.

                        Comment


                        • #27
                          Originally posted by Dennis Kaczor View Post
                          No problem for shouting, you are just advising this is a bad idea and I understand, I only had set that for the admin only and no others. I placed a support ticket on this and it was resolved some time last night and here is a copy of that message, so that if any others have the same issue could get their issues resolved as well.



                          You gave those usergroups the Can publish, which gives them access to the other permissions as well. At this time permissions are inclusive of others.

                          As for why they can't see the page: Show on Section widget is set to no, this is currently asking if you want to hide the page.


                          Zachery Woods
                          Is this still the case? I want my users to be able to publish content, but I don't want them to be able to edit other's content.

                          Comment


                          • #28
                            Originally posted by roller View Post
                            Is this still the case? I want my users to be able to publish content, but I don't want them to be able to edit other's content.
                            FWIW, I upgraded to 4.0.6 tonight and it doesn't seem to have addressed this issue.

                            This is a pretty serious issue. Shall I start a ticket?

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X