Announcement

Collapse
No announcement yet.

Recurring Issue: Some users must "click to another page" to show as logged in

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • RobMc
    replied
    Hey All ... want you to know that I was having this EXACT problem as described in the original post on www.planedomain.net . The problem never happened to me (i.e. the developer) and I could not reproduce it. But my client had the problem and I witnessed it as his residence. Came home found this post and it resolved the problem.

    Went in and set cookie domain to ".planedomain.net" and it resolved the issue.

    Thanks to Fifth Dimension for the thorough reply.

    Leave a comment:


  • Dudley
    replied
    I deleted the cookies from my site and was able to get to the AdminCP. Resolved.

    Leave a comment:


  • Dudley
    replied
    Originally posted by Fifth Dimension View Post
    Hi. I faced this issue last night. Did you build your site on a slightly modified domain than from which your users maybe accessing the site? Or have it running on two domains?

    For instance -- is your domain "http://vbulletin.com" and "http://www.vbulletin.com"? If so, you may need to go into Admin CP -> Settings - > Options - > Cookies and HTTP Header Options.

    Here, look through the two settings: Path to Save Cookies and Cookie Domain. See if there is an option in the drop down menu "Suggested Settings" for both of these. If there is, then this is likely your culprit. Go ahead and change those to the suggested settings. It will likely be ".yourwebsite.tld". So if your website were to be http://vbulletin.com for instance, it would say ".vbulletin.com." Or if it were "http"//vbulletin.org", then it would say ".vbulletin.org". Anyway, if it does show a suggested option for Path to Save cookies, go ahead and do that. If it shows something similar for "cookie domain", go ahead and do that also. Click Save Settings, Ok, Confirm, etc and that should help.

    If it doesn't show that, then sorry don't have any other ideas. Maybe someone else does.
    I was having this same problem so I followed your instructions and it appears to have solved the IE login issue, however I can not access my AdminCP now? It confirms that it is logging me in, but takes me right back to the login screen after I get the "thank you for logging in Webmaster"

    The only setting I changed was the Cookie Domain because it had a second option under "suggested settings".... The cookie path I left as /

    Any ideas? Thanks in advance.

    Leave a comment:


  • Ted S
    replied
    Thank you for the suggestion. I did indeed build on a development domain and have a suggestion option other than blank which I will try (no path option however). Thanks!

    Leave a comment:


  • Fifth Dimension
    replied
    Hi. I faced this issue last night. Did you build your site on a slightly modified domain than from which your users maybe accessing the site? Or have it running on two domains?

    For instance -- is your domain "http://vbulletin.com" and "http://www.vbulletin.com"? If so, you may need to go into Admin CP -> Settings - > Options - > Cookies and HTTP Header Options.

    Here, look through the two settings: Path to Save Cookies and Cookie Domain. See if there is an option in the drop down menu "Suggested Settings" for both of these. If there is, then this is likely your culprit. Go ahead and change those to the suggested settings. It will likely be ".yourwebsite.tld". So if your website were to be http://vbulletin.com for instance, it would say ".vbulletin.com." Or if it were "http"//vbulletin.org", then it would say ".vbulletin.org". Anyway, if it does show a suggested option for Path to Save cookies, go ahead and do that. If it shows something similar for "cookie domain", go ahead and do that also. Click Save Settings, Ok, Confirm, etc and that should help.

    If it doesn't show that, then sorry don't have any other ideas. Maybe someone else does.

    Leave a comment:


  • Recurring Issue: Some users must "click to another page" to show as logged in

    I am have a strange but very persistent issue where some users, after logging in are returned back to the homepage or other page and show up as not logged in (they have the login boxes). However after clicking on any link they are all set as logged in as if the cookie had not yet "set".

    This issue has been reported by people on different machines many of whom have cleared all settings/ cookies and rebooted.

    It does not happen to everyone and is not browser dependant -- a user with IE 8 has the issue while I do not have it in IE 8. Another has it at work but not at home, etc.

    Mods have been disabled, styles set to default to test but it persists for a fraction (10% or less reported) of users.

    Test @ www.divematrix.com (default style is 24)
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X