Announcement

Collapse
No announcement yet.

"The service is unavailable." Unknown error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by misterwaterfalli View Post
    So that information should be automatically pulled for us?
    Yes. That's what the $ variable is doing.

    $username, $password - these are calling the entries from your config.php file.
    $servername:$port - also coming from your config.php.
    To be updated...

    Comment


    • #17
      It seems to me like they arent pulling anything. When I go through the steps in the install script to connect to the database, its telling me I dont have permission to connect to the server. It then sas please confirm the values in the config file, after it had already verified this and is claiming that it is in the class_core.php file

      Comment


      • #18
        Well, sounds like you have a problem connecting to your database. There's not much else to tell, there's something wrong with your config.php or your permissions to access your server.

        You may want to setup a support ticket with vBulletin Staff to get a closer look at your system. Either way, I can say for sure, that the code used class_core.php works as it's intended.
        To be updated...

        Comment


        • #19
          we are now incurring this problem:
          Invalid SQL:

          CREATE TABLE access (
          userid INT UNSIGNED NOT NULL DEFAULT '0',
          forumid SMALLINT UNSIGNED NOT NULL DEFAULT '0',
          accessmask SMALLINT UNSIGNED NOT NULL DEFAULT '0',
          PRIMARY KEY userid (userid, forumid)
          );

          MySQL Error : Table 'access' already exists
          Error Number : 1050
          Request Date : Tuesday, March 16th 2010 @ 11:11:34 AM
          Error Date : Tuesday, March 16th 2010 @ 11:11:34 AM

          Comment


          • #20
            We are now in the process of clearing our database and re-uploading everything. The tech that we spoke to seems to think this is the right move. Any help as to where as the .sql file is? we were told that we need to rename this file as our database name, but I can not locate it in the vBulliten suite.

            Comment


            • #21
              any help on this?

              Comment


              • #22
                Why are you reinstalling your site over the existing database?!
                Vote for:

                - *Admin Settable Paid Subscription Reminder Timeframe*
                -
                *PM - Add ability to reply to originator only*
                - Add Admin ability to auto-subscribe users to specific channel(s)
                - "Quick Route" Interface...

                Comment


                • #23
                  Originally posted by Trevor Hannant View Post
                  Why are you reinstalling your site over the existing database?!
                  I was told that this would be the easiest way. I did back up my old database, but the error that we were getting told me that I had effectively 2 databases set up. I was going to wipe everything, and try re uploading all the files after clearing the old database

                  Comment


                  • #24
                    Clearing the database won't work - you need to delete all the tables.

                    I assume this is a new install rather than an upgrade?
                    Vote for:

                    - *Admin Settable Paid Subscription Reminder Timeframe*
                    -
                    *PM - Add ability to reply to originator only*
                    - Add Admin ability to auto-subscribe users to specific channel(s)
                    - "Quick Route" Interface...

                    Comment


                    • #25
                      Originally posted by Trevor Hannant View Post
                      Clearing the database won't work - you need to delete all the tables.

                      I assume this is a new install rather than an upgrade?
                      correct, its a new install

                      Comment


                      • #26
                        any other help? i tried deleting the database and it didnt really get me anywhere. I am restoring it currently to give it another try

                        Comment


                        • #27
                          Originally posted by misterwaterfalli View Post
                          So that information should be automatically pulled for us?
                          Assuming you have actually entered the required values into config.php (and renaming it from config.php.new to config.php) then uploaded it to /includes/, then yes.
                          My Live vB5 Site - NZEating.com
                          vBulletin Hosting | vBulletin Services - Need hosting for your vB? Need it installed? Something else? Let me take that hassle off your hands.

                          Comment


                          • #28
                            I think we have figured out that problem, now I am just wondering how to get the database issue figured out. I looked through the manual and did a search on mysql issues but I didn't find any useful information

                            Comment


                            • #29
                              Originally posted by misterwaterfalli View Post
                              I think we have figured out that problem, now I am just wondering how to get the database issue figured out. I looked through the manual and did a search on mysql issues but I didn't find any useful information

                              Try settinging this:
                              $config['Database']['force_sql_mode'] = true;

                              How did you get rid of the Service Unavailable issue? I have the same on a W2008-64 bit install... And it's not a DB thing, as I have another site on the same server connected to the DB and it works fine. Just have to set the server name to "127.0.0.1".

                              Comment


                              • #30
                                Ok, "Service Unavailable" means the database connection is not right. doh!

                                But you also need to have the server name set to 127.0.0.1 and force SQL to be true.

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X