Announcement

Collapse
No announcement yet.

Multiple dots on Attachment-Extensions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Multiple dots on Attachment-Extensions

    Hello,

    on my forum i'm having the problem, that an additional dot is being added to the attachment.
    I've added the type "zip" (not .zip), and when i'm now uploading an archive, it says for example:

    setup_fix..zip

    How can i delete this second dot?

    Thanks and Greetings
    SeToY

    PS: Here's a pic of it in the admincp
    Click image for larger version

Name:	punktpunkt..png
Views:	2
Size:	35.8 KB
ID:	3714939

    When you open it, it says "punktpunkt..png" above the close-button, too.

  • #2
    Is this something that only started after 4.0.2? And it only happens for zip files? You said "I've added the type "zip"", but there should already be a type zip in the Attachment Manager, so I'm a bit confused about that statement.

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools <- awesome site for html/css help

    Comment


    • #3
      Well yeah, sorry. I've not added it. I've edited it.

      I can't say if it's starting with 4.0.2, but it's on vb.com here also. If you upload an attachment (a picture for example) and open it, it says "filename..extension" above the "CLOSE"-Button.

      Here to test:
      Attached Files

      Comment


      • #4
        I would put this in the bug tracker then. Put as much info as possible in there so the devs can reproduce this. I can't get it to do this on my test site (I've only tried 3 different images though), so it isn't happening all the time.

        Please don't PM or VM me for support - I only help out in the threads.
        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
        Want help modifying your vbulletin forum? Head on over to vbulletin.org
        If I post CSS and you don't know where it goes, throw it into the additional.css template.

        W3Schools <- awesome site for html/css help

        Comment


        • #5
          I have the sam problem in my forum (4.0.2). All attachments uploaded by registered users are renamed with an "extra dot" (e.g. image.jpg -> image..jpg). Thumbnails are just shown as question marks.

          Oddly enough, uploads by me as the administrator are not affected and are displayed correctly, without the "extra dot" in the file name.

          Would be great if this bug could be found and fixed.

          Comment


          • #6
            I will second this bug too; and I have it even as an administrator. File names are being written to the database as wpmuspm_beta_2.zip instead of plain text as before.
            Boardoo.com - Hosting, Software, WHMCS Addons, and whole lot more.
            Featuring vBLink :: The vBulletin Integration Suite for WHMCS

            Comment


            • #7
              Yes, i'm having this as an admin, too. Even files uploaded by me are shown with an additional dot.

              Comment


              • #8
                See this bug report - Attachment filenames are messed up in 4.0.2

                Please don't PM or VM me for support - I only help out in the threads.
                vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                Want help modifying your vbulletin forum? Head on over to vbulletin.org
                If I post CSS and you don't know where it goes, throw it into the additional.css template.

                W3Schools <- awesome site for html/css help

                Comment


                • #9
                  Thanky, Lynne!

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X