Announcement

Collapse
No announcement yet.

Removed all plugins and still a fetch_template problem - please help if you can

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Removed all plugins and still a fetch_template problem - please help if you can

    I upgraded to 4.0.2 but I ran into a problem.

    I am getting this message in all of my posts, but no where else.

    Warning
    : fetch_template() calls should be replaced by the vB_Template class. Template name: navbar in [path]/includes/functions.php on line 3893

    Parse error: syntax error, unexpected T_STRING in /usr/local/www/apache22/vhosts/***********.com/upload/showthread.php(2175) : eval()'d code(2) : eval()'d code on line 1

    I have removed all plug-ins and it still exists. Only way to remove it is to disable the hooks in the config file, but then I can't add any plugins.

    I did get a navbar template error when I upgraded and clicked the Address button, but I do not think it fixed it. I forgot to revert the default template when I upgraded. I did follow all the other steps and safe practices.

    Any "next steps" I should be taking?

    Would a clean install fix this?

    Any help is appreciated,

    DM

  • #2
    You say you have deleted all your plugins...

    Delete your products one by one and see what happens. I'd put money on it that that's where the problem is.

    Comment


    • #3
      Originally posted by icarusforde View Post
      You say you have deleted all your plugins...

      Delete your products one by one and see what happens. I'd put money on it that that's where the problem is.
      I would also agree. However a disable should work as well.
      Michael Biddle - Follow me on Twitter!

      Comment


      • #4
        I would also agree. However a disable should work as well.
        Woops, that's what I meant. :P

        However, you will have to delete the ones that don't work. xD

        Comment


        • #5
          Personally I would just disable because you can always upgrade and not lose the data (Should an addon store extra data)
          Michael Biddle - Follow me on Twitter!

          Comment


          • #6
            Thanks for your replies but all plugins/products have been uninstalled which is what confuses me.

            The only way to get rid of the error message is to disable hooks in the config file.

            I am completely perplexed here.

            Comment


            • #7
              That's really odd. Do you have any products that inserted any extra tables in the database? I had one issue once where a chatbox crashed my site, i uninstalled, deleted files, etc, etc - and in the end i had to nuke the actual tables from the database that corresponded to the chatbox...

              If there are, backup your DB and try that - last resort only though

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X