Announcement

Collapse
No announcement yet.

500 internal sever error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] 500 internal sever error

    I keep getting this error its a 500 internal server error it only ever happens on the cms, the forums and blog are unaffected.....

    MySQL Error : Got a packet bigger than 'max_allowed_packet' bytes
    Error Number : 1153
    Request Date : Monday, February 15th 2010 @ 05:45:24 PM
    Error Date : Monday, February 15th 2010 @ 05:45:42 PM
    Script : http://www.site/forum/content.php?38-Forum-Additons
    Referrer : http://www.site/forum/content.php?1-home/addcontent&contenttypeid=30&postid=29857&parentid=1
    IP Address : 87.115.194.178
    Username : RoG GhOsT RV
    Classname : vB_Database
    MySQL Version : 5.0.89-community

    Database error in vBulletin 4.0.1:

    Invalid SQL:

    REPLACE INTO vb_cache
    SET cacheid = 'widget.ae66c4fbcc69ccaea7c7f184807d82f8',
    expires = 1266274224,
    created = 1266273924,
    locktime = 0,
    data = "O:17:\"vB_Search_Results\":10:{s:23:\"\0vB_Search_Results\0user\";O:21:\"vB_Legacy_Curren tUser\":5:{s:14:\"\0*\0attachments\";N;s:16:\"\0*\0hidden_forums\";N;s:22:\"\0*\0unsearcha ble_forums\";N;s:11:\"\0*\0registry\";O:11:\"vB_Registry\":105:{s:9:\"datastore\";O:12:\"v B_Datastore\":5:{s:12:\"defaultitems\";a:13:{i:0;s:7:\"options\";i:1;s:9:\"bitfields\";i:2 ;s:15:\"attachmentcache\";i:3;s:10:\"forumcache\";i:4;s:14:\"usergroupcache\";i:5;s:10:\"s tylecache\";i:6;s:13:\"languagecache\";i:7;s:8:\"products\";i:8;s:10:\"pluginlist\";i:9;s: 4:\"cron\";i:10;s:12:\"profilefield\";i:11;s:9:\"loadcache\";i:12;s:11:\"noticecache\";}s: 8:\"registry\";R:6;s:8:\"dbobject\";O:11:\"vB_Database\":18:{s:9:\"functions\";a:21:{ etc................ there is alot more its like a million characters.....

  • #2
    Mysql is hitting its max_packet_size and it should likely be increased. You can see the max_packet_size when you login to the admincp, I would guess its very tiny like 1mb

    Comment


    • #3
      how do i up the size?

      Comment


      • #4
        If you have a managed server, you can ask your host to do this. If you manage your own then you may need to do this yourself. To do this, edit my.cnf (or my.ini for Windows systems)

        set-variable=max_allowed_packet=xM

        Change it to the size ('x') you want in Megabytes. Restart MySQL after making this change.
        Vote for:

        - *Admin Settable Paid Subscription Reminder Timeframe*
        -
        *PM - Add ability to reply to originator only*
        - Add Admin ability to auto-subscribe users to specific channel(s)
        - Highlight the correct navigation tab when you are on a custom page
        - "Quick Route" Interface...
        - Allow to use custom icons for individual forums

        Comment


        • #5
          I asked the hosting company about this, they said they carnt change it for shared hosting because it runs across the board....

          As soon as i updated to 4.0.2 i havent had a problem, i guess it was something to do with to many querys on the homepage... since its been reduced now, problem sorted..... carnt wait for 4.0.3

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X