Announcement

Collapse
No announcement yet.

Asset Manager - Uploading from website

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Asset Manager - Uploading from website

    We're able to upload images normally (from local PC) just fine. However, whenever you attempt to upload via a website, the following error is received:

    <www.globalaffairs.org>

    The following errors occurred:

    http://d2.stern.de/bilder/stern_5/re...e_735_490.jpg: Upload failed due to failure writing temporary file.
    This is somewhat perplexing since normal uploading works just fine. Any ideas on where to start looking first?
    I drank WHAT?! - Socrates

  • #2
    To de top...
    I drank WHAT?! - Socrates

    Comment


    • #3
      due to failure writing temporary file.
      Seems Like the system can't write in the tmp folder make sure it's have 777 permissions.
      Marco Mamdouh Fahem.
      OUZMind Lead Developers
      vBFoster Lead Developers

      Comment


      • #4
        So why would normal uploads work (from your PC) and uploads from a website not work?
        I drank WHAT?! - Socrates

        Comment


        • #5
          You probably have this checked when you upload from a website - Retrieve remote file and reference locally If you uncheck that box, then the upload will probably be fine. However, your issue is the /tmp directory. vB doesn't have permissions to write to it, so you need to fix that.

          Please don't PM or VM me for support - I only help out in the threads.
          vBulletin Manual & vBulletin 4.0 Code Documentation (API)
          Want help modifying your vbulletin forum? Head on over to vbulletin.org
          If I post CSS and you don't know where it goes, throw it into the additional.css template.

          W3Schools &lt;- awesome site for html/css help

          Comment


          • #6
            I had the same problem til I rectified the image options in the admincp.

            I'd enabled imagemagik, but had refernced the file incorrectly.

            Comment


            • #7
              OK. I still don't understand why a normal upload from the PC would work, yet uploading from a website doesn't.

              And what "tmp" directory needs to be changed? /tmp on the server, /tmp under home, /tmp somewhere else? If it's /tmp at the server level (in other words, the tmp directory at the root level), it's already set to 777.
              I drank WHAT?! - Socrates

              Comment


              • #8
                Look under vboptions > server settings > safe mod enabled? Is it enabled? And then under Safe Moder Temp directory What do you have set there and is is chmod to 777?

                Then there is Maintence > View PHP Info... look for /upload_tmp_dir Is that valid and chmod to 777?

                Please don't PM or VM me for support - I only help out in the threads.
                vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                Want help modifying your vbulletin forum? Head on over to vbulletin.org
                If I post CSS and you don't know where it goes, throw it into the additional.css template.

                W3Schools &lt;- awesome site for html/css help

                Comment


                • #9
                  Originally posted by Lynne View Post
                  Then there is Maintence > View PHP Info... look for /upload_tmp_dir Is that valid and chmod to 777?
                  I have 'none' there. I made a different tmp dir in the VB folder; do I still need the one set in php? I'm having the exact same problem - can upload a file but not link to a remote file.
                  My VB forum: BMWRA

                  Comment


                  • #10
                    Originally posted by Lynne View Post
                    Then there is Maintence > View PHP Info... look for /upload_tmp_dir Is that valid and chmod to 777?
                    Bingo! That was it. It wasn't defined. Much appreciated Lynne.
                    I drank WHAT?! - Socrates

                    Comment


                    • #11
                      Originally posted by AntonLargiader View Post
                      I have 'none' there. I made a different tmp dir in the VB folder; do I still need the one set in php? I'm having the exact same problem - can upload a file but not link to a remote file.
                      You will need to modify php.ini and set the upload_tmp_dir to something like /home/accountname/public_html/tmp and then chmod the directory to 777.
                      I drank WHAT?! - Socrates

                      Comment


                      • #12
                        Done, and it works.

                        So, the 'graphics upload' test really isn't that helpful, if it doesn't detect a problem uploading from a remote site.
                        My VB forum: BMWRA

                        Comment


                        • #13
                          Originally posted by AntonLargiader View Post
                          Done, and it works.

                          So, the 'graphics upload' test really isn't that helpful, if it doesn't detect a problem uploading from a remote site.
                          This may be a good thing to put into the bug tracker as a Suggestion - a new Diagnostic to check uploading from a remote site.

                          Please don't PM or VM me for support - I only help out in the threads.
                          vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                          Want help modifying your vbulletin forum? Head on over to vbulletin.org
                          If I post CSS and you don't know where it goes, throw it into the additional.css template.

                          W3Schools &lt;- awesome site for html/css help

                          Comment


                          • #14
                            That's what had me so perplexed. Normal uploads would work if uploading from a PC, yet remote sites didn't work. One would think it would operate under the same principle. **scratching head**
                            I drank WHAT?! - Socrates

                            Comment


                            • #15
                              This just happened to me on this site.

                              http://www.vbulletin.com/forum/usercp.php
                              ...

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X