Announcement

Collapse
No announcement yet.

Adding poll widget to layout throws database error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Legionary
    replied
    Originally posted by Edwin Brown View Post
    There was a bug on this, and the fix will be in v404.
    Great to hear. Is there any ETA on when 4.04 will be released?

    Leave a comment:


  • Edwin Brown
    replied
    There was a bug on this, and the fix will be in v404.

    Leave a comment:


  • Legionary
    replied
    We are experiencing exactly the same database error in vBulletin Suite 4.0.3. When we remove the poll widget the database error disappear.

    Is there any better solution to this? We would very much like to display polls on our main page.

    Leave a comment:


  • Edwin Brown
    replied
    We saw that v4.01 was making large mysql log files, and we fixed that in 4.02. That's probably the issue.

    Leave a comment:


  • Lynne
    replied
    I would put in a support ticket and perhaps they can recommend something.

    Leave a comment:


  • meissen
    replied
    Nope, nothing. It seems like it's trying to put way too much data into the "data" field which is causing the problem. The text in the "data" field is at least 1mb - my db_errors.log file is a little over 1mb and its just the ONE database error.

    Leave a comment:


  • Lynne
    replied
    That is odd. Is there a more specific error showing up in your mysql error_logs? I really don't have the answer to this one.

    Leave a comment:


  • meissen
    replied
    I have them set a little higher than what it was by default (i think?).

    wait_timeout = 600
    connect_timeout = 600

    It's just weird because like I said normally when I get a MySQL has gone Away error message it takes that whole timeout period - this error was popping up instantly before it was hitting the timeouts.

    Leave a comment:


  • Lynne
    replied
    Could be the connect_timeout or wait_timeout. Do you have access to change these values in my.cnf? Do you know what they are currently set to?

    Leave a comment:


  • meissen
    started a topic [CMS] Adding poll widget to layout throws database error

    Adding poll widget to layout throws database error

    The moment I add the poll widget to my layout, I get a database error:

    Database error in vBulletin 4.0.1:

    Invalid SQL:

    REPLACE INTO cache
    SET cacheid = 'widget.b21d4845a2aff6d77371b2d37704aca3',
    expires = 1265402330,
    created = 1265402030,
    locktime = 0,
    data = "O:17:\"vB_Search_Results\":10:{s:23:\"\0 -trimmed, the e-mail is over 1MB in size from this field...-

    blah blah blah
    MySQL has gone away
    I tried clearing CMS cache multiple times but it wouldn't work. And the funny thing is that it's instantaneous... normally the MySQL has gone away is after a timeout but it instantly pops up with that, no lag. Any ideas?
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X