Announcement

Collapse
No announcement yet.

Google referrals dropped since 4.0.1 upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • colemanitis
    replied
    Update: Analytics is now pulling all my stats! Google referrals are already at 150 for the day! Moving my Analytics code to the footer template fixed the problem. Thanks for everyone's input - it was much appreciated!

    Leave a comment:


  • colemanitis
    replied
    I just updated my Google sitemap file. It was WAY outdated and contained the old URLs, which are now redirects. Hopefully that'll help out. My Analytics account hasn't updated yet, so I still don't know if relocating my Analytics code has helped yet.

    Leave a comment:


  • nforums
    replied
    Originally posted by colemanitis View Post
    Here's my Searh Engine stats. See the drop!

    [ATTACH]42219[/ATTACH]
    If your analytics is functioning properly then the steep drop like that usually means some sort of penalty has been asserted to your domain where you literally lose all your rankings for high traffic keywords. There could be numerous possibilities for this including

    Competing sites overtook you (highly doubtful due to the sudden drop, this would be more casual)
    Google is having serious problems navigating your site (try to get it to validate as close as possible)
    A malformed robots.txt
    Google might not see your site as relevant any more
    Spamming
    Malware infection

    Really the list can go on and on. Hopefully it's a Analytics problem though Can you check your server stat logs and you'd be able to confirm faster.

    Leave a comment:


  • Darkimmortal
    replied
    Originally posted by colemanitis View Post
    I just moved my Analytics code to the Footer template. I had it in an Ad Location template since the upgrade. Maybe that was causing the problem? I'll let you guys know if that helps. It shouldn't take long to notice a difference.
    Could it have been included multiple times?

    Leave a comment:


  • colemanitis
    replied
    I just moved my Analytics code to the Footer template. I had it in an Ad Location template since the upgrade. Maybe that was causing the problem? I'll let you guys know if that helps. It shouldn't take long to notice a difference.

    Leave a comment:


  • colemanitis
    replied
    Here's my Searh Engine stats. See the drop!

    Click image for larger version

Name:	stats_drop.gif
Views:	1
Size:	8.9 KB
ID:	3677844

    Leave a comment:


  • colemanitis
    replied
    Originally posted by Loco.M View Post
    this is an upgrade from what?
    4.0.0 - 4.0.1? or the 3.x series to 4.0
    if it's from 3 to 4 and you changed your url's, that's the main reason traffic has dropped
    4.0.0 to 4.0.1. Didn't experience a problem until I upgraded to 4.0.1.

    Leave a comment:


  • colemanitis
    replied
    No URL structure change. No removal of backlinks. No links to bad sites. No spam on forum. Google has a sitemap.

    I can access my site via Google, it pops up no problem.

    site:http://domain.com returns a TON of results for my forum. All the links work.

    Originally posted by nforums View Post
    did your URL structure change?
    Did people remove backlinks from your site?
    Did you link out to bad sites, or possibly be infected with malware?
    Do you have a bunch of spam?
    Did you compile and submit a sitemap to Google Webmaster Tools?
    Are search engines able to access your site?
    If you do a "site:http://domain.com" but enter your domain, does anything get returned, and if so does clicking on the links returned take you to the page?

    SEO is a funny thing, and no one can really give you any answer with the information you've provided.

    Leave a comment:


  • xsquid
    replied
    I think mine has risen also.

    Leave a comment:


  • Loco.M
    replied
    this is an upgrade from what?
    4.0.0 - 4.0.1? or the 3.x series to 4.0
    if it's from 3 to 4 and you changed your url's, that's the main reason traffic has dropped

    Leave a comment:


  • nforums
    replied
    Originally posted by colemanitis View Post
    Before upgrading to 4.0.1 I was receiving over 300 referrals/day from the Google search engine. Now it's down to around 25 referrals/day. My stats are taking a MAJOR hit because of this. Can somebody help explain why this is happening in 4.0.1? Thanks!
    did your URL structure change?
    Did people remove backlinks from your site?
    Did you link out to bad sites, or possibly be infected with malware?
    Do you have a bunch of spam?
    Did you compile and submit a sitemap to Google Webmaster Tools?
    Are search engines able to access your site?
    If you do a "site:http://domain.com" but enter your domain, does anything get returned, and if so does clicking on the links returned take you to the page?

    SEO is a funny thing, and no one can really give you any answer with the information you've provided.

    Leave a comment:


  • smirkley
    replied
    I have to agree with oddmud myself.

    Leave a comment:


  • oddmud
    replied
    I have not seen any drop in google referral since the upgrade, in fact it's almost risen the average slightly.

    Leave a comment:


  • colemanitis
    replied
    Anyone? I'd really like to get this resolved!

    Leave a comment:


  • colemanitis
    started a topic [Forum] Google referrals dropped since 4.0.1 upgrade

    Google referrals dropped since 4.0.1 upgrade

    Before upgrading to 4.0.1 I was receiving over 300 referrals/day from the Google search engine. Now it's down to around 25 referrals/day. My stats are taking a MAJOR hit because of this. Can somebody help explain why this is happening in 4.0.1? Thanks!
Loading...
Working...
X