Announcement

Collapse
No announcement yet.

Guests can see my Unpublished Articles

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] Guests can see my Unpublished Articles

    That's the problem. When I add a new article, select not published, it goes all the way to the bottom of entries and guests can see it, including the nice red "Not Published" text.

    What do I need to check here?

  • #2
    Bump for help

    Comment


    • #3
      Check the CMS group permissions. Admincp > CMS >CMS Permissions. If that doesn't fix it clear the cache (you shouldn't need to, but...). If that doesn't fix it post a bug. During beta there were several permissions bugs, but to the best of my knowledge those were all fixed in 4.00.
      Please- I'm not tech support. Don't send your problem reports to me unless I've asked you to.

      Comment


      • #4
        I am having exactly same problem. Installed the cms data as a part of new install. The front page shows unpublished data. So tried as edwin suggested.

        Removed all access in the cms permissions for front page section except read only access to all groups and for all other sections, removed all permissions. Cleared the cache..Still shows the unpublished data. Once I removed readonly permissions for front page, it showed no content to display. I hope the readonly permission is needed for the guests ..

        Let me wait for 4.0.1 hope it will be fixed in that.

        Comment


        • #5
          Originally posted by Edwin Brown View Post
          Check the CMS group permissions. Admincp > CMS >CMS Permissions. If that doesn't fix it clear the cache (you shouldn't need to, but...). If that doesn't fix it post a bug. During beta there were several permissions bugs, but to the best of my knowledge those were all fixed in 4.00.
          Hey Edwin,

          Guest permissions allow them to "Read" only, I just checked again. I also cleared CMS cache and nothing changed.

          If you want to check it yourself, just click here and scroll all the way to the bottom of the page (Foro), I made a test article for vbulletin, it's supposed to be published on Feb 1 2010 but doesn't work.
          However, if you click on the title to go to the article itself, it won't let you see it.
          You can also see the beautiful date bug in action. (This page will be published on %01-%b-%2010 %0:%Feb %p )

          So, solutions?

          Comment


          • #6
            I did a bunch of rewrites to permission handling in 4.01, which is currently clearing QA. When that gets out, download it and install. If the permissions issue is still happening, vivamexico please PM me and I'll work with you to fix it.
            Please- I'm not tech support. Don't send your problem reports to me unless I've asked you to.

            Comment


            • #7
              Originally posted by Edwin Brown View Post
              I did a bunch of rewrites to permission handling in 4.01, which is currently clearing QA. When that gets out, download it and install. If the permissions issue is still happening, vivamexico please PM me and I'll work with you to fix it.
              Awesome, thanks Edwin !

              Comment


              • #8
                I've a problem. Guests can't view the content of my cms. How can I fix that?

                Comment


                • #9
                  vBCMS>Permissions
                  Check the permissions for every section you have that you want 'guests' to be able to 'read' and be sure you have the 'read' checked off for 'unregistered/not logged in' usergroup (if you utilize any javascript on anything in that section you'll also need to be sure they can 'use html'.

                  Comment


                  • #10


                    I've this permissions. But there is no change... Thanks

                    Comment


                    • #11
                      did you change the names of any of the vb default usergroups? I'm not sure since I'm not proficient in the language you are using, but I don't see one for 'unregistered/not logged in'... the last one I can see in the image is for moderated users the one above that is for 'users awaiting email confirmation' (I'm guessing) a.... =S

                      you may have to go through every single one of your sections and check to be sure it is checked off and don't forget to 'save permissions settings' before you change sections.
                      Attached Files

                      Comment


                      • #12
                        Ohh... I understand. So the HTML permission means access to the content. Now is working. Thanks for your help!!!

                        Comment


                        • #13
                          Originally posted by DigitalDark View Post
                          Ohh... I understand. So the HTML permission means access to the content. Now is working. Thanks for your help!!!
                          What? No! Guests should only have "Read" access, not HTML posting permissions, careful with that!

                          BTW this original issue was fixed for me with 4.01, so it was probably a bug in 4.00

                          Comment


                          • #14
                            Originally posted by vivamexico55 View Post
                            What? No! Guests should only have "Read" access, not HTML posting permissions, careful with that!

                            BTW this original issue was fixed for me with 4.01, so it was probably a bug in 4.00
                            vB.com staff told me and others in another thread that that setting, 'use html', is for *seeing*/reading that content, NOT for editing or posting.

                            Comment


                            • #15
                              Originally posted by Eq4Bits View Post
                              vB.com staff told me and others in another thread that that setting, 'use html', is for *seeing*/reading that content, NOT for editing or posting.
                              Oh, that's interesting, well then go ahead, I must have misunderstood that option.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X