Announcement

Collapse
No announcement yet.

CMS Usergroup Permissions don't work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by Edwin Brown View Post
    I got access to a site that was having this problem, and at least for that case I understand it. Let me explain.

    In dealing with permissions, the php code uses the id's of each group. You can rename them, but the computer doesn't care. The default installation ships with 7 usergroups, and the php code makes decisions based on those numbers.
    These groups are:
    1- Unregistered / Not Logged In
    2- Registered Users
    3- Users Awaiting Email Confirmation
    4- Users Awaiting Moderation
    5- Super Moderators
    6- Administrators
    7- Moderators

    Those groups are ours. You can rename them. You might not like those names, or you might speak some other language. But that doesn't change how they work. If, for example, you change the name of #1 to "Administrators", then whatever privileges you assign will be available to unregistered/not logged in users.

    So please check your usergroups in the admincp usergroup manager. If these aren't the groups, then rename them back to the above - or whatever you want to use that means the same thing. The verify permissions are correct. If you are having problems after that, then post a bug report.
    So is this not a bug?

    Comment


    • #32
      Originally posted by punchbowl View Post
      So is this not a bug?
      I don't know. If a user can show us that, on their site, something isn't working as designed then it's a bug. I haven't been able to reproduce this, but that means only that I can't reproduce this.
      Please- I'm not tech support. Don't send your problem reports to me unless I've asked you to.

      Comment


      • #33
        Originally posted by Edwin Brown View Post
        You should be able to do that in admincp > CMS > CMS Permissions. I've used that dozens of times, most recently last friday evening. If you've set up permissions properly there and it's not working, please flush the CMS cache. It that doesn't fix it please submit a support ticket.
        The part I bolded is what fixed this for me. I had set the permissions via this page (since all of my users are outside the main 7 groups (subscriptions)), but it was still freaking out and giving the permissions problems. As soon as I cleared the cache it worked as expected.

        Oddly though - I was able to get access to the page by allowing users to "Edit Content" and not clearing the cache. I have no clue if that's to be expected or not.

        Comment


        • #34
          I am having this exact same problem. I didn't change any of the default groups to be something other than what they were meant to be, although I did change the name of one or two of them. I have flushed the CMS cache many times... did not fix the problem.

          Edwin you can look at my site.

          Comment


          • #35
            Originally posted by theda View Post
            I am having this exact same problem. I didn't change any of the default groups to be something other than what they were meant to be, although I did change the name of one or two of them. I have flushed the CMS cache many times... did not fix the problem.

            Edwin you can look at my site.
            I'd be happy to look at your site, but I need to have at least Admincp CMS rights. I can do a lot more if I can run database queries. Please PM me with login parameters, or create a support ticket and PM me the number.
            Please- I'm not tech support. Don't send your problem reports to me unless I've asked you to.

            Comment


            • #36
              Another way to have the content be hidden is to hide it. Note that there is a "hide from section widget" radio button. If you click that, your content will be hidden. In v402 you can hide articles also, and they won't display on section pages at all. You have to then make another way to navigate to those articles. You can embed a link to them in article(s), or you can put them on the subnav. But if you hide content, it will be hidden.
              Please- I'm not tech support. Don't send your problem reports to me unless I've asked you to.

              Comment


              • #37
                permissions don't seem to restrict?

                I have just added a usergroup, called contributing authors added a user to that group and given them permisions to create content but not edit other peoples content, however when I log in as this user they can edit any content??

                pm me if you need access

                Thanks,

                Andy

                Comment


                • #38
                  Originally posted by Edwin Brown View Post
                  You should be able to do that in admincp > CMS > CMS Permissions. I've used that dozens of times, most recently last friday evening. If you've set up permissions properly there and it's not working, please flush the CMS cache. It that doesn't fix it please submit a support ticket.
                  I did all of that and it wasn't working until I turned off the preview option for each article.


                  Now the CMS works inline with what my permission say. Thanks for the help!

                  Comment


                  • #39
                    I've the same problems as the orginal poster - after trying all the suggestions here I've submitted a support ticket with admincp login details.

                    Comment


                    • #40
                      hello ...the bug

                      i have same problam
                      wehen install cms white defult data the permision is work but when install cms without defult data the permision to can read user not wordk and its a big bug

                      Comment


                      • #41
                        Originally posted by yaghoubmortazavi View Post
                        hello ...the bug

                        i have same problam
                        wehen install cms white defult data the permision is work but when install cms without defult data the permision to can read user not wordk and its a big bug
                        Which one? There have been a couple different ones in this thread? And have you read my blog explaining how the new v402 settings work? http://www.vbulletin.com/forum/entry.php?2406-New-Section-Display-Settings&bt=8079#comment8079 So far the issues have all been that they don't understand the display settings. That's not intended as a criticism- we at vBulletin should have, and didn't make it so people didn't have to know. But it is a fact that so far, if you do understand the settings and click the right radio buttons things have been working as designed.
                        Please- I'm not tech support. Don't send your problem reports to me unless I've asked you to.

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X