Announcement

Collapse
No announcement yet.

CMS Usergroup Permissions don't work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    I have just changed the CMS permission for REGISTERED USERS to NOT be able to create content but to no avail. My test user can still go ahead and create articles?

    If this is really a bug (and not some strange combination of permission settings) it seems to me to be a fairly BIG BUG to have in a Gold Release which is claimed to have been extensively tested. This, to me, seems like a very basic issue, and I worry what other bugs might be lurking around.

    I do think things like this should have been ironed out before release for a several hundred dollar piece of software.

    Anyway, will see if I can track/access the bug report mentioned above for results.

    Thanks and hoping this core issue can be quickly resolved!

    Comment


    • #17
      Originally posted by Edwin Brown View Post
      I got access to a site that was having this problem, and at least for that case I understand it. Let me explain.

      In dealing with permissions, the php code uses the id's of each group. You can rename them, but the computer doesn't care. The default installation ships with 7 usergroups, and the php code makes decisions based on those numbers. These groups are:
      1- Unregistered / Not Logged In
      2- Registered Users
      3- Users Awaiting Email Confirmation
      4- Users Awaiting Moderation
      5- Super Moderators
      6- Administrators
      7- Moderators

      Those groups are ours. You can rename them. You might not like those names, or you might speak some other language. But that doesn't change how they work. If, for example, you change the name of #1 to "Administrators", then whatever privileges you assign will be available to unregistered/not logged in users.

      So please check your usergroups in the admincp usergroup manager. If these aren't the groups, then rename them back to the above - or whatever you want to use that means the same thing. The verify permissions are correct. If you are having problems after that, then post a bug report.
      This explains why my solution of moving everyone back to a registered usergroup fixed things. What about custom registered usergroups?

      This behavior is broken? Is it going to stay this way?

      Comment


      • #18
        The seven groups above have very specific meanings, and the php code works with those meanings. So, for example, the "Unregistered/Not Logged In" user means that we don't know who they are. How could there be two different sets of permissions for someone we don't know anything about? Yes, they could be anybody, but because we don't know who they are we have to treat them according to the rules we've defined for "I-don't-know-who-you-are".

        You can make your own user groups, and assign people to them, and assign rights to those people, and CMS will enforce those rights.

        Can you explain how this behavior is broken, and in what way you expect it to behave differently?
        Please- I'm not tech support. Don't send your problem reports to me unless I've asked you to.

        Comment


        • #19
          Originally posted by Edwin Brown View Post
          You can make your own user groups, and assign people to them, and assign rights to those people, and CMS will enforce those rights.

          Can you explain how this behavior is broken, and in what way you expect it to behave differently?
          Hi Edwin, thanks! Yes, I mean that for me this behavior was broken after the upgrade, because I had a registered usergroup who couldn't do anything, but it was a custom usergroup based on the registered usergroup permissions. So as I said, my solution was to revert them all back to a default registered usergroup and then create a new one with their regular special permissions.

          I should've probably said it was a bug? I imagine in some cases custom usergroups aren't properly receiving permissions for some reason after an upgrade, if you look around the forum it seems to happen sometimes. For me, this didn't happen with other usergroups, just with one.

          Comment


          • #20
            yep, same issue here. It's a bug.

            Comment


            • #21
              Same here. I upgraded to 4.0 from 3.8ish versus a clean install.

              I never changed any of the names or positions of any of my default usergroups. I do have custom usergroups but they are all much higher group mumbers... mainly 18-24 area.

              Here's a shot my my admincp:

              http://www.simtechonline.com/temp/vbshot1.jpg





              The test user is only listed as a registered user. This is the msg I get when I try and go to the home page:


              test user, you do not have permission to access this page. This could be due to one of several reasons:
              1. Your user account may not have sufficient privileges to access this page. Are you trying to edit someone else's post, access administrative features or some other privileged system?
              2. If you are trying to post, the administrator may have disabled your account, or it may be awaiting activation.
              Here's my admin permission sheet for CMS permissions:

              http://www.simtechonline.com/temp/vbshot3.jpg

              Comment


              • #22
                UPDATE: The issue appears to be in the home page not being "published". If you are having this problem go to admincp/vbulletin CMS/section manager/ and make sure the page is marked as published. This seems screwy but it works in both Firefox and IE. Not sure why unregistered people have permissions to see unpublished pages though. This seems more of a workaround rather than a fix.

                Comment


                • #23
                  Originally posted by Edwin Brown View Post
                  I got access to a site that was having this problem, and at least for that case I understand it. Let me explain.

                  In dealing with permissions, the php code uses the id's of each group. You can rename them, but the computer doesn't care. The default installation ships with 7 usergroups, and the php code makes decisions based on those numbers. These groups are:
                  1- Unregistered / Not Logged In
                  2- Registered Users
                  3- Users Awaiting Email Confirmation
                  4- Users Awaiting Moderation
                  5- Super Moderators
                  6- Administrators
                  7- Moderators

                  Those groups are ours. You can rename them. You might not like those names, or you might speak some other language. But that doesn't change how they work. If, for example, you change the name of #1 to "Administrators", then whatever privileges you assign will be available to unregistered/not logged in users.

                  So please check your usergroups in the admincp usergroup manager. If these aren't the groups, then rename them back to the above - or whatever you want to use that means the same thing. The verify permissions are correct. If you are having problems after that, then post a bug report.
                  That doesn't really have anything to do with the problem I'm having (as the OP). The "Unregistered" group is able to see the CMS homepage when the permissions are set to deny them.

                  Comment


                  • #24
                    Originally posted by Sau View Post
                    it's the same permission issue, you have it with unregistered, we have it with registered users.
                    Yours is the opposite problem and because of people replying with the opposite problem, my original post is being ignored. Make your own thread for a different problem.

                    Comment


                    • #25
                      Originally posted by shorecogs
                      Here's the screenshot you requested. Also I should note that they can only see the "Home" page. If they click on the other links on the CMS, they don't see the content with the exception of the HTML widget on one of the pages.

                      http://img209.imageshack.us/img209/4...mingcms.th.png
                      Hey shorecogs, I think I have a solution for you. It sounds like you want to prevent unregistered users from seeing the Home page full stop. You want them to get the "You are not logged in" message right? If you go to the unregistered users' Usergroup (under Usergroups tab> Usergroup Manager> Edit Unregistered/Not Logged in Users) and make sure that view forum is ticked to "no", then it will do that.

                      Comment


                      • #26
                        Originally posted by Simtech View Post
                        UPDATE: The issue appears to be in the home page not being "published". If you are having this problem go to admincp/vbulletin CMS/section manager/ and make sure the page is marked as published. This seems screwy but it works in both Firefox and IE. Not sure why unregistered people have permissions to see unpublished pages though. This seems more of a workaround rather than a fix.
                        This fixed it for me. Thanks!

                        Comment


                        • #27
                          Want to try Simtech method but cannot find "vbulletin CMS"

                          Comment


                          • #28
                            Originally posted by aberg View Post
                            I have the same problem with CMS Usergroup Permissions.
                            It don't work.
                            Settings as above check, but they are ok.
                            So this must be a bug.
                            Please either submit a support ticket and PM me with the number, or PM me with a login that has access to CMS admin and CMS permissions admin. We've done a lot of testing, and I'm not aware of any permissions issues in the last six weeks or so.
                            Please- I'm not tech support. Don't send your problem reports to me unless I've asked you to.

                            Comment


                            • #29
                              Originally posted by Simtech View Post
                              UPDATE: The issue appears to be in the home page not being "published". If you are having this problem go to admincp/vbulletin CMS/section manager/ and make sure the page is marked as published. This seems screwy but it works in both Firefox and IE. Not sure why unregistered people have permissions to see unpublished pages though. This seems more of a workaround rather than a fix.
                              I was having the opposite problem until I did the above, which solves half of the issue (Only admin could view content). However I want what the OP has said. I would like to block the content so that only registered members and higher have at least read access. I have the default 7 usergroups.

                              Comment


                              • #30
                                Originally posted by enitnessel View Post
                                I was having the opposite problem until I did the above, which solves half of the issue (Only admin could view content). However I want what the OP has said. I would like to block the content so that only registered members and higher have at least read access. I have the default 7 usergroups.
                                You should be able to do that in admincp > CMS > CMS Permissions. I've used that dozens of times, most recently last friday evening. If you've set up permissions properly there and it's not working, please flush the CMS cache. It that doesn't fix it please submit a support ticket.
                                Please- I'm not tech support. Don't send your problem reports to me unless I've asked you to.

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X