Announcement

Collapse
No announcement yet.

rss feed duplicate problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Drake Splinter
    replied
    I'm having the same problem with the duplicate rss posts. I've had to set mine into 'moderation' mode so I can at least screen what is being posted. Since installing, it has reposted the same 4 items about 5 times. The feed is coming from my own site (the image gallery), so I know it is not the content publisher making changes.

    Have there been any updates regarding this issue?

    Leave a comment:


  • understated
    replied
    The duplicate feeds have resumed. I have verified they are exact copies by pasting the entire text into a ctrl-f field on the suspect duplicate. It finds the whole post not surprisingly.

    Leave a comment:


  • understated
    replied
    Thanks again for the reply.

    On the topic of the upgrade script: I had the new contents of the admin and mod folders in the wrong place when I ran the script. Are you saying that I do not need to run it again?

    FYI, I have not seen a duplicate rss post since I moved this stuff to the right place, though it is usually slow (quantity of posts) on weekends. I am optimistic that the problem was solved by the 4.0.2 upgrade, and and then doing it right...

    Leave a comment:


  • Trevor Hannant
    replied
    If you're re-uploading the files, you don't need to run the upgrade script as the relevant database changes etc will already have been made. The upgrade script is only to move onto another version.

    Sorry, I haven't seen this error before and can't replicate it on any of my own test forums. If the above doesn't work, please submit a support ticket for my attention and include all the relevant login info in the Sensitive Details box and I'll take a look at it directly.

    Leave a comment:


  • understated
    replied
    Trevor,

    When I first ran the diagnostic, I had innumerable problems. Upon re-reading your post, I realized that I had changed both the modcp and admincp folder names to slow down the baddies a bit--moving all the contents solved all those issues except one...

    The only file that has a non-expected contents message now is one called "blank.html"
    There are another four that are parts of my four plug-ins, everything else is okay.

    I will reupload this one file if necessary, but I am extremely hesitant to overwrite the whole works yet again because I am still fixing the fallout from our 4.0.2 upgrade--it did not go smoothly. I shiver at the notion of running the upgrade script again as well.

    I can appreciate your suggesting the shotgun approach because it is most efficient for you, but I am not on board with it. Have you had any developments or other similar reports since your post of ten days prior?

    Thank You

    Leave a comment:


  • kat00
    replied
    I'm not sure its a fix mate and not much elaboration required. In the search items for words box I am limiting it to only one word for a search, when my duplicated threads were occuring I had serveral words in that box, now I have several different one word searches. Mmy feeds are fairly limited and I probably only see a feed once a week, that is why I am not convinced its a fix.

    It is incredibly curious that my duplicated posts also started on 08/02 as well and I have a different source to you.

    Leave a comment:


  • mikec_nvnews
    replied
    Originally posted by kat00 View Post
    I'm not the only one then.

    I think I have stopped mine from duplicating by putting only one search word for each feed.
    Can you elaborate on this fix?

    Leave a comment:


  • mikec_nvnews
    replied
    No plugins and I've re-created the RSS feed to no avail. I've turned the feed on temporarily so folks can appreciate how messy this situation is:

    http://www.nvnews.net/vbulletin/forumdisplay.php?f=61

    The source of the feed is here.

    http://www.google.com/reader/shared/...google/starred

    Update: Note that feeds posted prior to 2/8/2010 were never duplicated. Wow, what a mess the News Headline forum is already
    Last edited by mikec_nvnews; Fri 12 Feb '10, 6:36am.

    Leave a comment:


  • kat00
    replied
    I'm not the only one then.

    I think I have stopped mine from duplicating by putting only one search word for each feed.

    Leave a comment:


  • Trevor Hannant
    replied
    Are these on new installs or upgraded sites?

    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Also, try deleting all RSS feeds from the RSS Feed Manager and recreate them.

    Do you have the same problem?

    Leave a comment:


  • understated
    replied
    Same problem here. It is not every item in the feed, and does not happen every time. It does occur in more than one feed, though the only correlation I can find is that of the more active feed being more susceptible to duplication. My first suspicion was that of minor edits being made by the source--not so; something else is at work here.

    On an unrelated note, at least no one has made a snarky retort admonishing anyone to use the search feature...yet.

    Leave a comment:


  • mikec_nvnews
    replied
    It's suprising that I'm replying to my own post, but I would like to get to the bottom of what is causing the duplicate RSS news posts. If someone on the vBulletin staff is willing to investigate this matter, I will gladly provide assistance.

    I am determined to find the cause and will ensure that this thread remains relavant until this issue is resolved.
    Last edited by mikec_nvnews; Wed 10 Feb '10, 3:38pm.

    Leave a comment:


  • mikec_nvnews
    replied
    I enabled an RSS feed a few months ago and started receiving duplicate posts last week. There were so many duplicate postings that I had to disable the feed.

    When using the preview feed under the edit RSS feed in the vBulletin control panel, the feed looks fine. The source of the feed also looks fine:

    http://www.google.com/reader/public/...ogle%2Fstarred

    Bummer...

    Posted in wrong forum. Please move to the vBulletin 3.7 Questions, Problems and Troubleshooting forum.
    Last edited by mikec_nvnews; Wed 10 Feb '10, 7:55am.

    Leave a comment:


  • SemperFideles
    replied
    Same problem here.

    Does the vBulletin staff read and respond to posts here? I've noticed that I've posted a few questions that have never received any attention. I have to rely more on vBulletin.org. I guess I'll check over there too.

    Leave a comment:


  • maximutt
    replied
    I've noticed a few duplicate posts as well.

    This should be reported as a bug.

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X